#opnfv-testperf: Testperf Weekly Meeting 20180614

Meeting started by gabriel_yuyang at 15:02:53 UTC (full logs).

Meeting summary

  1. Roll Call (gabriel_yuyang, 15:04:08)
    1. Cédric Ollivier (ollivier, 15:04:19)
    2. Gabriel Yu (gabriel_yuyang, 15:04:20)
    3. Rex (mj_rex, 15:04:32)
    4. Georg Kunz (phone only from now on) (georgk, 15:04:35)
    5. Emma Foley (efoley, 15:04:39)

  2. Brief report of ETSI plugtest/OPNFV Plugfest (gabriel_yuyang, 15:04:55)
    1. Bottlenecks only test Compass in Plugtest (gabriel_yuyang, 15:07:43)
    2. 1st release scope of Dovetail was run on different platforms (gabriel_yuyang, 15:08:42)
    3. some issues need to be solved and good opportunity to test commercial products (gabriel_yuyang, 15:09:25)
    4. https://etherpad.opnfv.org/p/minum_test_sets_gating_cd (gabriel_yuyang, 15:12:12)
    5. there were discussions and refinements of requirements for the CD release (efoley, 15:12:35)
    6. Developer gate should consider tempest/rally tests instead of healthcheck, which depends on SNAPS. (efoley, 15:15:43)
    7. Al Morton (acm, 15:18:31)
    8. http://testresults.opnfv.org/functest/gambiachallenges/ (ollivier, 15:19:41)
    9. http://testresults.opnfv.org/functest/gates/ (ollivier, 15:20:43)
    10. https://etherpad.opnfv.org/p/minum_test_sets_gating_cd (ollivier, 15:21:28)
    11. https://etherpad.opnfv.org/p/minum_test_sets_gating_cd (efoley, 15:21:30)
    12. functest need to sync the requirements from different feature projects, (gabriel_yuyang, 15:24:45)
    13. run functest multiple times in a row and the current CI should run all the functest tests for gating purpose (gabriel_yuyang, 15:28:28)
    14. unit test is not enough for verifying testing framework (mj_rex, 15:34:51)
    15. for test framework, first to introduce reference platform, then, funtional gates should be introduced - Cedric (gabriel_yuyang, 15:42:16)
    16. https://wiki.opnfv.org/display/INF/Improving+CI+for+Test+Projects (mj_rex, 15:43:28)

  3. TestAPI & TestDB Issues (gabriel_yuyang, 15:45:09)
    1. 1) login swagger, can not modify test cases/test items; 2) can not login to test reporting page (gabriel_yuyang, 15:47:47)
    2. swagger page does not allow any operation of modifying test cases (gabriel_yuyang, 15:49:22)
    3. linux account does not work again for TestAPI page (gabriel_yuyang, 15:52:56)
    4. https://gerrit.opnfv.org/gerrit/#/c/58455/ (bramwelt, 15:53:02)
    5. testapi webpage: http://testresults.opnfv.org/test/ (SerenaFeng, 15:53:19)
    6. ACTION: Serena will fix the linux account issue for TestAPI page (gabriel_yuyang, 15:53:21)
    7. more committers for Test reporting, API, ..., releng repos (gabriel_yuyang, 15:58:08)
    8. ACTION: Gabriel asks Jack for gating page and dovetail dashboard jobs (gabriel_yuyang, 16:01:22)
    9. topic in the next Testperf meeting discussing about TestAPI (gabriel_yuyang, 16:06:16)
    10. current agreements are: 1) establish procedure to oversee changes in TestAPI, reporting pages,... 2) include more testing guy as committer (gabriel_yuyang, 16:07:29)


Meeting ended at 16:07:37 UTC (full logs).

Action items

  1. Serena will fix the linux account issue for TestAPI page
  2. Gabriel asks Jack for gating page and dovetail dashboard jobs


People present (lines said)

  1. gabriel_yuyang (25)
  2. ollivier (6)
  3. mj_rex (5)
  4. efoley (4)
  5. collabot_ (4)
  6. acm (2)
  7. SerenaFeng (1)
  8. georgk (1)
  9. bramwelt (1)


Generated by MeetBot 0.1.4.