15:03:06 <gabriel_yuyang> #startmeeting Testperf Weekly Call 20180816
15:03:06 <collabot> Meeting started Thu Aug 16 15:03:06 2018 UTC. The chair is gabriel_yuyang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:06 <collabot> The meeting name has been set to 'testperf_weekly_call_20180816'
15:03:16 <gabriel_yuyang> #topic Roll Call
15:03:22 <gabriel_yuyang> #info Gabriel Yu
15:03:23 <mbeierl> #info Mark Beierl
15:03:24 <efoley> #info Emma Foley
15:03:33 <mj_rex> #info Rex
15:03:49 <gabriel_yuyang> #topic Test results mgnt for testing projects
15:06:51 <gabriel_yuyang> #info VSPERF has issues getting test results displayed in TestAPI and would like to discuss about the DB for test results
15:07:17 <gabriel_yuyang> #info VSPERF also want put time series data into DB for later analysis
15:08:17 <mbeierl> #info Issues with TestAPI should be raised in RELENG project
15:08:31 <gabriel_yuyang> #info Now testing projects have their own support data bases, i.e., basically 4 kinds of dbs
15:11:57 <gabriel_yuyang> #info Mark suggest to discuss it in TSC and Releng to make the situation better
15:12:36 <mbeierl> #link http://testresults.opnfv.org/fraser/functest/status-apex.html For Functest
15:13:16 <gabriel_yuyang> #link http://testresults.opnfv.org/test/#/results
15:13:24 <mbeierl> #link http://testresults.opnfv.org/fraser/vsperf/reporting.html
15:15:04 <mbeierl> #info http://testresults.opnfv.org/master/vsperf/reporting.html reports 404 but fraser does work.
15:17:53 <gabriel_yuyang> http://testresults.opnfv.org/test/#/results
15:19:24 <mbeierl> #link http://testresults.opnfv.org/test/api/v1/results?project=vsperf&period=2 shows that results are populated
15:19:38 <mbeierl> #info The dashboard is giving 404 and that is the issue
15:22:10 <mbeierl> #info the git repo for the dashboard is here: https://github.com/opnfv/releng-testresults
15:22:13 <gabriel_yuyang> #info The results are in the testDB, but not displayed in the TestAPI
15:23:56 <gabriel_yuyang> #action Gabriel reach out to Serena for VSperf displaying issue
15:29:09 <mbeierl> #info here is a sample of the 'series data' that storperf puts into the results db: http://testresults.opnfv.org/test/api/v1/results?project=storperf&period=2
15:29:41 <gabriel_yuyang> #info Bottlenecks, VSperf, NFVbench would like to use Prometheus to store time series results
15:32:04 <mbeierl> Are we suggesting to change the testresults db from mongo to prometheus?
15:37:18 <gabriel_yuyang> I do not think so, just for the temporary/real time testing results
15:39:53 <gabriel_yuyang> #link https://github.com/att-comdev/prometheus-openstack-exporter/blob/3231f14419f0c47547ce2551b7d884cd222104e6/exporter/main.py#L46
15:40:06 <gabriel_yuyang> #info an example of prometheus exporter
15:45:40 <gabriel_yuyang> #topic K8S capacity testing
15:45:59 <gabriel_yuyang> #link https://gerrit.opnfv.org/gerrit/#/c/60969/
15:50:17 <acmacm> #info Al Morton
16:00:58 <gabriel_yuyang> #endmeeting