15:01:15 <maryamtahhan> #startmeeting VSPERF Weekly call
15:01:15 <collabot> Meeting started Wed Oct 28 15:01:15 2015 UTC.  The chair is maryamtahhan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:15 <collabot> The meeting name has been set to 'vsperf_weekly_call'
15:06:56 <billyoma> #topic Agenda Bashing
15:08:11 <billyoma> #info Data Plane Performance Demonstrator
15:08:23 <billyoma> #topic DPPD
15:08:42 <billyoma> #info could be a good VNF
15:09:10 <billyoma> #info not a replacement for VSPERF
15:11:15 <billyoma> vCPE also mentioned as a possible VNF (virtual Customer Premises Equipment)
15:11:45 <billyoma> #topic Dev. Update
15:11:53 <billyoma> #info near end of 2nd sprint
15:12:44 <billyoma> #info Simple Perf Test VSPERF-91 done
15:13:35 <billyoma> Several LTD related jobs completed this week \o/
15:14:34 <billyoma> VSPERF-97 IMIX testing being moved to blocked. Need to agree/design API to specify various IMIXes.
15:14:48 <billyoma> #info Several LTD related jobs completed this week \o/
15:15:00 <billyoma> #info VSPERF-97 IMIX testing being moved to blocked. Need to agree/design API to specify various IMIXes.
15:15:18 <billyoma> #topic TrafficGen integration updates
15:20:31 <billyoma> #info Xena - working of RFC2544. No integration yet.
15:21:35 <billyoma> #info Rick will have send an email to ML about some concerns about repeatability of tests across different TGs. We can then start a discussion on this at next weeks meeting.
15:22:48 <billyoma> #info Spirent - issue w. lic. server at Hillsborough.
15:23:49 <billyoma> #info Moongen
15:24:14 <billyoma> #info bidir tests working. Also latency measurements
15:24:56 <spirentbrian> #info Spirent traffic gen update: Pushed the initial Spirent integration code to gerrit for review. Mayram is helping work through a Jenkins build error that seems unrelated to my code.
15:25:03 <billyoma> thanks Brian.
15:25:08 <billyoma> #topic CI
15:25:13 <billyoma> #info no update this week
15:25:29 <billyoma> #topic Doc integration with RELENG
15:26:02 <billyoma> #info there is patch in gerrit for the re-org'd doc structure.
15:27:11 <billyoma> #info RELENG will build this standardized doc structure each night to html (for each OPNFV project)
15:27:21 <billyoma> #topic IETF-94
15:27:29 <billyoma> #info draft updated to a new version
15:27:48 <billyoma> #info slides being prep'd for a readout next week.
15:28:23 <billyoma> #info Will ask BMWG if draft can be frozen for a while as the LTD is currently in a state of flux.
15:29:09 <billyoma> #info readout is to the IETF
15:29:23 <billyoma> #topic PDV
15:29:31 <billyoma> #info synch with IXIA being arranged.
15:30:16 <billyoma> #topic New Tests
15:31:04 <billyoma> #info We need new tests that a) cover more relevant UCs b) cover more cells in the test matrix (on the wiki)
15:39:59 <billyoma> https://www.irccloud.com/pastebin/tmARvQhy/
15:42:24 <billyoma> can people see the brainstorm of new test types ok?
15:45:00 <billyoma> #info encryption of traffic taking place
15:51:28 <billyoma> #action Brian Castelli offered to try an dig out some documentation on test methods regarding testing performance for multiple flows and across complex/large match/action tables.
15:52:11 <billyoma> #topic Naming of Deployment Scenarios
15:53:37 <billyoma> #info There was a proposed Deployment Scenario involving SRIOV that did not fit with current naming convention
15:55:31 <billyoma> #info
15:55:48 <billyoma> #info Should we stick with:
15:55:48 <billyoma> P2P, PVP, PVVP …
15:55:48 <billyoma> Or should we migrate to:
15:55:48 <billyoma> T1n – VSWITCH Onboard port Forwarding ( either P2P port forwarding or flow based )
15:55:48 <billyoma> T1u – VSWITCH Forwarding with user space L2 forwarding
15:55:49 <billyoma> T1v – VSWITCH Forwarding with one VM ( either switch based port forwarding or flow based )
15:55:49 <billyoma> T2v – VSwitch Forwarding with two VMs ( either switch based port forwarding or flow based with DNAT on VM1 )
15:56:11 <billyoma> #info Should we stick with:
15:56:12 <billyoma> #info P2P, PVP, PVVP …
15:56:12 <billyoma> #info Or should we migrate to:
15:56:12 <billyoma> #info T1n – VSWITCH Onboard port Forwarding ( either P2P port forwarding or flow based )
15:56:12 <billyoma> #info T1u – VSWITCH Forwarding with user space L2 forwarding
15:56:12 <billyoma> #info T1v – VSWITCH Forwarding with one VM ( either switch based port forwarding or flow based )
15:56:12 <billyoma> #info T2v – VSwitch Forwarding with two VMs ( either switch based port forwarding or flow based with DNAT on VM1 )
16:00:22 <billyoma> #action Rick will have send an email to ML about some concerns about repeatability of tests across different TGs. We can then start a discussion on this at next weeks meeting.
16:05:42 <billyoma> #action Maryam will schedule the talk on new topology naming and virtual topology for test towards top of next meeting.
16:05:58 <billyoma> #endmeeting