15:48:58 <mtahhan> #startmeeting VSPERF Weekly Call
15:48:58 <collabot> Meeting started Wed Jan 27 15:48:58 2016 UTC.  The chair is mtahhan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:48:58 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:48:58 <collabot> The meeting name has been set to 'vsperf_weekly_call'
15:49:05 <mtahhan> #info Roll Call
15:49:10 <mtahhan> #info Maryam Tahhan
16:00:06 <mtahhan> Hi folks
16:00:43 <mtahhan> if you are on the IRC channel feel free to log your attendance
16:01:09 <acm> #info Al Morton
16:01:14 <mars_toktonaliev> #info Mars Toktonaliev
16:01:24 <Simona> #info Simona Coppola
16:01:34 <Simona> Agenda
16:01:44 <Simona> Moongen Overview
16:01:54 <Simona> Dev updates
16:02:03 <Simona> traffic gen updates
16:02:27 <Simona> Priority list for Rel C
16:02:42 <Simona> Review Open actions
16:04:19 <mtahhan> #topic Moongen Overview
16:06:03 <mtahhan> #info Provides a LUA script on top of DPDK.
16:06:22 <mtahhan> #info Bill has added some low level stats to the LUA script
16:07:09 <mtahhan> #info Red Hat have integrated Moongen with an internal test framework. but mostly Bill's repo mirrors Moongen @ github
16:07:28 <mtahhan> #info a detailed README exists on github
16:07:37 <ljlamers__> #info Larry Lamers
16:07:56 <mtahhan> #info additional setup information can be found @
16:08:08 <mtahhan> #link https://raw.githubusercontent.com/bmichalo/MoonGen/opnfv/MoonGenSetUp.html
16:08:24 <mtahhan> Bill's github repo can be found @
16:08:27 <mtahhan> #link https://github.com/bmichalo/MoonGen/tree/opnfv
16:09:29 <mtahhan> the relevant branch for vsperf from Bill's repo is the opnfv branch
16:09:55 <mtahhan> #info Today Moongen uses DPDK 1.7.1
16:10:48 <mtahhan> #info it would be a "nice to have" to upgrade to DPDK 2.2 but this is up to the Moongen maintainers.
16:11:42 <mtahhan> #info Bill can't run Moongen with DPDK 2.1 or DPDK 2.2, but this isn't an issue for us, we should just use Moongen as a standalone traffic generator
16:20:48 <mtahhan> #info examples/opnfv-vsperf.lua is a script that Andrew and Bill wrote modelled on other scripts in the example dir and it runs an RFC2544 test
16:22:06 <mtahhan> #info the script does a binary search
16:22:50 <mtahhan> #info to find the throughput value for the specified traffic loss %
16:25:34 <mtahhan> #info Bill added a validation run to the script to ensure that the throughput value found in the binary search is indeed the x% frameloss throughput value
16:26:11 <mtahhan> #info if validation fails the script continues to run the binary search till the validation phase passes.
16:32:45 <mtahhan> #topic dev update
16:36:58 <Simona> #Current Sprint status link: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=43
16:37:36 <Simona> #info planning for next sprint started, please review and add tasks
16:38:02 <Simona> #topic Traffic Gen update
16:38:29 <mtahhan> #topic Spirent update
16:39:23 <mtahhan> #info Sridhar should be pushing some patches to vsperf will use the spirent REST API.
16:40:23 <Simona> #Info Sridhar to follow up on Jira access with Aric
16:40:37 <mtahhan> #info Sridhar has a document for adding a new test case.
16:41:51 <mtahhan> #action Sridhar to migrate the ppt to rst and push to gerrit
16:42:29 <mtahhan> #topic Xena update
16:42:45 <mtahhan> #info Xena code is written - it just needs to be tested
16:43:24 <mtahhan> #info Christian is going to test it - working on installing vsperf
16:43:37 <mtahhan> #info having some issues with it.
16:45:04 <Simona> #Topic Test priority list for Rel C
16:45:41 <Simona> #info new deadline Friday 5th Feb for feedback
16:48:31 <Simona> Action Maryam to upload OVS Tests
16:49:13 <mtahhan> #link https://etherpad.opnfv.org/p/vSwitchPerfNewTestList
16:53:46 <Simona> #Action Maryam to post test results report
16:59:01 <mtahhan> #link https://build.opnfv.org/ci/view/vswitchperf/
16:59:06 <mtahhan> ci build for OPNFV
19:43:16 <mtahhan> #endmeeting