15:01:29 <mtahhan__> #startmeeting vsperf weekly
15:01:29 <collabot> Meeting started Wed Sep 21 15:01:29 2016 UTC.  The chair is mtahhan__. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:29 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:29 <collabot> The meeting name has been set to 'vsperf_weekly'
15:01:49 <mtahhan__> #topic Dev updates
15:02:09 <mtahhan__> #info binary support for OVS has now been merged to vsperf
15:02:39 <mtahhan__> #info means you can test binary packages with vsperf now
15:03:17 <mtahhan__> #info Moongen: outstanding codeset for latency support, there's a bug in moongen with the latency measurement code
15:03:28 <mtahhan__> #info more info to follow on the bug next week
15:04:05 <mtahhan__> #info running moongen in a virtual machine/container - however Bill needs the latest version of Moongen, Bill's version is a little bit behind
15:04:38 <mtahhan__> #info Bill is trying to merge the code and is encountering some issues that still need to be resolved
15:05:13 <mtahhan__> #info requiremetns gathering in release D ongoing
15:05:28 <mtahhan__> sorry for typos
15:05:57 <mtahhan__> #info 2889 Address learning and caching implementation to start soon
15:06:33 <mtahhan__> #action Sridhar info sharing next week on QoS testing
15:07:13 <mtahhan__> #topic - Yardstick presentation
15:09:04 <mtahhan__> #info Martin prepared 3 sample testcases stored inside the vsperf repo
15:09:27 <mtahhan__> #info each testcaset to be executed by yardstick is to be defined inside the yaml file
15:10:59 <mtahhan__> #info you can also specify the custom config file as a parameter to the yaml test case
15:11:40 <mtahhan__> #info you can also pass additional configuration files as arguments to be executed before and after the test case
15:11:58 <mtahhan__> #info to allow you some more flexibility
15:13:02 <mtahhan__> #info runner: defines which parameters for the test case will be modified by yardstcik itself, so one tet case can be run multiple times with those parameters
15:14:05 <mtahhan__> #info we have to use the runner syntax to execute each test case individually and report the results per test case
15:14:32 <mtahhan__> #info SLA parameter allows you to set a threshold for pass/fail
15:14:38 <mtahhan__> #info of a test case
15:15:21 <mtahhan__> #info SLAs for vsperf -> you can use any value that's reported as a result to set a threshold for pass/fail
15:15:54 <mtahhan__> #info context - defines what VMs to execute on the DUT
15:21:20 <mtahhan__> #info next steps
15:21:41 <mtahhan__> #info how do we configure the rules on the vswitch with Yardstick
15:21:59 <mtahhan__> #info can be done through a setup-script
15:22:17 <mtahhan__> #info but this would mean that we would need a script per setup
15:22:52 <mtahhan__> #info will also be more difficult with multi node installations... Needs to be figured out
15:23:16 <mtahhan__> #info at the moment yardstick runs on the jumphost
15:23:33 <mtahhan__> #info will need some ssh functionality integrated into OVS
15:24:15 <mtahhan__> #info vsperf @jumphost vs vsperf in a VM
15:24:31 <mtahhan__> #info easier to prepare a VM that can be downloaded and used
15:24:44 <mtahhan__> #info only limitation is this ssh feature that will be required
15:48:13 <mtahhan__> #endmeeting