14:59:04 <mtahhan__> #startmeeting VSPERF weekly call
14:59:04 <collabot> Meeting started Wed Sep 28 14:59:04 2016 UTC.  The chair is mtahhan__. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:04 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:04 <collabot> The meeting name has been set to 'vsperf_weekly_call'
14:59:44 <mtahhan__> #info Roll Call
14:59:50 <mtahhan__> #info Maryam Tahhan
15:01:28 <mtahhan__> #topic Agenda
15:01:38 <mtahhan__> #info dev update
15:01:46 <mtahhan__> #info QoS Readout
15:01:57 <mtahhan__> #info Release D
15:02:05 <mtahhan__> #info AOB
15:02:28 <mtahhan__> #topic dev-update
15:05:32 <mtahhan__> #info bug fixes worked on as well as cli parameter updates
15:05:39 <mtahhan__> #link https://gerrit.opnfv.org/gerrit/#/dashboard/self
15:05:52 <mtahhan__> #info don't be afraid to merge +1'd code
15:06:06 <mtahhan__> #info Moongen - latency testing is being worked in
15:06:20 <mtahhan__> #info Moongen - running in a VM - work ongoing there
15:07:17 <mtahhan__> #info as part of this effort - virtio drivers from master moongen branch have been merged with Bill's tree
15:07:31 <mtahhan__> #info not published yet
15:08:33 <mtahhan__> #info Bill is seeing packets getting dropped on the Receive side of the virtio ports into the VM on both his branch and the master moongen branch
15:10:28 <mtahhan__> #info don't know if the moongen maintainers are aware of the latency bug that exists
15:10:41 <mtahhan__> #info github issue will be opened against the repo
15:12:28 <mtahhan__> #info 2889 address caching and learning tests still under testing
15:12:48 <mtahhan__> #info Sridhar looking at Yardstick support from the yardstick.
15:13:40 <mtahhan__> #topic QoS Testing Readout - Sridhar
15:15:02 <mtahhan__> #action - Sridhar to send link to "An internet-wide analysis of Traffic policing" paper to the mailing list
15:15:32 <mtahhan__> #action Sridhar to upload readout to the readouts wiki
15:15:51 <mtahhan__> #info Sridhar walking though how to setup QoS for OVS
15:16:27 <mtahhan__> #info OVS doesn't implement QoS itself
15:16:48 <mtahhan__> #info it uses a subset of Linux Kernel QoS features
15:17:32 <mtahhan__> #info Policing works as expected
15:17:56 <mtahhan__> #info traffic shaping is a possible test case that we could look at benchmarking
15:23:16 <mtahhan__> #info Al points out that if OVS vsctl is using tc to configure the queuing - then the queuing is happening on the Linux Plane not the vswitch plane
15:24:14 <mtahhan__> #info then the testing would really be of the Linux Kernel Queue
15:24:55 <mtahhan__> #info Al points out that there is a traffic management benchmarking rfc - 7640 that we might be able to leverage
15:27:16 <marst> #link https://tools.ietf.org/html/rfc7640
15:27:36 <mtahhan__> #topic Release D planning
15:34:38 <mtahhan__> #info goals for moongen - latency testing, CI integration
15:35:04 <mtahhan__> #info Al suggests that maybe RFC5481 can be implemented with moongen
15:35:23 <mtahhan__> #info Q. if there's a limit on samples, how many samples can you get?
15:35:35 <mtahhan__> #info 800/900 per second
15:35:47 <mtahhan__> #info it may not be enough
15:36:12 <mtahhan__> #info adding more options for tuning to vsperf
15:36:57 <mtahhan__> #info binding options, profiles, moving to libvirt instead of Qemu, adding testpmd 16-07 as a switch
15:37:09 <mtahhan__> #info are some options
15:37:38 <mtahhan__> #info vsperf integrated in a more openstack env
15:39:15 <mtahhan__> #info Yardstick integration.
15:41:50 <mtahhan__> #info IMIX testing is also something that could be implemented for D
15:44:34 <mtahhan__> #info 40Gb integration is also an option for D
15:47:49 <mtahhan__> #info Netronome would like to contribute back to vsperf the following features: NIC integration for 40Gb and 25 Gb. Moongen support for Netronome NICs, Drop rate tolerance and traffic patterns
15:48:27 <mtahhan__> #info Moongen changes are in the master moongen branch
15:48:56 <mtahhan__> #info compilation changes to DPDK for the NICs aren't upstreamed to Moongen yet
15:53:35 <mtahhan__> #action Bill to look Moongen feature planning for D next week
15:55:08 <mtahhan__> #action Maryam to to the same for yardstick
15:55:32 <mtahhan__> #info Christian - vsperf tuning and options
15:56:05 <mtahhan__> #info Prevaze - Netronome features
15:56:42 <mtahhan__> #info review IMIX stories already in JIRA
15:57:02 <jmorgan1> ixia chassis in intel-pod3 should be working again
15:57:36 <mtahhan__> #endmeeting