15:56:26 <trevc> #startmeeting OPNFV VSPERF
15:56:26 <collabot`> Meeting started Wed Nov 16 15:56:26 2016 UTC.  The chair is trevc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:56:26 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:56:26 <collabot`> The meeting name has been set to 'opnfv_vsperf'
15:56:37 <trevc> #info Trevor Cooper
16:04:41 <trevc> #topic Moongen
16:07:07 <trevc> #info VSPERF-419 - Moongen not detecting TX traffic (test: phy2phy_tput). Bill says thinks the problem here is that the current stable version of MoonGen associated with VSPERF does not have proper X710 rate control.   This has been added in a version of MoonGen that will be going into the next release of VSPERF.   However, this is currently on a development git repository (branch)
16:07:07 <trevc> - therefore this is not immediately ready to have a stable branch cut and associate with VSPERF.
16:07:07 <trevc> This being said, I have given instruction to the Jira ticket submitter how to test MoonGen with this latest X710 supported development branch.   As APIs and such are different and there will be an integration process with putting this latest MoonGen into the VSPERF infrastructure, the immediate test would involve running MoonGen outside of VSPERF to see if the problem is fixed.
16:07:37 <trevc> #info Christo will test the new version on Friday and update Jira accordingly
16:08:14 <trevc> #topic Updates from martin
16:08:41 <trevc> #info VSPERF-375 (--test-params enhancement) – review comments applied and code merged
16:09:34 <trevc> #info VSPERF-422 – update of yardstick scenario + documentation + samples – implementation prepared and verified in my testing environment (single node devstack deployment); patches in review: https://gerrit.opnfv.org/gerrit/#/c/24359/ (vsperf repo – TC samples and docs) https://gerrit.opnfv.org/gerrit/#/c/24361/ (yardstick repo – code + unit test updates)
16:11:14 <trevc> #info Martin reported progress on Yardstick integration
16:11:25 <trevc> #info A few notes:
16:11:25 <trevc> * I’ve prepared a sample VM image with preinstalled vsperf for easier “ramp up” with vsperf/yardstick integration. Image is not uploaded to artifactory yet, because connection between POD3 and GDRIVE is currently broken. I’ve asked Fatih for help.
16:11:25 <trevc> * I’ve enhanced “Dummy” trafficgen implementation, so image above can be used at environment without real traffic generator. Just to verify that vsperf and yardstick integration works.
16:11:25 <trevc> * If needed, new YAML TC examples customized for other traffic generators can be added into yardstick specific documentation file.
16:11:25 <trevc> Next steps:
16:11:25 <trevc> I’ll check yardstick documentation and code, if there is any “plugin” support suitable for native vsperf TCs execution.
16:11:25 <trevc> In case you have any knowledge about this functionality or in general any comments to my email ‘November sprint and "vsperfstick" tasks’ from 3rd of November, please let me know.
16:16:23 <trevc> #info Update from RH (Christian) ... Jira 406 (adding testpmd as switch for routing traffic to guest not using OVS) ... has been testing and figuring how to integrate ... should be doen in 2-3 weeks.
16:18:34 <trevc> #info Christian finished Jira 258 ... RHEL 7.2 rls scripts for Python 3.3 Martin reviewed and +1. If no further review comments Christian will merge the code.
16:21:19 <trevc> #info Christo - Xia interface - isues with intergration ... now using new Ixnetwork. Still have to do Jira 417 - integration testing and doc changes
16:23:30 <trevc> #info Sridhar - Finished changes and will update Jira 420 and 395 by end of the week (naming and address learning issues)
16:26:36 <trevc> #info Open issue for Yardstick folder or update exisitng Yardstick docs - Sridhar
16:27:04 <trevc> #action trevor setup a Yardstick integration ehterpad to share progress and issues with yardstick team
16:29:13 <trevc> #endmeeting