15:07:44 <trevor_intel> #startmeeting OPNFV VSPERF
15:07:44 <collabot`> Meeting started Wed May 31 15:07:44 2017 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:07:44 <collabot`> The meeting name has been set to 'opnfv_vsperf'
15:07:49 <acm> #info started to use YS for benchmarking
15:08:18 <trevor_intel> #info Trevor Cooper
15:08:27 <acm> #info looked at VSPERF - thought about integration with YS
15:10:00 <acm> #info Integration currently only at Traffic Gen mode, missing is YS related parts (automation)
15:11:08 <acm> #info Jing is interedted in OVS with DPDK, and testpmd (? missed it)
15:12:25 <acm> #info Jing also interested in MoonGen as a TG, YS not using latest branch (?) need 2 DPDK ports.
15:15:02 <acm> #info In tests of L2 forwarding, MoonGen receiving more packets than sent, problem with negative values
15:16:00 <acm> #info need VSPERF to handle negative packet loss values (?)
15:16:49 <acm> #info Jing consideres YS integration of Traffic Gen mode complete.
15:18:48 <acm> #info trevor_intel Q: did u just moongen?  yes, not interested in any others, partners use MoonGen
15:19:57 <acm> #info trevor_intel Q: did u just use Throughput?  Some latency meas, but numbers are zero? not interested.
15:20:35 <acm> #info Bill: MG is not set up to report Latency in VSPERF today, why the numbers of zero
15:21:28 <acm> #info need work on VSPERF side, JIRA ticket exists
15:22:18 <acm> #info Bill: MG master branch is very dynamic - took a version and designated that as our "stable" version.
15:23:03 <acm> #info Bill = BillMichalowski
15:24:42 <acm> #info BillMichalowski: did you post the diffs as patch? please send.  Just YS code though.
15:27:00 <acm> #info trevor_intel  Only MoonGen.py code needs to change - BillMichalowski will look at changes and submit a patch if ok
15:28:25 <acm> #action  BillMichalowski  here is the patch https://gerrit.opnfv.org/gerrit/#/c/35379/4
15:30:47 <acm> #info  not able to publish data, but results on Throughput were stable
15:31:26 <acm> #info ...over several runs
15:32:17 <acm> #info Jing says thank you, just downloaded and used (for the most part)
15:34:12 <acm> #info trevor_intel: +Sridhar we have a page comparing Traffic Gens, Jing would be interested in the results.  Would like to have company comparing results.
15:34:59 <acm> #info trevor_intel: gave Jing access to our page with restricted (as of now) results https://wiki.opnfv.org/display/vsperf/Traffic+Generator+Testing
15:35:41 <acm> #info Jing chatted in GTM: Changes in trafficgen.lua is un-necessary. I chose to change trafficgen.lua because changing moongen.lua to handle "negative frames" seem more involved.
15:36:15 <acm> #topic Dev updates
15:37:36 <acm> #info Sridhar  looking at Trex performance for single flow.  same as Prox and MG, OVS slightly better than VPP
15:38:05 <acm> #info Sridhar just throughput for now, latency and multiflow next
15:39:14 <acm> #info Sridhar VPP and OVS and Cache hits does not seem to differ with ?
15:40:45 <trevor_intel> #info back2back test result analysis added to TG page by Al https://gerrit.opnfv.org/gerrit/#/c/35379/4
15:41:04 <trevor_intel> #info link is https://wiki.opnfv.org/display/vsperf/Traffic+Generator+Testing#TrafficGeneratorTesting-AppendixB:Back2BackTestingTimeSeries%28fromCI%29
15:42:53 <trevor_intel> #info Al will look at some additional test cases e.g. PVP
15:43:48 <trevor_intel> #info Test is important when servers burst out traffic ... max the network device can handle
15:45:46 <trevor_intel> #info B2B result became stable a few weeks ago ... only looked at 2017 results (only started in Feb)
15:46:41 <trevor_intel> #info Martin mentioned lab NW issues may be relevant (huge delays in test case execution)
15:52:55 <acm> #info need to look at 2016 results for P2P, there was a lab networking issue untill 3 weeks ago, which may explain the 128 byte change to consistent results.
15:55:00 <acm> #info Martin talking with KVM for NFV folks - using testpmd threads for processing, something about master core?  multiple cores used
15:55:29 <acm> #info trevor_intel: need to look at these results.
15:55:54 <acm> #topic Design Summit
16:01:00 <trevor_intel> arghhh GTM killed
16:01:10 <trevor_intel> will have to continue over email
16:01:16 <acm> #info we need to sort-out the sessions at Summit by e-mail -
16:01:49 <acm> #info  I see where you were going, there isn't a lot of open time for trevor_intel
16:01:50 <trevor_intel> acm, Does it make sense to do a quick call with Sridhar to discuss the session agenda?
16:02:04 <trevor_intel> or try by email?
16:02:10 <acm> Yes, I'm available
16:02:31 <trevor_intel> ok I'll quickly get a bridge
16:02:50 <acm> maybe he has some slides already, he's not on IRC though
16:03:16 <acm> #endmeeting
16:03:40 <trevor_intel> #endmeeting