#opnfv-vswitchperf: VSPERF

Meeting started by acm at 15:03:48 UTC (full logs).

Meeting summary

    1. Al Morton (acm, 15:04:06)
    2. delay histogram, upgrades CI hosts, feedback from IETF BMWG on the test results (acm, 15:08:23)

  1. upgrades to CI (acm, 15:09:14)
    1. Centos 7.3 image upload/install on sandbox, no difference to Tput. (acm, 15:10:02)
    2. Chris - there is an unknown source of packet loss, will investigate locally (acm, 15:10:53)
    3. Chirs never sees loss anymore - current status is in JIRA 518 (acm, 15:11:45)

  2. delay histogram (acm, 15:12:16)
    1. Al's feedback on the list (acm, 15:15:14)
    2. no generic historgarm config for the T-gens (acm, 15:21:29)
    3. acm thinks they should be the same. (acm, 15:23:50)
    4. ACTION: sridhar generic config for generator histogram collection (acm, 15:26:22)

  3. stress-ng test case proposal (acm, 15:27:57)
    1. new noisy neighbor (_nn) test case with 2544 tput (acm, 15:29:52)
    2. need many VMs, sridhar looking for a place to put VNF images (acm, 15:30:25)
    3. stress-ng is created to cause a particular sort of load/noise, and generates when it is spawned (acm, 15:31:50)
    4. mars - the right place may be OPNFV artifacts directory (acm, 15:32:29)
    5. mars - naming of test cases is not very good, maybe _nn should be a prefix, not a suffix (acm, 15:33:23)
    6. ACTION: sridhar will send out test case proposal (acm, 15:34:21)
    7. sridhar shows the stress-ng configuration parameters and example (acm, 15:35:13)
    8. author of stress-ng Collin King, at Canonical, very helpful, already added new feature (acm, 15:37:36)

  4. VSPERF at IETF BMWG (acm, 15:38:23)
    1. question from BMWG - did you try IMIX?? (acm, 15:40:51)
    2. answer - VSPERF is limited fixed packet sizes, and IMIX is a feature that benchmarkers would like to see (acm, 15:41:42)
    3. need a generic way to specify IMIX, that we can translate to all T-gens (acm, 15:42:38)
    4. yardstick may have the generic spec, also IMIX Genome spec (acm, 15:43:47)
    5. ACTION: sridhar will look at YS IMIX and IMIX Genome RFC (acm, 15:44:16)
    6. BMWG agree with more info on latency (acm, 15:44:57)
    7. Interest to refine the back 2 back frame testing - described the correction factor we used in Design Summit calculations (acm, 15:46:38)
    8. if we want to reduce frame sizes used in b2b frame testing, need to feedback results from Tput tests (acm, 15:48:22)
    9. BMWG is re-chratering, taking-up new proposals NOW! (acm, 15:49:37)

  5. next week (acm, 15:51:49)
    1. acm will not be able to join, away all week (acm, 15:52:14)
    2. no other business (acm, 15:52:35)


Meeting ended at 15:52:42 UTC (full logs).

Action items

  1. sridhar generic config for generator histogram collection
  2. sridhar will send out test case proposal
  3. sridhar will look at YS IMIX and IMIX Genome RFC


People present (lines said)

  1. acm (37)
  2. collabot (3)


Generated by MeetBot 0.1.4.