14:45:07 <trevor_intel> #startmeeting OPNFV VSPERF
14:45:07 <collabot> Meeting started Wed Aug  9 14:45:07 2017 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:45:07 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:45:07 <collabot> The meeting name has been set to 'opnfv_vsperf'
14:45:17 <trevor_intel> #info Trevor Cooper
15:01:42 <acm> #info Al Morton
15:03:15 <trevor_intel> #topic 2.	Release milestones update
15:05:25 <trevor_intel> #info Need to merge TREX integration and new TCs from Martin
15:06:51 <acm> #info patches for Trex integration and Martin's JIRA: VSPERF-518 should be completed by Aug 11  MS5
15:07:14 <acm> #info Any documentation updates?
15:07:21 <trevor_intel> #topic Documentation
15:07:39 <trevor_intel> #info Tuning POD work may add some documentation
15:08:38 <trevor_intel> #topic Ixia license
15:09:03 <trevor_intel> #info Mars used Ixia so it works
15:10:26 <acm> #topic Integration of SW version of IXNetwork - need input from Pierre (OOO this week)
15:10:27 <trevor_intel> #topic Ixia integration work
15:10:46 <trevor_intel> #info Still waiting for description of the work from Ixia
15:11:18 <acm> #topic Long Duration Tests
15:12:39 <acm> #info  Test WG has discussed long duration tests, need Pod resources for this, logistics with 5 installers are complex
15:13:12 <acm> #info  what are test cases we would like to include?  Long duration means 2 weeks.
15:14:25 <trevor_intel> #info Trevor proposed latency test cases ... need to tune up what we collect to make them useful
15:14:39 <acm> #info  trevor_intel proposes latency tests for long duration
15:17:37 <trevor_intel> #info Al suggests an alternative is many short duration tests ... repeated ... makes results duration easier
15:18:53 <acm> #info look at min max ave collected from many short duration latency tests
15:18:53 <trevor_intel> #info Sridhar ... what aspect of OVS should we focus on?
15:19:32 <trevor_intel> #info for example varying number of flows
15:25:25 <trevor_intel> #info Trevor proposes going with Al's suggestion to use current latency tests and repeat
15:25:53 <acm> #info follow-up proposal at Test WG meeting this week
15:26:02 <trevor_intel> #topic Test API
15:28:33 <acm> #info  need to discuss naming of a few test  cases
15:28:59 <acm> #info  need to fix time display (currently UNIX format)
15:29:29 <acm> #info  time for each test should be replrted seperately
15:30:27 <acm> #info summary, some small problems and still some things to do, Mars will supply links
15:30:54 <marst> #link https://wiki.opnfv.org/display/vsperf/VSPerf+testcases+report
15:32:37 <acm> #info Mars described this report on the Wiki - this is a list of all test cases VSPERF has
15:35:33 <acm> #info does not include ??  This is the list of tests included in the API (results collected and stored through the API??)
15:40:52 <trevor_intel> #action Trevor schedule a separate meeting to discuss including Morgan or Serena
15:41:42 <trevor_intel> #topic IMIX
15:41:56 <acm> #info JIRA- 521
15:43:37 <trevor_intel> #link https://jira.opnfv.org/browse/VSPERF-521
15:45:02 <trevor_intel> #info Martin and Al discuss 520 and 521 with a view to merge and assign tasks
15:46:43 <acm> #action Martin K and acm discuss 520 and 521 with a view to merge and assign tasks
15:47:47 <acm> #topic Sridhar's topics: Stress VMs
15:49:24 <acm> #info related to JIRA 523, Noisy Neighbor tests, so integration of Stress VMs is a sub-task of 523
15:51:15 <acm> #info  Sridhar's VMs at github.com/opensource-tnbt/stressng-images
15:51:54 <acm> #info  Sridhar created thiese VMs after discussion with Stress-ng author, Colin King
15:53:14 <trevor_intel> #action Sridhar will put the VM images into OPNFV artifacts
15:53:34 <acm> #info  need to store the VMs with our other VMs, like VLOOP, but apparently need special write access, trouble ticket
15:54:07 <trevor_intel> #info 523 is a proposal for suffix to test case name
15:57:54 <acm> #info ACE Lee has some MoonGen related questions - should mail to the VSPERF list
15:58:03 <trevor_intel> #info Ace Lee would like to proposes fixes to Moongen ... suggest send suggestions and questions to VSPERF mailing list
15:59:14 <acm> #info SR's 524  - live results from traffic Generators
16:00:33 <acm> #info SR's 525 - want to include *collectd*  these all support the bigger task of *correlation*
16:01:01 <acm> #info Need a bigger task or Story or Epic to group all these tasks.
16:01:39 <acm> #topic Latency histogram  JIRA -522
16:03:34 <trevor_intel> #topic CI tuning
16:03:39 <acm> #topic  CI tuning - Christian
16:04:28 <acm> #info  has done much to isolate CPUs, want to try this profile on the Sandbox, ...
16:05:06 <acm> #info ... but this profile is for Centos, most of Pod uses Ubuntu 16.04
16:06:25 <acm> #info uses tuneadm profile, have a new one for Centos 7.3, if recommend this to the community then we shouldget similar numbers
16:08:20 <acm> #info so, documentation needed recommending a consistent baseline configuration and these are the perf numbers you should get...
16:09:31 <acm> #endmeeting