14:59:06 <trevor_intel> #startmeeting OPNFV VSPERF
14:59:06 <collabot> Meeting started Wed Aug 23 14:59:06 2017 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:06 <collabot> The meeting name has been set to 'opnfv_vsperf'
15:00:36 <trevor_intel> #info Trevor Cooper
15:01:22 <acm> #info Al Morton
15:03:32 <acm> #info MS6 closes this week
15:03:54 <acm> #topic Latency and Live results
15:04:33 <acm> #topic T-rex Integration
15:04:59 <acm> #info  Martin, e-mail about lab, problem fixed
15:05:38 <acm> #info Martin G. has some issue defining Line Rate, now solved due to old version
15:06:02 <trevor_intel> #info TREX results are very low cf Ixia
15:06:30 <acm> #info Thput numbers are lower than IXIA, may be due to number of cores, only able to reach 5Mil pps for small frames
15:07:27 <acm> #info need to consider configurations, similar to Sridhar's performance during T-Gen Tests
15:08:03 <acm> #info should result in a patch on Thursday.
15:08:44 <trevor_intel> #info Al raised topic of T-gen limitations
15:09:07 <trevor_intel> #info Seems like TREX does not have limitations for packet and stream creation
15:11:22 <trevor_intel> #info Propose looking at generator config files to compare - Sridhar will send out details and config files. Had to use TREX GUI for test setup (manual setup)
15:14:15 <acm> #action Sridhar: make configs avaliable, in JIRA
15:17:40 <acm> #topic Latency and Live results
15:18:40 <trevor_intel> #topic Test API
15:18:43 <acm> #topic Test API patch - Mars
15:20:23 <acm> #info result DB treats all throughput tests (over different packet sizes) as one test, Martin revised start and stop times
15:20:46 <acm> #action marst please review martin's patch
15:21:20 <acm> #info Mars already +1, "beautiful patch"
15:23:33 <acm> #info Morgan has asked for completion date, Mars says tested in 12 hours, so probably donetomorrow.
15:23:49 <acm> #topic Latency and Live results
15:26:21 <acm> #info  min max and average come from T-gen once per second
15:30:13 <acm> #info tests are running on Spirent Lab, can run on Intel pod, but with VMs?  yes, traffic gen load level and other? issues...
15:30:47 <acm> #info  trevor_intel  how can we actually use any of these results?
15:32:32 <acm> #info Sridhar - we can get the same histogram from T-Rex, but need patch. and need patch from IXIA...
15:33:15 <acm> #info Sridhar is showing both live collection, and Histogram for results at end of test
15:33:55 <acm> #info Spirent VMs on Intel Pod need NTP for delay to work properly
15:34:35 <acm> #info Martin - 40% of Sridhar's patch is re-usable for other T-gens.
15:36:42 <acm> #info some discussion of collectd and IPFIX to gather Live data during the testing
15:37:37 <acm> #info #info  for future: run multiple collectors at the same time (as above)
15:39:02 <acm> #info Sridhar has a patch to examine collectd simple stats on CPU, OVS, etc. then prepare plots (as acm suggested on e-mail)
15:40:04 <acm> #info trevor_intel  do we want to commit to this in E-release? there seems to be risk, so do not submit now, it was not announced for E
15:40:29 <acm> #info Martin agrees
15:42:21 <acm> #info VSPERF-527 is the Story for this.  We can close Noisy Neighbor tickets VSPERF 524 and 523
15:43:26 <acm> #info  plan is to deprecate artifacts directory (?)
15:44:06 <acm> #topic CI POD Tuning
15:44:52 <acm> #info  Christian not here, but any progress? nothing else tested.
15:48:22 <acm> #info  SRIOV tests in CI are low, compared to P2P
15:48:49 <acm> #info Martin has produced higher results, but not with zero packet loss
15:49:46 <acm> #info one VM running with SR-IOV, seems to exceed PCI bus limitations
15:52:33 <acm> #info SR-IOV configures two interfaces (virtual?) per one? interface card
15:53:53 <acm> #info logical ports on OVS may be limiting factor
15:54:27 <acm> #info Martin  current SR-IOV may be the limitation of VM with single physical core
15:56:00 <acm> #topic Documentation  - 4 areas CI POD Tuning, Test API, TREX, and New Test cases
15:56:53 <acm> #info  VSPERF-519  should have documentation related to this and *all* new test cases?
15:57:46 <acm> #info  we are way behind on documentation for E-release, within the next 3 weeks.
15:59:56 <acm> #info minimum we can do is to get the list of test cases that are currently implemented
16:00:24 <acm> #topic Traffic dictionary
16:00:49 <acm> #info not active now, for future, not for E-release
16:01:18 <acm> #endmeeting