14:53:31 <trevor_intel> #startmeeting OPNFV VSPERF
14:53:31 <collabot> Meeting started Wed Sep 13 14:53:31 2017 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:53:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:53:31 <collabot> The meeting name has been set to 'opnfv_vsperf'
14:53:42 <trevor_intel> #info Trevor Cooper
15:05:39 <trevor_intel> #topic Project description for Euphrates messaging and announcement materials
15:08:43 <acm> #info Al Morton
15:09:41 <trevor_intel> - VSPERF is a mature project that provides an automated test-framework and comprehensive test suite based on industry standards for measuring data-plane performance which includes switching technologies with physical and virtual network interfaces. The VSPERF architecture is switch and traffic generator agnostic and test cases can be customized. The vSwitch and other software component versions and configurations are
15:09:41 <trevor_intel> controlled by VSPERF as is the network topology. VSPERF is useful for development of switching technologies as well as for evaluation and optimization of the data-path.
15:11:16 <acm> #topic project description
15:17:09 <acm> #info Deadline is friday for reviewing the patch that makes the suggested changes to the Project Description
15:18:19 <acm> #my audio just dropped out, usually comes back quickly
15:18:38 <acm> #audio is back
15:19:20 <trevor_intel> #topic Documentation updates for Euphrates
15:21:14 <trevor_intel> #action Trevor make doc updates for release (project description, RFC, ...) and clarify with docs team re. latest redthedocs artifacts
15:22:14 <trevor_intel> #topic Status update related to CI test results
15:22:18 <acm> #topic Status update related to CI test results
15:23:17 <acm> #info  Intel Lab IT "feature" for FW access keeps blocking access. No CI testing till repaired.
15:23:40 <acm> #info no CI tests for two weeks.
15:24:12 <trevor_intel> #info Patch updatign reporting logic could not be tested
15:24:21 <acm> #info Need to check that recent changes have not affected results reporting to DB
15:25:08 <trevor_intel> #info Tuned profile has not been fully tested with all test cases ... Martin tested one
15:25:08 <acm> #info Christian's recommended changes tested by Martin in PVP scenario, looks stable.
15:25:45 <acm> #Need more tests to confirm stability
15:26:10 <acm> #info Need more tests to confirm stability
15:27:59 <trevor_intel> #info Christian has doc patch to submit re. tuning configuration ... will submit before Friday
15:29:56 <acm> #action Christian will submit patch today/tomorrow
15:30:14 <trevor_intel> #topic Jira SCRUB
15:30:18 <acm> #topic  JIRA Scrub
15:31:09 <acm> #info Dave McB pushing for this, many tickets related to previous release in other projects.
15:32:35 <acm> #action all try to update status if closed, move tags out beyond E if not going to be done
15:33:11 <trevor_intel> #topic Multi-flow test configurations
15:34:47 <trevor_intel> #info We have explained 4k flow results for 3 different traffic gens
15:35:09 <trevor_intel> #info All three generate packets differently
15:37:15 <trevor_intel> #info Al has written up results for ETSI NFV TST for purpose of addressing issues in a normative spec (TST009)
15:40:36 <trevor_intel> #info Al proposes retest - prox from L3 dst to src and Moongen from L3 src to dst ... Sridhar will rerun tests
15:41:17 <trevor_intel> #info Martin will prepare a script to modify Ixia pkt gen too
15:42:04 <trevor_intel> #topic Representation of VSPERF results on reporting page
15:45:46 <trevor_intel> #info Martin provided patch to push results even when they fail (same logic as indicted by Jenkins CI results). Morgan updated explanation on page to be accurate.
15:46:11 <trevor_intel> #topic DPDK/OVS/VPP/QEMU versions
15:47:26 <trevor_intel> #info Haven't been able to verify new versions due to CI being down
15:48:17 <trevor_intel> #info Martin suggests updating versions after stable generated and then decide if we should cherry pick to Euphrates
15:49:09 <trevor_intel> #topic vSwitch metrics
15:51:21 <trevor_intel> #info Sridhar using collectd to collect stats for vSwitch daemon and use to create plots
15:52:16 <trevor_intel> #info We are collecting metrics on the infrastructure ... very useful for operations
15:53:39 <trevor_intel> #action Sridhar will demo this next week and show the plots
15:54:27 <trevor_intel> #info Sridhar uses Python script to collect metrics and create plots ... will contribute to VSPERF
15:55:26 <trevor_intel> #endmeeting