15:01:08 <acm> #startmeeting VSPERF
15:01:08 <collabot`> Meeting started Wed Oct 11 15:01:08 2017 UTC.  The chair is acm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:08 <collabot`> The meeting name has been set to 'vsperf'
15:04:13 <acm> #info Al Morton
15:05:13 <acm> #info  Al plans to attend the plugfest, Sridhar plans to decide this week
15:08:50 <acm> #Info no questions on milestones
15:10:41 <acm> #topic Add multistream support to T-Rex
15:11:10 <acm> #info Christian has made a recent update, Martin will look over tomorrow
15:11:52 <acm> #info Sridhar has tried the tests, p2p tests seem to show default at 64 streams
15:12:57 <acm> #info 03 traffic conf file may need multistream truned off, christian replied
15:14:44 <acm> #info L2 Src-only L3 is soruce only, L4 Source only, linear address rotation for now.
15:16:21 <acm> #info Sridhar, how to enable Latency measurements?  Martin - should be VSperf config, 03_traffic.conf
15:17:38 <acm> #info default is 1000 pps
15:18:01 <acm> #topic Status of tuning CI configuration (Martin)
15:19:33 <acm> #info no progress yet, but daily job is running again, results are fluctuating, p2p and pvp results,
15:20:11 <acm> #action anyone to look into this variation in the results,
15:21:10 <acm> #info intel firewall issue has not been resolved, this is a work-around...
15:22:18 <acm> #info failures of teh verify jobs are out of our control, seems to be a race condition among shared jobs at those machines.
15:23:12 <acm> #info but problem observed since September, re-boot of the shared server fixed for a while.
15:25:24 <acm> #info possible work-around is to ask to move our job to another physical server which is not so busy
15:26:49 <acm> #info Martin has the admin contacts, was Fatih, now another...
15:27:56 <acm> #topic
15:28:04 <acm> #topic Discuss VPP test cases and results in CSIT report
15:28:52 <acm> #info https://docs.fd.io/csit/rls1707/report/vpp_performance_tests/overview.html
15:34:17 <acm> #info main difference is packet sizes, FDIO CSIT uses IMIX, small and large and Jumbo packet sizes
15:35:58 <acm> #info Need some generic API for control, IMIX Genome was proposed.
15:38:20 <acm> #info there is a JIRA ticket for this, also for multistream a common definition of fields to manipulate (Wireshark) VSPERF-520 I think
15:41:11 <acm> #info Sridhar - will take a look at the specifications, in 2 weeks will summarize study, for IMIX specifications
15:45:15 <acm> #info CSIT CPU tuning, not much surprising (acm and Martin), we are using Christian's Tuned recommendation,
15:45:38 <acm> #info trade-off betwen tuning complexity and final results.
15:58:06 <acm> #info looked at some ETH throughput, seems consistent but with many variables in test codes to understnad further
15:58:35 <acm> #info also, at 64 byte frames, the linmitation is the NIC (Niantic)
16:00:00 <acm> #action the CSIT comparison could prompt new features for F release, everyone to take a look and consider resources needed
16:01:44 <acm> #info  Sridhar will be on holiday next week
16:01:55 <acm> #endmeeting