15:58:57 <SridharRao> #startmeeting vswitchperf
15:58:57 <collabot`> Meeting started Wed Feb 14 15:58:57 2018 UTC.  The chair is SridharRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:58:57 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:58:57 <collabot`> The meeting name has been set to 'vswitchperf'
15:59:21 <SridharRao> #info Long-Duration Tests
15:59:21 <SridharRao> : RFC2889 Soak tests (LTD spec is updated). Periodical checking. Packet-loss or Frame-rate for deciding when to stop.
15:59:50 <SridharRao> #info Results – Histogram. Two Options. Bucket Sizes and %le values.
16:00:16 <SridharRao> #topic Summary of discussions.
16:02:31 <earrage> #info earrage
16:03:08 <SridharRao> #topic development update.
16:03:24 <SridharRao> #info VSPERF-504 is completed.
16:05:23 <SridharRao> #info Comparative studies with other projects needs inputs.
16:06:29 <SridharRao> #info Al suggests work with Alec for NFVBench.
16:08:52 <SridharRao> #action Sridhar to focus on NFVBench.
16:09:00 <SridharRao> #action Mars to focus on CSIT.
16:09:23 <SridharRao> #info need volunteers for Yardstick and Bottlenecks.
16:09:26 <acm> #info Al Morton
16:11:08 <SridharRao> #info Christian is working on the updating the T-Rex Patch - VSPERF-559.
16:11:30 <SridharRao> #topic architecture design review.
16:14:16 <SridharRao> #info Include the TestAPi support flow in the architecture diagram.
16:14:38 <SridharRao> #action Sridhar to update the architecture diagram.
16:15:00 <SridharRao> #info Al Suggested to put the architecture diagram in the Wiki.
16:30:09 <acm> #info  a key point on teh performance efficiency score:
16:31:00 <acm> #info Eddies Idea is to have this normalized
16:32:18 <acm> #info a formula that would relate to all resources, clock cycles, memory, resulting in ### packets per second
16:37:07 <SridharRao> #topic Summary of discussions.
16:38:20 <acm> #info  din't forget to #endmeeting
16:38:55 <SridharRao> #info Long-Duration Tests:  RFC2889 Soak tests (LTD spec is updated). Periodical checking. Packet-loss or Frame-rate for deciding when to stop.
16:39:18 <SridharRao> #info Results – Histogram.Two options: Bucket sizes  and %le values.
16:39:29 <SridharRao> #info Traffic Profile: (a)Description of few parameters. (b) IMIX specification - Latency histogram and percentiles. (c) Changing VSPERF conf to YAML is not an option – as it takes significant work. It may apply for TGAAS. (d) definition of frame/packet content needs to be updated – Scapy? (e) These fields - pre_installed_flows', 'flow_type’, 'flow_control', 'learning_frames’ – will continue to remain in VSPERF. It ne
16:39:29 <SridharRao> ed not be included in TGAAS – if VSPERF Traffic-profiles is used.
16:39:39 <SridharRao> #info TST-009 - Walkthrough and Call for contributions – Inputs from VSPERF. (AL is working on the inputs from the VSPERF). IETF-BMWG inputs to be reviewed
16:39:51 <SridharRao> #topic Next Round of Discussions.
16:40:02 <SridharRao> #info Following Topics were suggested.
16:40:39 <SridharRao> #info NFVi forwarding performance and Compliance (verification) program.
16:40:39 <SridharRao> Performance Efficiency score.
16:40:55 <SridharRao> #info NFVi forwarding performance and Compliance (verification) program. Performance Efficiency score.
16:41:04 <SridharRao> #info Test-Metrics and Infra Structure metrics Correlation.
16:41:17 <SridharRao> #info Automation of Deployment and Test-execution.
16:41:27 <SridharRao> #info VSPERF and Cloud-native NFV - Containerized NFV.
16:41:56 <SridharRao> @acm Sure. Thanks.
16:41:56 <collabot`> SridharRao: Error: "acm" is not a valid command.
16:42:07 <SridharRao> #endmeeting