15:57:58 <trevor_intel> #startmeeting OPNFV VSPERF
15:57:58 <collabot`> Meeting started Wed Mar  7 15:57:58 2018 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:57:58 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:57:58 <collabot`> The meeting name has been set to 'opnfv_vsperf'
15:58:09 <trevor_intel> #topic Rollcall
15:58:23 <trevor_intel> #info Trevor Cooper
15:59:23 <acn> #info Al Morton
16:04:33 <trevor_intel> #topic Time Zone change
16:07:07 <trevor_intel> #info We will stick with Pacific Time i.e. 8 AM (PST and PDT)
16:07:31 <acn> #info not following UTC
16:07:56 <trevor_intel> #action Sridhar to change meetings to Zoom
16:08:36 <acn> #topic Dev update
16:09:21 <trevor_intel> #chair acn
16:09:21 <collabot`> Current chairs: acn trevor_intel
16:09:47 <acn> #topic Dev update
16:09:57 <trevor_intel> #chair earrage
16:09:57 <collabot`> Current chairs: acn earrage trevor_intel
16:11:07 <trevor_intel> #info CIs not working
16:12:02 <trevor_intel> #action Trevor follow up with Martin and help to resolve
16:12:45 <trevor_intel> #info See Jira - CI is still not working – details in INFRA-215 and INFRA-220
16:14:21 <trevor_intel> #action All please review 3 patches submitted by Martin
16:15:28 <trevor_intel> #info Christian has reviewed a patch and is helping Martin resolve T-REX issue
16:16:01 <trevor_intel> #info Al has also reviewed one of the patches
16:17:18 <trevor_intel> #info Richard Elias has prepared a patch to enhance “--test-params” functionality and to compare (optional) results of several tests in tabular form. Patch will be send for review in next days.
16:17:44 <acn> #info 2.	Recap of last week’s discussion - action review
16:20:20 <trevor_intel> #info Performance Efficiency - Eddie has started to work on a doc to capture ideas and aiming for first draft end of the week
16:20:27 <acn> #info  WI =  Pc x Cn  x Cf where...
16:29:18 <acn> #info  this will be controversial, but worth pursuing for *some* set of users - maybe this is useful outside of VVP
16:29:48 <trevor_intel> #topic VSPERF results Plotting  - Yardstick-Grafana. (Jose, you can share your queries/inputs/requests).
16:30:13 <trevor_intel> #info There was a discussion over email (Jose)
16:30:43 <acn> #info 3.	VSPERF results Plotting  - Yardstick-Grafana. (Jose, you can share your queries/inputs/requests).
16:31:18 <trevor_intel> #info Waiting for Jose to get back with further questions
16:31:44 <trevor_intel> #topic VSPERF and Cloud-native NFV (Containerized NFV)
16:32:48 <acn> #info we'll capture coments
16:34:30 <acn> #info trevor_intel need to keep evolving/fresh.  Containers are NOW. Benchmarking must follow the trends.
16:35:02 <acn> #info  acm agrees
16:37:46 <acn> #info Need assessment of work needed to implement Container-benchmarking (what is re-useable in VSPERF?)
16:38:07 <trevor_intel> #info We need to understand how VSPERF can be used for container / bare metal performance
16:41:49 <acn> #info K8s is more flexible in resource allocation than hypervisors/VIM
16:43:54 <acn> #info istio is a core plugin used in K8s, unit of containers, K8s can replicate containers in a pod, so can scale-up as necessary (microservices)
16:44:55 <acn> #info istio connects all the microservice, full mesh communication permitted with "sidecars"
16:45:26 <acn> #info flannel and weave handle how traffic moves in/out of cluster
16:46:21 <acn> #info K8s doesn't work at L2, all at L3 - web devs don't need to know L2
16:47:48 <acn> #info istio can carve off a portion of traffic to "container #2"  ...
16:49:37 <trevor_intel> #info The emphasis for now is web traffic (stateful)
16:50:20 <trevor_intel> #info All based above L3
16:50:21 <acn> #info forwarding, load balancing, based on L4 - L7
16:51:37 <acn> #info flannel and weave can deal with L3, NAT'd , iptables for static mapping
16:53:04 <trevor_intel> #info Clover is working on best practices to deliver VNFs in Cloud Native
16:53:45 <acn> #info  clover is a set of Best Practices for delivering VNFs in Cloud Native env, using istio, yeager for tracing, prometheus for telemetry data
16:56:47 <acn> #info VSPERF would be useful to understand flannel and weave's role (CNI plug-ins) performance to move traffic to K8s
16:58:34 <acn> #info  K8s uses Docker containers.
17:01:41 <acn> #info flannel and weave do the L3 routing, then istio -   GRPC is the stateful protocol for communicating between the micro-services.
17:02:36 <trevor_intel> #action Sridhar to present Container Networking next week and continue discussion
17:04:06 <trevor_intel> #endmeeting