15:02:00 <SridharRao> #startmeeting vswitchperf
15:02:00 <collabot_> Meeting started Wed Jun 27 15:02:00 2018 UTC.  The chair is SridharRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:00 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:00 <collabot_> The meeting name has been set to 'vswitchperf'
15:02:14 <SridharRao> #topic Development Update
15:03:10 <SridharRao> #info Xena-Patch from Christian/Bob multi-flows is merged.
15:04:01 <SridharRao> #info Logging Support VSPERF - Should Timestamps be added?
15:06:38 <SridharRao> #info Timestamps should be added.
15:07:16 <SridharRao> #topic Pod-12 Status
15:07:20 <acm> #info Al Morton
15:08:23 <marst> "We do have a new IP of 192.55.66.214 so you will need to change your VPN settings."
15:08:43 <acm> #info Intel Pods IP (new) We are back online at 192.55.66.214 with the exception of traffic generator.
15:11:42 <SridharRao> #info Rerun Tests with Timestamps enabled in logs.
15:13:23 <SridharRao> #topic VSPERF-Intel Demo IEEE SDN-NFV
15:14:02 <SridharRao> #info Create Cache Profiles - L3 Cache.
15:14:54 <SridharRao> #info Find a test VNF that is cache-hungry [ Data-plane VNFs - AVB, Video-Servers, TGen-10G-64B]
15:17:18 <SridharRao> #info 35-55MB of L3-Cache per socket
15:18:51 <SridharRao> #info Experiment Test-VNF and Noisy-Neighbor - without dedicated cacheways
15:19:04 <SridharRao> #info Repeat experiment with dedicated cacheways
15:23:34 <acm> #info  OS Nova cannot balance load across NUMA Nodes (Alec)
15:23:56 <acm> #info No OS on Pod 12
15:24:44 <acm> #info Need Pod 19, where there will be a full OS and OPNFV Deployment, then NFV Bench
15:26:00 <acm> #info Alec - multiple instances of Testpmd  may be sufficient to consume cache
15:26:32 <SridharRao> #topic Container-Networking - Vswitch-Based Only ?
15:27:35 <acm> #info Many options, and K8s adds even more networking options!
15:28:32 <acm> #info Sridhar - Should we focus on vSwitch scenarios?
15:28:51 <acm> #info Alec - first decision is to use K8s or not
15:29:45 <acm> #info SR - Assume no K8s, just Docker Containers, is this worthwhile place to start?
15:30:19 <acm> #info vSwitch would be running on baremetal
15:31:05 <acm> #info Christian - not plugged-in yet, need to ask RH perf team, get some input
15:31:15 <SridharRao> #info (1) Presentation on VSwitch-Based Container Networking.
15:32:18 <acm> #info Need info on common use cases today
15:32:35 <SridharRao> #info Kubernetes + vSwitches:  Solutions/Studies existing
15:34:08 <acm> #info Alec - K8s only understands L3, is IP based, no L2 with vSwitch, SR/IOV is working for containers, too.
15:34:51 <SridharRao> #info Alec - Intel and VPP/FD.IO have studies on Kubernetes+vSwitch
15:35:34 <acm> #info Alec - K8s uses TCP/IP stack in host, and there are some scaling issues when using many containers
15:37:09 <acm> #info #info Alec - experiments running TCP/IP stack in user space, with VPP?, with container connectivity at L3
15:40:31 <acm> #action Alec627 to send FD.io doc on container networking
15:44:25 <acm> #info acm agree  with this path, also learn from what others have done when measuring in this space.
15:51:49 <acm> #info Alec - L3 today in K8s, but this is not efficient when connecting multiple containers.
15:58:08 <SridharRao> #endmeeting