14:59:37 <SRao> #startmeeting vswitchperf
14:59:37 <collabot> Meeting started Wed Oct 10 14:59:37 2018 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:37 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:37 <collabot> The meeting name has been set to 'vswitchperf'
15:01:35 <SRao> #topic Development Update
15:04:26 <acm> #info Al Morton
15:05:00 <SRao> #info We closed the patch on matplotlib - version update.
15:06:14 <SRao> #info @Sridhar yet to submit a patch on histogram.
15:07:30 <SRao> #topic Intern Update
15:17:07 <acm> #action acm to help akanksha1702 get access to Intel Pod12 on Pharos - need to create a JIRA ticket.
15:20:09 <SRao> #info progress on vsperf-container and results-container.
15:20:55 <SRao> #action akanksha request helpdesk for contributing to vsperf.
15:21:15 <SRao> #action sridhar share information on how to submit patches to vsperf.
15:22:25 <SRao> #info intern updates: https://wiki.opnfv.org/display/vsperf/Intern+Project%3A+VSPERF+Automated+Deployment+and+Results+Management
15:22:46 <SRao> #topic VLOOP-VNF
15:24:06 <SRao> #info Christian: ubuntu image may not be tuned
15:24:33 <SRao> #info The image created with fedora - size is huge.
15:32:32 <SRao> #info Parameters to consider - VCPUs (default 2, better to assign more), testpmd-queues, cpu-pinning (isolcpus), IRQ-pinning (tuna tool), cpu-affinity (apart from isolcpus),
15:34:32 <SRao> #info Christian will follow this up - it may take few weeks.
15:36:26 <SRao> #info Run test with 1500bytes, check if any loss at testpmd (guest), if yes, there is some issue with the guest.
15:38:34 <SRao> #info Christian to show the approach he take in debugging the guest.
15:43:17 <SRao> #topic Test-Results
15:44:53 <SRao> #info Tests - SRIOV (ubuntu 14.04 VNF): results similar to phy2phy. 5Gb/s. T-Rex.
15:46:56 <SRao> #info tested with netEm [TC: 100Mb/s, Egress]. Came across -ve loss and -ve loss %ge.
15:47:36 <SRao> #info This behavior (-ve values) around 75 to 90mb/s range.
15:49:41 <SRao> #info Trex Stateful tutorial: https://trex-tgn.cisco.com/trex/doc/trex_control_plane_peek.html
15:52:32 <SRao> #action acm to create wiki on edge-computing characterization, traditional-tools, TGens, TC, etc.
15:57:32 <SRao> #topic OVS-VANILLA
15:58:42 <SRao> #info currently ovs_vanilla is not built.
15:59:11 <SRao> #info we have to either (a) change the "default" path for OVS_Vanilla. (b) Build ovs-vanilla also by default
16:00:25 <SRao> #info Documentation update is needed.
16:00:46 <SRao> #endmeeting