#opnfv-vswitchperf: Vswitchperef

Meeting started by SRao at 16:04:44 UTC (full logs).

Meeting summary

  1. Development Update (SRao, 16:04:55)
    1. Added a patch to affinitize stressor-vm cpus (SRao, 16:05:16)
    2. added a patch to fix variable name. (SRao, 16:05:30)
    3. Al Mort9on (acm, 16:06:47)
    4. Al Morton (acm, 16:07:04)
    5. include 'before' and 'after' images for affinitize patch. (SRao, 16:07:12)
    6. ACTION: all need reviews on (acm, 16:08:26)

  2. IEEE NFVSDN (SRao, 16:08:55)
    1. 3-hr tutorial on dataplane performance benchmarking, tried to convince the attendees to participate in these projects. (SRao, 16:09:31)
    2. Majority of the participants from academia. VSPERF can be used as part of the research activity. (SRao, 16:10:07)
    3. NFVBench Demo - Trex reported -ve dropped packets. (SRao, 16:10:46)
    4. If someone can create a vagrantfile it would help users to try vsperf on laptop (SRao, 16:12:51)
    5. I think that the method of reading TX and Rx counters separately may be part of the issue (with -Trex) (acm, 16:13:16)
    6. - no vagrant experience for me, good question about is it still cool... (acm, 16:14:05)
    7. Collectd reporting the l3-cache values - has issues of staledata, and timestamps. (SRao, 16:15:30)
    8. I'd like to use collectd to read interface tx/rx packet counters periodically, can it do that? (acm, 16:15:56)

  3. Containerizing VSPERF. (SRao, 16:16:44)
    1. should we put the contents in existing repo or should we create a new repo - vswitchperf-containers? (SRao, 16:17:34)
    2. I'd like to9 get some advice from Eddie Arrage or Alec H (acm, 16:17:45)
    3. It would be a quick e-mail (acm, 16:18:13)
    4. If existing one - create a folder containers, and within that we need 2 folders one for vsperf and results. (SRao, 16:18:50)
    5. ACTION: acm write e-mail to Eddie Arrage or Alec H to get their suggestion on Container->VSPERF (acm, 16:19:02)
    6. first define the messages to be exhanged (acm, 16:20:24)
    7. we have four candidate rpcs to support - minimal - start tests and check status (acm, 16:20:56)
    8. Install - upload a config file - start tests and check ststus (acm, 16:22:28)
    9. I think we need results too (acm, 16:22:52)
    10. reuest feedback on this (acm, 16:23:25)
    11. that's good! (acm, 16:26:40)
    12. ACTION: Sridhar to send .proto to AL. (SRao, 16:27:03)
    13. ACTION: Sridhar to create results container. (SRao, 16:27:26)
    14. - ok, I was imagining a high-level question first, and see where that goes (acm, 16:27:28)
    15. ok, thanks! (acm, 16:29:02)
    16. https://wiki.opnfv.org/display/DEV/Intern+Project%3A+VSPERF+Automated+Deployment+and+Results+Management (SRao, 16:29:17)
    17. yes, I'll add that to the discussion. (acm, 16:29:37)
    18. Eddie is the right guy! (acm, 16:29:51)
    19. not yet (acm, 16:30:13)
    20. is possible to results push to Acumos ? (acm, 16:30:45)
    21. I would assume our VES guy QAlok Gupta knows (acm, 16:31:17)
    22. so question: can any project push results data to Acumos today??? (acm, 16:32:18)
    23. Yes, AT&T , but I don't have any contact with them, directly, so far (acm, 16:33:46)
    24. AL: Started work on Long-Duration testing. (SRao, 16:36:32)
    25. ACTION: Need better support of 'integrating' iperf (non-dpdk) tools. (SRao, 16:38:17)
    26. LDT: Early Stopping, based on monitoring some metrics (SRao, 16:41:15)

  4. OPNFV Strategy - VSPERF. (SRao, 16:42:32)


Meeting ended at 16:59:30 UTC (full logs).

Action items

  1. all need reviews on
  2. acm write e-mail to Eddie Arrage or Alec H to get their suggestion on Container->VSPERF
  3. Sridhar to send .proto to AL.
  4. Sridhar to create results container.
  5. Need better support of 'integrating' iperf (non-dpdk) tools.


Action items, by person

  1. acm
    1. acm write e-mail to Eddie Arrage or Alec H to get their suggestion on Container->VSPERF
  2. UNASSIGNED
    1. all need reviews on
    2. Sridhar to send .proto to AL.
    3. Sridhar to create results container.
    4. Need better support of 'integrating' iperf (non-dpdk) tools.


People present (lines said)

  1. acm (31)
  2. SRao (22)
  3. bfubel (3)
  4. collabot` (3)


Generated by MeetBot 0.1.4.