15:05:02 <srao> #startmeeting vswitchperf
15:05:02 <collabot> Meeting started Wed Mar 13 15:05:02 2019 UTC.  The chair is srao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:02 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:02 <collabot> The meeting name has been set to 'vswitchperf'
15:05:16 <acm> #info Al Morton
15:05:17 <srao> #topic development updates
15:05:45 <srao> #info Need reviews for 2 "live results" patches.
15:07:05 <srao> #action Send reminder to Infra JIRA-338 - Access to Bob.
15:08:31 <srao> #info Sridhar: Completed a new collector for vsperf - multicmd .. Which will run multiple commands - start and stop external collectors
15:09:02 <srao> #info multicmd: collectd, prox, crond, filebeat, plotnetcfg
15:13:20 <srao> #info adding support for how the current test-result measures up with "historical" results.
15:15:22 <srao> #info CI Status.
15:15:37 <srao> #info Node-1 to act as Jenkins Slave.
15:16:39 <srao> #info Mars to pick up from where he had stopped and close it soon.
15:17:18 <srao> #topic VSPERF Results.
15:18:11 <srao> #info Should all the logs of the test remain in /tmp or should be moved to results_timestamp/logs/ folder?
15:20:26 <srao> #info All agree to move logs to results_timestamp/logs instead of just /tmp : This helps in analysis.
15:20:43 <srao> #action Sridhar to submit patch for that change.
15:21:29 <srao> #info VSPERF and Edge Cloud testing.
15:27:08 <srao> #info Option-1: How to correctly concatenate "performance at individual ec-deployment-types" to get the E2E performance?
15:28:34 <srao> #info Compute Nodes the topology is Container-Networking + Overlay Networking
15:29:01 <srao> #info Container networking - Calico is used, and overlay - OVS-Vxlan
15:29:37 <srao> #info Bonding of the Interfaces: Overlay and CN interfaces along with Mgmt & Storage networks.
15:32:18 <srao> #info Check: Network Service Mesh Project
15:33:46 <srao> #info Nokia's DANM
15:35:45 <srao> #info Option-2: Single compute compute Container + VM networking performance.
15:36:22 <srao> #info Al: Now that many projects have fixed the "plumbing" challenge.. performance study may become critical
15:39:41 <srao> #info Al: "multiflows" helps in higher UDP throughput
15:49:19 <srao> #info Tunnel endpoint performance VPP vs OVS  - TGens emulating Tunnels can cater this testcase
15:49:45 <acm> #topic INTERN
15:50:26 <srao> #info Chances of VSPERF getting intern is high.
15:51:16 <acm> #topic Cross-NUMA node test in TST009
15:53:09 <srao> #info the "results" part of the annex maybe out - Al has plan-B to present the same in different way.
15:55:22 <srao> #info Going ahead - "NUMA" approach may be changed (overcome cross-numa issues) by Chip-Vendors such as Intel.
15:58:01 <srao> #topic Al experiments: TCP vs UDP for performance tests... We have enough evidence that UDP is better.
15:59:31 <srao> #info this information may be know at IETF WGs, but not so common knowledge at other communities
15:59:53 <srao> #info Summary; Better go with UDP based Speed and LAtency Test.
16:00:49 <srao> #info https://wiki.opnfv.org/pages/viewpage.action?pageId=29098781
16:03:26 <srao> #endmeeting