14:59:32 <srao> #startmeeting vswitchperf
14:59:32 <collabot> Meeting started Wed Apr 24 14:59:32 2019 UTC.  The chair is srao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:32 <collabot> The meeting name has been set to 'vswitchperf'
15:00:58 <srao> #topic Development Update
15:02:22 <srao> #info Team agree to share jupyter notebook with VSPERF distribution.
15:02:43 <srao> #info tools/notebooks folder.
15:03:55 <srao> #topic Intern Introduction.
15:04:02 <srao> #info Name: Shailesh.
15:04:52 <srao> #info Shailesh will start with Containerization of VSPERF.
15:05:18 <srao> #info VSPERF has initial PoC, Shailesh will explore the alternate approach first.
15:07:08 <srao> #info Is containerizing VSPERF itself Feasible? Can we install ovs-dpdk and vpp & Spawn VM using qemu commands from the container.
15:07:50 <srao> #action Create these queries and try to get responses from the community.
15:13:56 <srao> #topic Version upgrades of upstream software in VSPERF
15:14:24 <srao> #info Currently dpdk 17 is used in VSPERF.
15:16:52 <srao> #info Trevor: Get latest Version support from OVS and VPP then choose the lowest.
15:17:53 <acm> #info Al Morton
15:18:04 <acm> #info VPP Ed Warnicke <hagbard@gmail.com>
15:22:08 <srao> #info For VNF - vsperf copies the forwarding code and dpdk to vnf and builds it.
15:24:12 <srao> #topic VSPERF Going Ahead.
15:25:41 <srao> #info Bob: It is not clear going ahead what the strategy is.
15:27:26 <srao> #info Mars: Investing my spare time, not really official. Some within organization are aware, though.
15:28:42 <srao> #info VSPERF's Plan: Containerization, Analytics and Container-Networking.
15:31:41 <srao> #info Trevor: Dovetail could be potential target.
15:32:00 <srao> #info Trevor: comparison of container-networking technologies.
15:33:14 <srao> #info Trevor: VSPERF should highlight the usecase that will be more relevant going ahead.
15:36:50 <srao> #info Trevor: Analytics interesting, but may not attract real interest from industry.
15:37:50 <srao> #info VSPERF'S Plan: Contribution to Standardization, Container-Networking, Containerization and Analytics.
15:39:47 <srao> #info Al: GSMA (NFVI Profile), IETF (BWG), ETSI-NFV (TST).
15:42:07 <acm> #info give and take with the NFVI reference platform projects (in general, GSMA, Carrier Task Force, New OPNFV Project, Dovetail)
15:44:04 <acm> #info need to understand the new platform performance specifications AND fill any Gaps with VSPERF features
15:45:35 <acm> #info New fast path through Kernel AFXDP? Need to agree on interfaces for the acceleration functions - like IPsec
15:46:25 <acm> #info AF_Packet and AF_XDP
15:50:23 <acm> #action new wiki page, directions for VSPERF in next phase, development, coordination, and Standards projects.
15:51:57 <trevor_intel> #link https://docs.google.com/presentation/d/1nsPINvxQwZZR_7E4mAzr-50eFCBhbCHsmik6DI_yFA0/edit#slide=id.g50f3b155d6_6_626
15:52:26 <srao> #info Trevor: VSPERF at CNF Testbed?
15:54:54 <acm> #info  Another work area - Packet loss from Interupts WHite Paper
15:56:24 <acm> #info  (action for acm) incorporate Binary Search with Loss Verification in VSPERF (try again in Next Release, failed for Hunter)
15:57:31 <srao> #info Trevor for container networking comparison : VSPERF should 'generate' results that will add value.
15:59:58 <srao> #endmeeting