15:03:43 <srao> #startmeeting vswitchperf
15:03:43 <collabot`> Meeting started Wed Jul 31 15:03:43 2019 UTC.  The chair is srao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:43 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:43 <collabot`> The meeting name has been set to 'vswitchperf'
15:04:19 <srao> #topic Development Update.
15:04:36 <srao> #info Configuration Generation Patch is merged.
15:05:00 <srao> #info Results Container patch is updated with changes suggested.
15:06:19 <srao> #info The containers will reside in vswitchperf/tools/docker folder.
15:07:34 <srao> #info Under this there will be 3 subfolders. (a) results (b) deploy (c) control/test
15:07:55 <srao> #info Sridhar: Focus mostly on Loss Pattern Generation.
15:09:24 <srao> #info Pierre: Anca to help vsperf in collecting live results from Ixia TGen.
15:11:24 <srao> #info Loss Patterns from different Traffic generators - Ixia, STC, T-Rex.
15:13:04 <srao> #info First Complete the T-Rex Live-Results (try lower granularity - in ms, else 1 sec).
15:15:38 <srao> #topic Containerizing VSPERF.
15:17:12 <srao> #info Deploy and Control there will 2 variations: 1. Interactive 2. Automated.
15:17:36 <acmacm> #info Al Morton
15:17:54 <srao> #info in Interactive the user can do step by step, where as in automated once the container starts it will do everything as per the configuration.
15:18:32 <srao> #info the Automated version will help in integrating with Dovetail and X-Testing.
15:19:12 <srao> #info in Automated version the user will provide details in the config file - such as testcases to run, the host credentials.
15:27:47 <srao> #info Automated Deploy and Interactive Deploy containers are Ready - needs minor fixes and additional sanity checks.
15:32:30 <srao> #topic Inputs from IETF Meeting
15:34:45 <srao> #info Search algorithms in Virtualization world: Multi-level search (0 and 'x'), probabilistic loss ratio  with small to large duration.
15:35:12 <srao> #info buffer size assessment - back to back testing.
15:38:38 <srao> #info TST009 Compliance: First Start with supporting Benchmarks, then Variations in Metrics.
15:41:03 <srao> #action List the benchmarks and the metrics-variations from TST009. Then Check what all can be supported by which TGen.
15:49:18 <srao> #action Document the usecase for VSPERF where it can be used for cloud dataplane benchmarking and performance testing.
15:56:24 <srao> #info Question: Should we (VSPERF) contribute to chapter-10. All agree that answer is YES.
16:00:31 <srao> #endmeeting