15:00:31 <SRao> #startmeeting vswitchperf
15:00:31 <collabot`> Meeting started Wed Oct  2 15:00:31 2019 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:31 <collabot`> The meeting name has been set to 'vswitchperf'
15:00:46 <SRao> #topic Development Update
15:02:47 <SRao> #info Sridhar: Submitted patch for VSPERF Containerization.
15:03:57 <SRao> #info TODO: Fix Pylint Errors, Fix Documentation.
15:04:35 <SRao> #info Use of protobuf. Python files generated through protofuf is also uploaded. We can exclude that.
15:06:16 <SRao> #info Shailesh to work fixing the pylint errors. Sridhar to do the remaining.
15:07:28 <SRao> #info New Intern.
15:07:53 <SRao> #topic New Intern
15:08:10 <SRao> #info Project: CN benchmarking. Automate the Setup, Deploy and testing.
15:08:44 <SRao> #info Alex: Final year, UK. Started from Monday (30th Sept 2019)
15:09:40 <SRao> #info Multus/DanM: ovs/vpp/sriov/flannel/calico/cilium/tungsten...
15:12:57 <SRao> #info VINAY from NIC.
15:15:04 <SRao> #info Vinay Chaudhary: vcteotia@gmail.com
15:16:16 <SRao> #info By End of 2019 VSPERF will have CN Benchmarking. User can choose the container and the N/W plugin, VSPERF will perform the rest - Setup, Configure, Deploy, Run test, share results, provide anlytics.
15:19:12 <SRao> #info Challenge: (1) Setup of Kubernetes and install of plugins (2) Install OVS and setup TGen (3) Deploy Pod and configure vLinks (4) Run Test and collect results. The challenge is how to insert step 3 between existing steps 2 and 4. Steps 2 and 4 is already what VSPERF is doing.
15:19:44 <SRao> #action Sridhar to share the alternative next week.
15:20:01 <acmacm> #info Al Morton
15:20:46 <SRao> #info Alex's first goal is to automate installation of Kubernetes - Master and Worker, and required (configured) plugins
15:21:59 <SRao> #topic Update on VSPERF Upgrades.
15:23:02 <SRao> #info Emma sent update over mail. She will share inputs on testpmd parameters, and they are working some fixes.
15:23:19 <SRao> #info Emma: Use OVS 2.11.3 instead of 2.11.2
15:23:44 <SRao> #topic VSPERF-Functest
15:24:30 <SRao> #info Discussed integration options with Cedric@Functest in ONS-EU 2019.
15:25:28 <SRao> #info Use functest container as the base and run tests based on YML configuration - list of Test-name and Command to run that test.
15:25:56 <SRao> #info Shailesh has agreed to try this over the weekend.
15:28:13 <SRao> #info Deployment will precede this testcontrol.
15:31:09 <SRao> #topic CNTT-VSPERF
15:33:11 <SRao> #info Al: There are lots of requirements for: RM, RA and RI. Take out the key points from them and start prototyping the implementation of these requirements
15:34:11 <SRao> #info Al: The tests should be derived from these requirements - these tests should cover as much as the requirements. There may be gaps, which we need to identify.
15:43:27 <SRao> #info This page will capture all CNTT-VSPERF activities: https://wiki.opnfv.org/display/vsperf/CNTT+and+VSPERF
15:54:24 <SRao> #info Al: Post discussion with Ch 4. the Table 4.4 to be moved to Ch. 8
15:56:03 <SRao> #info AL: Table 4.10 would be moved to Ch. 8
15:59:20 <SRao> #info AL: What may go into Ch. 4 may be from TST 008.
16:00:20 <SRao> #endmeeting