16:01:17 <SRao> #startmeeting vswitchperf
16:01:17 <collabot> Meeting started Wed Nov  6 16:01:17 2019 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:17 <collabot> The meeting name has been set to 'vswitchperf'
16:01:33 <acmacm> #info Al Morton
16:01:38 <SRao> #topic Development Update.
16:02:33 <SRao> #info All the patches from Emma et. al., is merged.
16:03:08 <SRao> #info Containerization: 20+ stability issues were fixed and updated.
16:04:04 <SRao> #info Few more issue to be fixed before sharing it for reviews.
16:04:29 <SRao> #info VSPERF Software upgrade - 2 issues.
16:05:41 <SRao> #info DPDK: 18.11.2, OVS: 2.12.0
16:06:39 <SRao> #info Error: rte_virtio_pmd_init(): IOPL call failed - cannot use virtio PMD.
16:07:00 <SRao> #action Sridhar to send the complete log.
16:07:38 <SRao> #info New Qemu Version (3.1.1) does not support if=scsi. Error: machine type does not support if=scsi,bus=0,unit=1
16:08:02 <SRao> #info 2 options: Fallback to older version of qemu, or update qemu.py (cmd)
16:09:31 <SRao> #info new version of vpp expects python36-devel (this is not available at centos/rhel 7). Commenting the dependency and running, works..
16:10:01 <SRao> #info VPP version 19.04
16:12:59 <SRao> #info Ready with patch for Intel DPPD-PROX in VLOOP-VNF. Will connect with SampleVNF for review.
16:14:14 <SRao> #info Using L2FWD Mode.
16:20:30 <SRao> #topic CN-Benchmarking
16:22:45 <SRao> #info Installer scripts are ready. Alex to create github project - vsperf-k8s
16:22:54 <SRao> #info share access with the team.
16:25:16 <SRao> #info VSPERF without traffic-generation, phy2phy_tput.
16:25:46 <SRao> #info Alex will start with Multus - OVS and other plugins.
16:28:18 <SRao> #topic Pod12 - Ixia TCLserver-Chassis Connectivity issue.
16:28:32 <SRao> #info It is still open; yet to be fixed. Intel team is working on it.
16:29:46 <SRao> #info While the test is running, collect the per-sec results frm the TGen. Results: Pks-sent, dropped, recvd, latency, etc.
16:30:02 <SRao> #topic Clarifications.
16:31:41 <SRao> #info rx_bps_num: bps l2, rx_bps_den: bps L1
16:37:41 <SRao> #info Goal of Drop-Pattern Analysis: Every iteration - we will collect the Drop-pattern. Associate this Drop-pattern to a type of loss (resource constraint or Transient)
16:38:56 <SRao> #info if we Loss-due-to-RC as A and Loss-due-to-Transient as B. By collecting lot of patterns, and learning from that pattern, can we categorize a new-pattern as A or B.
16:43:43 <SRao> #info Container and Kubernetes metrics: collectd or prometheus.
16:44:59 <SRao> #info 2 node [ master, and worker]. Kubernetes metrics collected Master, where container metrics is from the worker node.
16:45:58 <SRao> #action Formal projects for both parth and Tushar in Wiki.
16:50:03 <SRao> #action Sridhar to reschedule results container demo for Parth and Tushar.
16:52:08 <SRao> #endmeeting