16:00:44 <SRao> #startmeeting vswitchperf
16:00:44 <collabot`> Meeting started Wed Nov 27 16:00:44 2019 UTC.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:44 <collabot`> The meeting name has been set to 'vswitchperf'
16:00:59 <SRao> #topic Development Update.
16:04:42 <SRao> #info: VSPERF Update patch is merged. Now, we have VSPERF with latest version of OVS, VPP, DPDK and Qemu.
16:05:21 <SRao> #info: Received reviews from Shailesh and AL for VSPERF containers.
16:06:46 <SRao> #action Add Alex and Ancuta as reviewers.
16:09:22 <SRao> #info Created version-1 daemonset for the necessary setup
16:09:32 <SRao> #topic CN Benchmarking
16:09:43 <SRao> #info Created version-1 daemonset for the necessary setup
16:09:53 <SRao> #info Working on the automation part.
16:15:43 <SRao> #action Alex to update wiki with daemonset progression - single pod, dual-interface, 2-pods with each dual-interface, single pod with 3-interfaces.
16:16:16 <SRao> #info https://wiki.opnfv.org/display/vsperf/VSPERF-Container+Networking+Benchmarking+and+Testing
16:17:47 <SRao> #info vsperf-br0
16:18:56 <SRao> #action Sridhar to send alex the steps to run vsperf with "OVS" running without TGEN.
16:28:11 <SRao> #topic Ixia Live-Results
16:33:20 <SRao> #info Ancuta shared the current statistics generated - Port level and the traffic level.
16:35:03 <SRao> #info Ancuta submit the changes
16:35:19 <SRao> #action Sridhar to share with ancuta the path to write the files.
16:37:43 <SRao> #topic Kubecon update
16:37:55 <SRao> #info Attended sessions Kubernetes Networking.
16:38:24 <SRao> #info Multiple interfaces is still an open problem - there are not of issues yet to be addressed.
16:39:14 <SRao> #info Attempts for multiple interfaces: celium and Calico. Get it working with celium is very difficult, even the authors are not sure about the approach.
16:39:41 <SRao> #info Calico: Its not clear if single instance of calico is sufficient.
16:40:26 <SRao> #info Most the networking solutions used in production are for single interfaces, and very few with dual-interface.
16:40:45 <SRao> #info No Demo on two data + 1 Mgmt interfaces.
16:41:16 <SRao> #info Most of the demos are targeting enterprises and very few for telcos.
16:41:48 <SRao> #action Create/Update this information in Wiki.
16:42:40 <SRao> #topic Container Metrics
16:43:35 <SRao> #info Parth is working on Prometheus based solution
16:43:44 <SRao> #info We need to collect all the related metrics.
16:44:06 <SRao> #info Yes. It is necessary (else there will be no receiver).
16:44:28 <SRao> #info But, you can write to files while you are testing.
16:45:25 <SRao> #info Update Results container with (a) Prometheus (b) Grafana dashboard for container metrics.
16:45:46 <SRao> #info (c) Connect Grafana with prometheus data.
16:47:02 <SRao> #endmeeting