#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 15:02:41 UTC (full logs).

Meeting summary

  1. New Student Volunteers (SRao, 15:03:17)
    1. Shubham: P4 (TestVNF) (SRao, 15:04:54)
    2. Adarsh: P1 (Kibana For VSPERF) (SRao, 15:05:04)
    3. Parth: GUI for VSperf. (SRao, 15:05:42)
    4. Parth: CN Benchmarking. (SRao, 15:05:50)
    5. ACTION: Sridhar to create wiki to capture Shubham and Adarsh works. (SRao, 15:08:00)
    6. ACTION: Sridhar to create Jira for these two works. (SRao, 15:08:30)

  2. VSPERF and CNTT. (SRao, 15:19:41)
    1. Al: VSPERF is applicable even for post-deployment. (SRao, 15:20:10)
    2. With commercial (virtual) TGens, VSPERF may not add value as it has to rely on T-Rex only (SRao, 15:21:04)
    3. Al: VSPERF supports more than one TGen, and Better Metrics Collection, TST-009 Test Support, (SRao, 15:22:44)
    4. Al: VSPERF brings with it barometer Fully (SRao, 15:23:44)
    5. Al: Get Integrated with X-Testing Quickly. (SRao, 15:24:15)
    6. Hardware Validation (redfish, OPEN) --> Software Pre-Validation (WIP) --> Baremetal Provisioning [Airship] --> NwLinks Validation ( Open for project) --> [Performance Benchmarking (VSperf)] --> OS Deployment [Airship] --> Sw Post-Validation (Open for project) --> Functional Testing (X-Testing) --> Performance Testing (VSPERF, NFVBench, XTesting, Prox, etc..) (SRao, 15:24:49)

  3. TestCases for CN-Benchmarking (SRao, 15:26:51)
    1. The Node-1 and Node-2 will be ready to for Parth and Emanuele To Use it. (SRao, 15:28:32)
    2. ACTION: Sridhar to summarize the test from the "previous works" into a wiki. (SRao, 15:29:35)
    3. Federica: Start with Replicating the previous works -- Same Traffic Patterns. (SRao, 15:30:49)
    4. 2544 Tests with With Different Search Algorithms--- We can start legacy Binary Search. (SRao, 15:32:24)
    5. 2544 With different Search Algorithms. (SRao, 15:32:35)
    6. 2544 with Loss-Verification (SRao, 15:35:01)
    7. Metrics (TST-OO9?) - Throughput, Latency (%le), Delay-Variation (HDR). (SRao, 15:36:02)
    8. Traffic Type: UDP (SRao, 15:36:21)
    9. TCP: Testing match-action (as OVS and VPP are used). (SRao, 15:36:48)
    10. AL: Analyse the UDP/TCP performance in comparison with previous-works. (SRao, 15:37:39)
    11. CNCF --- Refer to the testcases (Traffic type) ? (SRao, 15:38:13)
    12. CSIT - NetworkMesh, MemIf, ... (SRao, 15:41:50)
    13. NetworkServiceMesh not NetworkMesh (SRao, 15:43:12)
    14. https://github.com/cncf/cnf-testbed/tree/master/examples/use_case/3c2n-csp (SRao, 15:44:27)
    15. Ancuta: Able to deploy the VM (on Pod-12, Node-5). (SRao, 15:47:00)
    16. Ancuta: Once I get the CLA approved, Will submit the patch. (SRao, 15:48:53)
    17. ACTION: Sridhar to create wiki for GUIl (SRao, 15:58:58)


Meeting ended at 16:01:49 UTC (full logs).

Action items

  1. Sridhar to create wiki to capture Shubham and Adarsh works.
  2. Sridhar to create Jira for these two works.
  3. Sridhar to summarize the test from the "previous works" into a wiki.
  4. Sridhar to create wiki for GUIl


People present (lines said)

  1. SRao (34)
  2. collabot` (3)


Generated by MeetBot 0.1.4.