16:02:35 <SRao> #startmeeting Vswitchperf
16:02:36 <collab-meetbot> Meeting started Wed Nov  4 16:02:35 2020 UTC and is due to finish in 60 minutes.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:36 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:36 <collab-meetbot> The meeting name has been set to 'vswitchperf'
16:02:44 <SRao> #info Development Update.
16:04:05 <SRao> #topic Development Update
16:05:18 <SRao> #info Multidimensional TestVNF: Patch to build TestVNF with 10 Tools is submitted by Shubham.
16:06:01 <SRao> #info 10 Tools: Collectd, stressng, fio, unixbench, openssl, ndpi, trex, dppd-prox, dpdk, ramspeed.
16:07:01 <SRao> #info This patch will only build VNF with these tools. Whereas Config+Control will be done separately.
16:08:25 <SRao> #info For each of these tool, scripts to config and control will be added the TestVNF. Only then patch will be closed.
16:09:56 <SRao> #info Upgrade to Newer Versions of Kernel might be a challenge with DPDK. DPDK also has to be changed, and it needs Change in VSPERF Code.
16:10:24 <SRao> #info Before Upgrading to newer OS versions, we will have to ensure DPDK build with Newer Kernel Versions, in VSPERF.
16:14:37 <SRao> #info Enlist Target OS Version - The corresponding Kernel used - and matching DPDK Version. Then make changes in VSPERF code to build successfully.
16:15:42 <SRao> #info Going ahead with Newer Kernel also needs update of l2fwd application. https://github.com/opnfv/vswitchperf/tree/master/src/l2fwd
16:16:46 <SRao> #action Connect with Emma Finn on this: L2Fwd and new Kernel Version Issue.
16:16:47 <acmacm> #info acmacm tried Fedora 32 in general - was not nice as a vm on Vbox
16:22:22 <SRao> #info We will go with DPDK 19.11.5 (LTS), Fedora 30.
16:28:14 <SRao> #info Q-to-answer: Which is the Most recent version of T-rex that we can use with VSPERF APIs?
16:28:29 <SRao> #info Works till 2.48.
16:30:07 <acmacm> #info https://github.com/trexminer/T-Rex/releases
16:31:56 <SRao> #action Test with newer version of T-Rex on Pod12
16:35:49 <SRao> #topic CNB
16:36:08 <SRao> #info Cross-Numa Tests were completed.
16:42:11 <SRao> #info Plots are uploaded to Dropbox.
16:53:35 <SRao> #endmeeting