16:03:13 <SRao> #startmeeting vswitchperf
16:03:13 <collab-meetbot`> Meeting started Wed Mar 10 16:03:13 2021 UTC and is due to finish in 60 minutes.  The chair is SRao. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:13 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:13 <collab-meetbot`> The meeting name has been set to 'vswitchperf'
16:03:29 <SRao> #topic Name-Change.
16:03:51 <SRao> #info ViNePerf name is approved. We will start using the name from next meeting.
16:04:29 <SRao> #info The IT-Ticket is opened to change the following: repo-name, jira-tag, mailing-list reference.
16:04:53 <SRao> #topic Wiki-Update.
16:05:26 <SRao> #info In Wiki (https://wiki.anuket.io/) project is already renamed to VinPerf (Thanks to LFN team).
16:06:25 <SRao> #info Categories: Development, Experimental-Studies, Internships, Readouts and Articles, Releases, Summits & COnf, Test Mehtodologies.
16:06:50 <SRao> #info New category will be added - only if required.
16:07:09 <SRao> #action Sridhar to change vsperf -> vineperf in wiki-pages.
16:07:56 <SRao> #topic K8S CNB.
16:09:29 <SRao> #info Started the reruns today - VPP and RFC2544.
16:09:46 <SRao> #info VPP rx-miss Reason: rx-miss happens typically when vpp is not able to service rx queue (either because it is too busy or because kernel is not giving him opportunity to do the job)
16:10:15 <SRao> #info Increase the CPUs for VPP.
16:11:18 <SRao> #info Check if Increasing cpus to the VPP the rx-miss will decrease or not.
16:13:10 <SRao> #info Tried with VPP-Vhostuser with Userspace CNI. Unfortunately, for now, we cannot do this.
16:14:18 <SRao> #info Currently only combination allowed with VPP is memif (https://github.com/intel/userspace-cni-network-plugin/blob/master/cnivpp/cnivpp.go).
16:15:43 <SRao> #info OVS_DPDK with memif is a WIP for userspace CNI.
16:17:32 <SRao> #info Kubevirt: One of the options to run VMs in Kubernetes cluster.
16:18:08 <SRao> #info Open Question: How the performance is affected when the VM is encapsulated inside a container.
16:19:18 <SRao> #info This could a interesting problem to work on.
16:21:15 <SRao> #info Resource Requirement: Additional Disks on 2 servers.
16:30:36 <SRao> #info Pod Has 2 disks in each server, we may be able to use it.
16:35:18 <SRao> #info Trevor: Understand the datapath -- every element involved - in Kubevirt case. Once we know it, one can have an Idea about the performance bottlenecks.
16:53:27 <SRao> #info NSB of Yardstick may not be revived. We can consider reusing some components (libraries).
17:01:12 <SRao> #info (a) Look for extended-stats for multipod (b) Rerun -- while the test is run, we can collect more stats from switch/tgen.
17:02:44 <SRao> #endmeeting