07:30:16 <Ana_C> #startmeeting Yardstick workmeeting
07:30:16 <collabot> Meeting started Mon Aug  3 07:30:16 2015 UTC.  The chair is Ana_C. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:16 <collabot> The meeting name has been set to 'yardstick_workmeeting'
07:30:29 <Ana_C> hi everyone
07:30:40 <hwkubi> hi~
07:30:43 <Ana_C> please type your names
07:30:43 <hello_> hi
07:30:54 <Ana_C> #info Ana Cunha
07:31:04 <hongbo> #info hongbo
07:31:09 <hwkubi> #info kubi
07:31:09 <hello_> #info QiLiang
07:31:12 <krihun> #info Kristian Hunt
07:31:12 <rex_lee> #info Rex
07:31:14 <Jingwen> #info Jingwen Hou
07:31:24 <Patrick_> #info Patrick
07:31:37 <Ana_C> let's start with follow up on jira issues
07:31:54 <Ana_C> #link https://wiki.opnfv.org/yardstick
07:32:40 <Ana_C> #info check the page https://wiki.opnfv.org/sprints for the epics
07:32:54 <Ana_C> progress jingwen
07:33:10 <Ana_C> on your tasks?
07:33:31 <Ana_C> #topic jira
07:34:13 <Jingwen> YARDSTICK-83
07:34:48 <Jingwen> I have contacted colleague of compass, the cases not implemented yet
07:35:36 <Ana_C> #info started to work on tasks YARDSTICK-83, support for compass
07:35:46 <Ana_C> do you need help?
07:36:16 <Jingwen> i think i can do it ,thanks
07:36:25 <Ana_C> ok
07:36:37 <Ana_C> test case for storage?
07:37:18 <Jingwen> YARDSTICK-93 and YARDSTICK-34 will be implented later
07:37:40 <Ana_C> #info Yardstikc-93 and Yardstick-34 on-going
07:37:41 <hwkubi> implement
07:37:54 <Ana_C> will you be able to demo on the 20 august?
07:38:12 <Jingwen> ok
07:38:33 <Ana_C> on lf pod also?
07:39:22 <Jingwen> i'm not sure
07:40:07 <Ana_C> ok, we settle for a sample demo on the 20th
07:40:38 <Ana_C> #agreed Storage erformance sample to be included in demo on 20th August
07:40:57 <Ana_C> #action Jingwen to prepare the demo for the storage performance
07:41:08 <Jingwen> ok, thank you . i will connect with you later to talk about the details on demo
07:41:17 <Ana_C> anything else on test cases?
07:41:38 <Jingwen> no
07:41:42 <Ana_C> yes, contact me and we discuss the details.
07:41:48 <Jingwen> ok
07:42:00 <Ana_C> Sean, anything toreport on test cases?
07:43:18 <Ana_C> anything to report on framework, database Yardstick-60?
07:44:00 <hello_> i' m not start code yet
07:44:21 <hello_> just did some monogodb learning
07:44:36 <hello_> and some sub-function seperation
07:44:45 <Ana_C> ok. did you check what is on-going in functest?
07:45:02 <hello_> yes
07:45:11 <Ana_C> probably we'll need to give input to the api they proposed
07:45:17 <Ana_C> any thoughts?
07:45:38 <hello_> last Friday i did code review
07:45:45 <Ana_C> #info investigation on Yardstick-60 on-going
07:45:59 <Ana_C> ok, can you update us?
07:46:59 <hello_> #link https://gerrit.opnfv.org/gerrit/#/c/1048/
07:47:26 <Ana_C> thanks
07:47:50 <Ana_C> anything else ? do you need any help?
07:48:13 <hello_> Guy Rodrigue Koffi initialized db storage server
07:48:48 <hello_> no thanks,
07:49:46 <Ana_C> #topic VTC
07:49:56 <Ana_C> akis, anything to report?
07:50:35 <Ana_C> have you started on the test cases?
07:51:23 <Ana_C> #action Ana to follow up on VTC
07:51:30 <Ana_C> #topic bugs
07:51:54 <Ana_C> any new faults found? progree on the opened bugs?
07:52:38 <krihun> I opened a new bug YARDSTICK-95
07:53:09 <akiskourtis> Hello Ana, Yes we have started on testing the use cases of the VTC
07:53:18 <hello_> i add new bug jira YARDSTICK-96
07:53:37 <hwkubi> "YARDSTICK-97 algorithm of arithmetic make an error " code has been commit to gerrit review branch
07:53:53 <hello_> bug fix code was already commit for review
07:54:48 <Ana_C> ok, how is it going with reviewing the code?
07:54:54 <Ana_C> do you get feedback?
07:55:30 <akiskourtis> we have managed to summarize all use cases in different independent versions
07:55:48 <akiskourtis> and we proceed to automate the testing of them
07:55:59 <Ana_C> akis, ok. do you need help to proceed? additional test cases?
07:56:46 <akiskourtis> for now we believe we cover a native scenario, one with dpdk, and one with docker
07:56:55 <Ana_C> can you present shortly the VTC on next week's thursday meeting (15 min)?
07:57:11 <Ana_C> any new requirements on the framework?
07:57:35 <akiskourtis> I will have to check with Intel, because NCSR is closed on vacation from 3-17 of August
07:57:51 <hwkubi> when i implement JIRA:YARDSTICK-49, i find that there is some redundance in every runner type .py
07:57:56 <akiskourtis> do you want me to update gerrit, or jira?
07:58:34 <Ana_C> akis, yes, pease update gerrit and the status on jira.
07:58:46 <Ana_C> akis, we check with michael for a suitable date.
07:59:06 <akiskourtis> ok great thank you
07:59:11 <Ana_C> #action akis to update status of VTC test cases in Jira and code in Gerrit.
07:59:36 <Ana_C> hwkubi, how do you advise to proceed ?
07:59:46 <hwkubi> some common part in every specific runner type should be abstracted into base.py
08:00:49 <Ana_C> #info Ana to add a task to abstract functions in runners to avoid redundancy
08:01:08 <hello_> ana, one question about jira yardstick-26 lxc
08:01:33 <hello_> Does this jira means we use lxc to test yardstick framework itself, for something link function test.
08:01:36 <Ana_C> yes?
08:02:17 <Ana_C> yes, correct.
08:02:26 <hello_> Does lxc just means linux container can we use docker directly?
08:03:14 <Ana_C> let's add info to the jira, ok? so it is clear and we can discuss further.
08:03:44 <hello_> ok, that's good.
08:04:05 <Ana_C> #action Ana to add info in Yardstick-26
08:04:10 <hwkubi> by the way ,the Unassigned JIRA "YARDSTICK-27:Framework: Run test cases in multiple instances" have been implemented or not?
08:05:02 <Ana_C> no
08:05:12 <Ana_C> i wll double check, ok?
08:05:32 <hwkubi> "multiple instances" means VMs?
08:05:37 <hwkubi> ok
08:05:38 <Ana_C> #action Ana to check whether Yardstick-27 is implemented
08:06:37 <Ana_C> thanks for a good meeting. let me know if I missed something !
08:06:44 <Ana_C> #endmeeting