07:30:01 <anac1> #startmeeting Yardstick work meeting
07:30:01 <collabot> Meeting started Mon Sep  7 07:30:01 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:01 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:30:08 <anac1> #info Ana Cunha
07:30:17 <anac1> hi, please info your names
07:30:26 <QiLiang> #info QiLiang
07:30:29 <krihun> #info Kristian Hunt
07:30:57 <kubi> #info gao liang
07:31:09 <anac1> #topic new project member
07:31:13 <Jingwen> #info Jingwen Hou
07:31:26 <anac1> #info wuzhihui has joined the yardstick project
07:31:28 <anac1> welcome
07:31:34 <QiLiang> welcome
07:31:35 <kubi> welcome
07:31:39 <krihun> welcome
07:32:02 <anac1> #info wuzhihui will install yardstick in ZTE community lab
07:32:04 <Jingwen> welcome
07:32:30 <anac1> #topic faults
07:32:48 <anac1> #info any progress on Yardstick-95 ?
07:33:09 <anac1> krihun, it is assigned to you
07:33:30 <krihun> no progress so far
07:33:43 <anac1> #info no progress so far
07:34:09 <anac1> #info build failed today, check https://build.opnfv.org/ci/job/yardstick-fuel-master/16/console
07:34:46 <anac1> let's monitor the build, try to fix the faults as they occur, ok?
07:35:05 <kubi> yes
07:35:21 <anac1> i will open a jira ticket once per week, monday moring, in case there is a fault
07:35:24 <anac1> is that ok?
07:35:42 <QiLiang> ok
07:35:46 <kubi> ok
07:36:03 <anac1> #action anac to monitor the build and open jira ticket once per week, mondays, in case of faults
07:36:11 <anac1> #topic ha
07:36:27 <QiLiang> Patrick cannot attend today's IRC meeting.
07:36:38 <anac1> ok, i saw a few comments on https://etherpad.opnfv.org/p/yardstick_ha
07:36:38 <QiLiang> I discussed with him on HA issuse earlier and represent him to answer Jorgen's question at https://etherpad.opnfv.org/p/yardstick_ha
07:36:59 <anac1> ok, i saw the comments, good
07:37:37 <anac1> i have created a test case Yardstick-135, check and we can discuss with patrik when available
07:37:47 <anac1> #info new test case added Yardstick-135
07:37:56 <QiLiang> ok
07:38:15 <anac1> i will ask jorgen to comment, he is not connected now
07:38:30 <anac1> #topic Yardstick folder structure
07:38:49 <anac1> #info new document structure has been decided in Releng
07:39:11 <anac1> check etherpad https://etherpad.opnfv.org/p/yardstick_folders
07:39:37 <anac1> also, a suggestion for a folder structure for unit+functiona+test cases
07:39:50 <anac1> #action all - comment on folder structure in https://etherpad.opnfv.org/p/yardstick_folders
07:40:36 <anac1> #topic result api & test dashboard
07:40:58 <anac1> a discussion has started with functest
07:41:32 <QiLiang> the discussion is on the maillist ?
07:41:35 <anac1> #info joint meeting with functst on thursday sept 10, utc 7:00-8:00
07:41:56 <anac1> yes, but i think we need to discuss functest-yardstick, so i propose a joint meeting
07:42:17 <anac1> we can use our meeting this thursday and extend with 30 min
07:42:20 <anac1> is that ok?
07:42:22 <QiLiang> ok
07:42:28 <kubi> ok
07:42:47 <anac1> i would like that we make a trial of the api
07:43:07 <anac1> functest has a mongodb, temporary in orange, we can use
07:43:18 <anac1> the db in releng is not yet operational
07:43:23 <anac1> any comments?
07:43:31 <QiLiang> i did result_collection_api test
07:43:37 <anac1> yes?
07:43:54 <anac1> do you agree with the datamodel?
07:44:16 <QiLiang> i gave some comments and the new code is already merged
07:44:26 <anac1> ok
07:44:34 <anac1> qiliang, hope you can participate
07:44:53 <anac1> and bring your comments
07:44:55 <QiLiang> i will participate :)
07:45:08 <anac1> great, thanks !
07:45:25 <anac1> we will also discuss the testing dashboard
07:46:09 <anac1> as this will be the way we present the opnfv testing results, let's try to understand what we need
07:46:29 <anac1> graphs, tables
07:46:54 <anac1> #info anac to send a meeting invitation for functest-yardstick meeting
07:47:35 <anac1> comments, questions on this subject?
07:48:15 <anac1> #topic kvm
07:48:17 <QiLiang> dose testing dashboard code is on opnfv git ?
07:48:45 <anac1> the dashboard does not yet exists
07:49:04 <QiLiang> do we need implement cyclictest scenario or the kvm-team will do?
07:49:16 <anac1> we need to help
07:49:23 <anac1> anyone interested?
07:49:38 <QiLiang> I am
07:49:45 <anac1> great !
07:49:51 <anac1> i will let them know.
07:49:57 <anac1> they do not have a pod yet
07:50:32 <anac1> the idea is to execute the cyclictest in kvm merge jjb
07:50:32 <QiLiang> then where to test ?
07:50:52 <anac1> and also after as platform testing (in yardstick jenkins job)
07:51:50 <anac1> they will get a pod space, fdegir, do you know?
07:52:19 <fdegir> anac1: are you talking about 5 node POD?
07:52:19 <anac1> #action anac to check where kvm will test their code
07:52:39 <anac1> where will kvm do their test?
07:52:48 <fdegir> for the verify and merge jobs, we might get 1 server
07:52:55 <fdegir> and do the testing on it
07:53:06 <anac1> which one, is it decided?
07:53:12 <fdegir> anac1: not yet
07:53:18 <fdegir> we're waiting to get the servers
07:53:23 <fdegir> after 13th of september
07:53:39 <anac1> ok, will put a question on jira, so it is visible
07:54:14 <anac1> qiliang, in the meantime we can proceed with the scenario, right?
07:54:28 <QiLiang> yes
07:54:39 <anac1> ok, let's do that
07:54:45 <Jingwen> hi,Ana.    about yardstick-127 Test Case: OPNFV_YARDSTICK_TC018_Network Timeout
07:54:52 <Jingwen> can you explain what is the network timeout duration when a link failure occurs ?
07:54:59 <Jingwen> From the failure to detect the time of failure, right?
07:55:23 <anac1> from the failute to detect the time of failute to resume service
07:55:56 <anac1> how long time the network does not reply
07:56:28 <anac1> Jingwen, want to take yardstick-127?
07:56:35 <Jingwen> yes
07:56:39 <anac1> great !
07:56:46 <kubi> how to resume service?
07:56:48 <Jingwen> whether the network timeout duration when a link failure occurs can be measured by ping
07:57:26 <anac1> ping is one method, maybe there are other more accurate ?
07:58:33 <anac1> some nodes cannot handle longer time with no reply, that's why we have this testcase
07:58:42 <anac1> anything else?
07:59:00 <Jingwen> i will investigate
07:59:07 <anac1> ok, sounds good
07:59:47 <anac1> #info meeting on mondays utc 14:00 will focus on virtual traffic classifier
08:00:25 <anac1> that all for today, meet again on thursday
08:00:30 <anac1> #endmeeting