14:00:02 <anac1> #startmeeting Yardstick Work Meeting
14:00:02 <collabot> Meeting started Mon Sep  7 14:00:02 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:02 <collabot> The meeting name has been set to 'yardstick_work_meeting'
14:00:10 <anac1> #info Ana Cunha
14:00:17 <anac1> hi, please info your name
14:00:50 <Akis__> #info Akis Kourtis
14:01:18 <krihun> #info Kristian Hunt
14:02:03 <anac1> #topic vTC code in Yardstick repo
14:02:37 <anac1> Akis_: do you get the permission you need to push code?
14:03:08 <Akis__> yes we managed to solve this problem, and now I have full access on both Jira and gerrit
14:03:22 <anac1> great!
14:03:37 <anac1> what is the plan ?
14:04:33 <anac1> you need to push in smaller batches and get it reviewed (gerrit review)
14:04:38 <Akis__> the plan is to upload first the .rst file with the description and general guidelines for the vtc
14:05:14 <Akis__> yes also because we usually build a few libraries, should we upload all of those?
14:05:29 <Akis__> or just make a script to do this automatically?
14:05:33 <anac1> ok, check documentation structure here: https://etherpad.opnfv.org/p/yardstick_folders
14:06:00 <anac1> where will the script fetch from?
14:06:28 <Akis__> from a bitbucket repository
14:06:46 <Akis__> or we can include the libraries
14:07:16 <anac1> we need to investigate
14:07:48 <anac1> #action anac and Akis__ to check the dependencies to bitbucket and how to solve the libraries
14:07:48 <Akis__> yes we are currently discussing this with Intel, and try to find the best way
14:08:13 <anac1> ok, we fix this, i will open a jira task and assign to you, ok?
14:08:39 <Akis__> ok perfect
14:08:44 <anac1> #action anac to create a task and assign to Akis__
14:09:36 <anac1> release-B will be openstacl liberty, what is your plan for vtc?
14:09:59 <anac1> openstack
14:10:29 <Akis__> we currently support kilo, but I see no major issues to support liberty also
14:11:05 <anac1> ok, can you uplift to liberty ?
14:11:31 <Akis__> yes we always update and test to the latest
14:11:43 <anac1> #info vTC currently on openstack kilo, plan to uplift to liberty
14:11:46 <anac1> good
14:12:38 <anac1> you need a committer to merge your code
14:13:08 <anac1> i'll keep track and encourage yardstick commiters to review
14:13:30 <Akis__> ok thank you
14:13:52 <anac1> to test the vtc, how much hadware is required ?
14:14:18 <anac1> hardware
14:14:35 <Akis__> physical hardware none, just a simple NIC
14:14:49 <Akis__> the VM should have at least 2 vNICs
14:15:32 <anac1> #info to test vTC, the VM should have minimum 2 vNICs
14:15:34 <Akis__> then it depends if you want to test also SR-IOV, but it works in the most simple test case scenario
14:15:58 <anac1> ok, takink SR-IOV in the picture
14:16:50 <Akis__> then one dual-port SR-IOV enabled NIC, incoming and outgoing traffic
14:17:02 <vincenzo_riccobe> Do we want to add to the list a packet generator or this is implicit?
14:17:18 <anac1> #info with SR-IOV, one dual-port SR-IOV enabled NIC
14:17:31 <anac1> what is the requirment on packet generator?
14:17:40 <Akis__> I believe it should be omitted for now, as one can choose his traffic generation
14:17:48 <anac1> ok
14:18:13 <vincenzo_riccobe> it makes sense
14:19:17 <anac1> what about the framework, shall we add an interface from yardstick to it?
14:19:53 <vincenzo_riccobe> the idea for that would be to have API exposed from the framework to yardstick
14:20:20 <anac1> ok, anyone object?
14:20:52 <anac1> #agreed design an API from vTC framework to Yardstick
14:21:12 <anac1> any idea how to move on the API? or have you started?
14:21:20 <vincenzo_riccobe> not started yet
14:21:39 <anac1> #action anac to add a task for the API design (from vTC to Yardstick)
14:21:49 <anac1> can i assign you, vincenzo ?
14:22:02 <vincenzo_riccobe> I think the API should depend on the test cases we want to implement within the framework
14:22:06 <vincenzo_riccobe> sure
14:23:26 <anac1> we have 2 test cases to start with, but let's specify a few more so we don't have to refactor the api too often
14:23:46 <anac1> does that make sense?
14:24:10 <vincenzo_riccobe> if the two test cases proposed by Michael are fine we could start from them, and can follow the approach you suggest
14:24:35 <anac1> how much work is to modify the api later ?
14:24:53 <vincenzo_riccobe> do we want to arrange a brief meeting at the end in 3/4 days to talk about the test cases?
14:25:18 <anac1> exactly what i was thinking
14:25:26 <anac1> when is michael available?
14:25:53 <anac1> friday this week work?
14:25:57 <vincenzo_riccobe> I think Thursday and Friday, I dont' know his dayly agenda bdw
14:26:04 <vincenzo_riccobe> daily
14:26:18 <vincenzo_riccobe> yep, should work
14:26:42 <anac1> let's say friday preliminary, we move if it doesn't work
14:27:01 <vincenzo_riccobe> ok
14:27:06 <Akis__> ok
14:27:09 <anac1> #info separate meeting to discuss test cases end of this week
14:27:40 <anac1> we like your visualization with grafana, plan to do the same for the rest of yardstick
14:28:04 <anac1> for the real time data
14:29:07 <Akis__> very good, grafana is very nice, available to help
14:29:56 <anac1> will put info and questions in yardstick-130
14:31:34 <anac1> have you a folder structure suggestion for the code?
14:31:48 <vincenzo_riccobe> for the framework?
14:32:24 <anac1> yes, framework and also vtc, if understand you plan to contribute both?
14:33:02 <vincenzo_riccobe> we don't have a structure yet
14:33:19 <anac1> add your suggestion to https://etherpad.opnfv.org/p/yardstick_folders, when you are ready
14:33:21 <vincenzo_riccobe> do we want to have a brief talk about it during the planned call?
14:33:31 <anac1> ok, we can do that
14:33:34 <vincenzo_riccobe> ok
14:34:32 <anac1> great demo last thursday, thanks a lot
14:34:54 <anac1> we have recorded it, on its way to be uploaded to opnfv youtube channel
14:34:55 <Akis__> thank you Ana!
14:35:30 <Akis__> than you for your support
14:36:02 <anac1> thank you for the amazing work ! michael mentioned you plan to make another demo, any idea on when ? one month time?
14:36:22 <vincenzo_riccobe> I think is going to be in one month time, yes
14:36:39 <vincenzo_riccobe> the idea was to show some features of the framework
14:37:13 <vincenzo_riccobe> coupled with the vTC
14:37:18 <anac1> ok, i will book a preliminary slot october 1st
14:37:32 <vincenzo_riccobe> ok
14:38:29 <anac1> i guess we got some action points and looks like you know what to do
14:38:34 <anac1> anything else?
14:39:05 <vincenzo_riccobe> it's fine on my side
14:39:14 <Akis__> me too
14:39:34 <anac1> thanks for today, i'll book the call for friday
14:39:39 <anac1> #endmeeting