07:00:01 <anac1> #startmeeting Yardstick-Functest joint meeting
07:00:01 <collabot> Meeting started Thu Sep 10 07:00:01 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:00:01 <collabot> The meeting name has been set to 'yardstick_functest_joint_meeting'
07:00:29 <anac1> #info Ana Cunha
07:00:50 <QiLiang> #info QiLiang
07:01:06 <morgan_orange> #info Morgan Richomme
07:01:32 <anac1> hi morgan, you on audio?
07:02:25 <Patrick_> #info Patrick
07:02:27 <morgan_orange> I am coming
07:02:46 <anac1> great, lets wait for morgan on audio
07:03:56 <anac1> #topic Minutes from joint meeting yardstick-functest
07:04:39 <anac1> #info Morgan presents background
07:05:20 <anac1> #info Morgan demos the testing dashboard
07:06:30 <anac1> #info results from tests are currently not post-processed
07:07:07 <anac1> #info need to post-process the results for release-B
07:07:47 <anac1> #Morgan shows the current functest results
07:07:57 <anac1> #undo
07:07:57 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c88b90>
07:08:16 <anac1> #info current functest results are shown
07:09:04 <anac1> #info intention is to use mongoDB as centralized collection for the testing from the test projects
07:09:39 <anac1> #info possible to push results to dB
07:11:05 <anac1> #info demo - functest last run from last night
07:11:17 <jose_lausuch> #info Jose Lausuch
07:11:38 <anac1> #info vping test - measures fail yes/no
07:12:28 <anac1> #info push results to dB after test execution
07:13:29 <anac1> #info mongodB trial in Ornage Cloud
07:13:37 <anac1> #undo
07:13:37 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c88f90>
07:13:51 <anac1> #info mongodB trial in OrangeCloud
07:15:42 <anac1> #info create a test project in the dB
07:16:03 <anac1> #info declare test cases under the project
07:17:40 <anac1> #info results are stored following this structure - per pod
07:18:26 <anac1> #info payload is the results from the tsts
07:18:31 <anac1> #undo
07:18:31 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c88dd0>
07:18:47 <anac1> #info payload is the results from the test run
07:25:11 <anac1> #info morgan shows the script he developed for the dashboard
07:26:12 <anac1> #info the script includes information on what to plot in the dashboard
07:26:33 <anac1> #info and the type of graph (e.g. bar, etc)
07:28:35 <anac1> #info need to consolidate the api
07:28:50 <anac1> #info need to develop unittest for the api
07:29:06 <anac1> #info need to move to target dB and test it
07:29:54 <anac1> #info proof of concept next week
07:32:04 <anac1> #info how long will th data be stores in dB ?
07:32:31 <anac1> #info no strategy yet, aim to store the entire release
07:34:11 <anac1> #info api version handling ?
07:35:57 <anac1> #info how is the structure of the dB handled ? releng is responsible fo the dB
07:36:23 <anac1> #info dB schema is stored in repo
07:36:47 <anac1> #info is releng also responsible for dB replication ? yes
07:37:22 <anac1> #info mechanism for backup the data should be developed by releng
07:37:40 <QiLiang> do we have any datamodel for dashboard
07:37:55 <anac1> #info data model to be added in releng repo
07:40:54 <anac1> #info linux foundation is responsible for the dashboard, the data is responsibility of the project
07:40:54 <anac1> qiliang, can i add you to this work?
07:40:56 <QiLiang> ok
07:41:41 <anac1> #action anac to include qiliang in the proof of concept
07:44:30 <anac1> #info dashboard will be static, view after the test is executed
07:49:19 <anac1> more questions?
07:50:23 <QiLiang> no from me
07:50:52 <anac1> ok
07:52:59 <anac1> that's all for today
07:53:03 <anac1> #endmeeting