07:30:02 <anac1> #startmeeting Yardstick work meeting
07:30:02 <collabot> Meeting started Mon Sep 21 07:30:02 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:02 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:02 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:30:09 <anac1> #info Ana Cunha
07:30:20 <anac1> hi everyone
07:30:28 <QiLiang> #info QiLiang
07:30:35 <kubi> #info gao liang
07:30:45 <YiminWang1> #info Yimin Wang
07:30:49 <patrick1> #info Patrick
07:30:49 <krihun> #info Kristian Hunt
07:30:53 <anac1> #topic New yardstick project member
07:31:18 <anac1> #info Yimin Wang has joined yardstick project
07:31:21 <anac1> welcome!
07:31:22 <QiLiang> welcome!!!
07:31:23 <patrick1> welcome!
07:31:27 <krihun> welcome!
07:31:28 <kubi> welcome!
07:31:30 <YiminWang1> Hi, everyone
07:31:46 <YiminWang1> thx
07:31:53 <anac1> #topic bugs
07:31:54 <jingwen> #info Jingwen Hou
07:32:14 <jingwen> welcome Yimin
07:32:16 <anac1> #info progress on yardstick-142
07:32:39 <anac1> #info progress on yardstick-143
07:33:28 <jingwen> yardstick-143 ,the fix code is already committ to gerrit
07:33:46 <anac1> #info yardstick-143 on-going, code to be pushed
07:33:53 <anac1> thanks jingwen!
07:34:14 <anac1> #action anac to follow up yardstick-142
07:34:20 <jingwen> you are welcome
07:34:26 <anac1> #topic cooperation with ha
07:34:51 <anac1> should we have an sw architecture meeting to discuss the framework?
07:35:11 <QiLiang> agree
07:35:22 <anac1> patrik?
07:35:25 <patrick1> agree too
07:35:47 <anac1> ok, i'll plan for next week, ok?
07:36:00 <QiLiang> ok for me
07:36:03 <patrick1> sure, thank you.
07:36:20 <anac1> #action anac to call for a sw architecture meeting next week, to evolve yardstick framework
07:36:47 <anac1> #topic cooperation with vsperf
07:37:05 <anac1> #info follow up meeting planned for september 30th
07:37:10 <patrick1> we can discuss in etherpad about this issue synchronously
07:37:21 <anac1> #action anac to call for meeting with vsperf
07:37:27 <anac1> patrick1: yes, agree
07:38:06 <anac1> #topic release-b planning
07:38:26 <anac1> #info test projects will receive requests for test cases until september 25th
07:39:01 <QiLiang> test cases cannot update after 9.25 ?
07:39:40 <anac1> we want the other projects to inform us if they need help by sept 25th
07:40:14 <anac1> this means, for example, project "x" needs yardstick help with test cases
07:40:35 <QiLiang> got it
07:40:40 <anac1> we can change the test cases after, also add our own (initiated by the yardstick team)
07:41:05 <anac1> i think after we know who needs help from us it is easier to discuss the architecture
07:41:27 <patrick1> totally agree.
07:41:30 <QiLiang> +1
07:42:25 <anac1> #info yardstick will add one test case from odl
07:42:43 <anac1> this was discussed last thursday, on test&performance meeting
07:43:00 <patrick1> together with cperf team?
07:43:11 <anac1> yes
07:43:41 <anac1> we agreed to reuse one test case to start with, performance-related
07:43:56 <anac1> when i get the details sorted out, i will write a jira task
07:44:04 <patrick1> ok. good.
07:44:18 <anac1> probably we will get help from cperf or sfc team
07:44:33 <patrick1> that would be helpful.
07:44:54 <anac1> yes, for all of us, it think
07:45:21 <anac1> #topic cyclictest
07:45:32 <anac1> #info suggestion added in yardstick-122
07:46:08 <anac1> kvm project is analysing, they will comment
07:46:25 <QiLiang> i see
07:46:47 <anac1> qiliang: any new comments?
07:47:59 <QiLiang> agree with jorgen, and there some little question latter i will add on yardstick_ha etherpad for discussing
07:48:19 <anac1> great, thanks !
07:48:47 <anac1> #action all to check etherpad yardstick_ha and add comments/ideas/questions
07:49:04 <anac1> #topic support for centOS
07:49:30 <anac1> #info troubleshooting on-going, jorgen working on this
07:50:52 <anac1> #topic jenkins jobs
07:51:27 <anac1> #info yardstick will have daily and weekly jobs
07:51:55 <anac1> yardstick-147 created to help identify what test cases/samples to run when
07:53:16 <anac1> i saw the functional tests, thanks !
07:53:31 <kubi> :)
07:53:56 <anac1> kubi: well done!
07:54:00 <patrick1> If we want to speed up the total time when we execute samples in CI, maybe some test case's durations will be changed to shorter.
07:54:53 <wuzhihui> hi,Ana.I already execute all the testcases below /yardstick/sample.
07:55:04 <anac1> patrick, agree, we need to find out which ones (a subset) to run daily and still get a good view on the platform
07:55:23 <anac1> wuzhihui: did you measure how long time it took?
07:55:25 <wuzhihui> but there are some testcase executed failed.
07:55:27 <patrick1> +1
07:55:53 <kubi> which testcase?
07:55:56 <anac1> wizhihui: write comments on jira and the rest of us will help
07:55:58 <patrick1> maybe you can email the failed log and we can see and fix it
07:56:18 <wuzhihui> testcase iperf and ping-ext-ip
07:56:52 <wuzhihui> i need some help
07:56:58 <QiLiang> ping-ext-ip is becasue of the Chinese network i think
07:57:11 <wuzhihui> iperf
07:57:42 <wuzhihui> becase ssh failed,SSHException('not a valid EC private key file
07:58:12 <anac1> wuzhihui: please add the problems as comments in yardstick-147, we will try to reproduce the fault in other labs
07:58:21 <wuzhihui> ok
07:58:25 <wuzhihui> thank you
07:58:26 <anac1> thanks !
07:58:36 <patrick1> Ana, because Oct.1~7 is the traditional national holiday in China. so the chinese guys will not attend the yardstick weekly meetings in this durations.
07:59:01 <anac1> ok, i will cancel oct 1st meeting
07:59:07 <anac1> what holiday is it?
07:59:12 <patrick1> and I am not sure whether all of us can attend to the Sep.30 meeting since some guys maybe leave office ahead of the holiday.
07:59:16 <QiLiang> nationnal day
07:59:24 <patrick1> National Day
07:59:34 <anac1> ok, i will propose another date for sept 30
07:59:49 <patrick1> thx
08:00:10 <anac1> #action anac to replan the meetings on sept 30 and oct 1st
08:00:23 <anac1> thanks everyone, that's all for today
08:00:27 <anac1> #endmeeting