#opnfv-yardstick: Yardstick work meeting

Meeting started by anac1 at 07:30:09 UTC (full logs).

Meeting summary

    1. Ana Cunha (anac1, 07:30:21)
    2. QiLiang (qiliang_, 07:30:29)
    3. Patrick (Patrick_, 07:30:30)

  1. milestone information (anac1, 07:32:29)
    1. milestone C last friday 25/spetember (anac1, 07:33:03)
    2. Jingwen Hou (jingwen, 07:34:50)
    3. milestone d december 1st (anac1, 07:35:07)
    4. requests summarized in epic in yardstick jira (anac1, 07:37:23)
    5. requests from sfc, ipv6, vnffg, armband, sdnvpn (anac1, 07:38:53)
    6. work until milestone d - have all test specifications ready (anac1, 07:39:34)
    7. request also form ha, kvm (anac1, 07:39:49)
    8. plan is to discuss architectural changes based on requests above (anac1, 07:40:32)
    9. the test cases should be executed during december, the test specification (.rst, plus functionality in framework) should be ready for milestone d (anac1, 07:43:11)
    10. this meeting today is for all of us to understand the scope (anac1, 07:45:38)
    11. suggestion: for new requests, put in backlog (anac1, 07:46:28)
    12. test specification should contain where to perform the test (anac1, 07:48:52)
    13. test specification is the .rst file: test_case_description_template.rst (anac1, 07:50:18)
    14. read ETSI TST001 document (anac1, 07:51:41)
    15. this document is a methodology for NFVI (anac1, 07:51:55)
    16. go to ETSI-NFV page to find the document, it a draft, but you can download it (anac1, 07:52:28)
    17. the other projects that have requested our support have also their tasks in jira (anac1, 07:56:37)
    18. hardware is a potential problem - where to verify the features for the release (anac1, 08:00:32)
    19. yardstick team will continue developing NFVI test cases (anac1, 08:09:16)
    20. a sample is an example how to the tool e.g. fio (anac1, 08:10:26)
    21. the test case (the .rst file mentioned above) is the the verification of a metric/characteristic (anac1, 08:11:06)
    22. drafts for two test cases will be pushed to gerrit (anac1, 08:15:26)
    23. tc002 and tc001 (anac1, 08:15:50)

  2. walk thruogh jira (anac1, 08:18:24)
    1. check dashboard and kanban board for overview of the project (anac1, 08:22:30)
    2. yardstick-19 (anac1, 08:24:00)
    3. yardstick-26 (anac2, 08:31:48)
    4. yardstick-27 (anac2, 08:34:29)
    5. this jira means invoking yardstick several times in paralel against the same installation (anac2, 08:36:01)
    6. yardstick-32 (anac2, 08:40:24)
    7. yardstick-35 and yardstick-36 in progress (anac2, 08:43:50)
    8. ACTION: anac to check yardstick-39 (anac2, 08:44:28)
    9. yardstick-50 (anac2, 08:45:40)
    10. no info (anac2, 08:46:01)
    11. ACTION: anac to check yardstick-50 (anac2, 08:47:55)
    12. yardstick-56 (anac2, 08:48:23)
    13. framework user guide (anac2, 08:48:31)
    14. ACTION: anac to add a task for adding/expand docstrings in the scenarios, check if the current ones need update (anac2, 08:52:48)
    15. yardstick team needs to agree on architecture befor writing the architecture chapter (anac2, 08:53:34)
    16. yardstick-60, 61,62,63,64 (anac2, 08:54:27)
    17. yardstick-64 (anac2, 08:59:15)
    18. yardstick-64 updated with scope (anac2, 09:04:09)
    19. yardstick-71 (anac2, 09:05:25)
    20. ACTION: anac to include runners in the docstrings action (anac2, 09:09:56)
    21. to recap: how to write test cases with existing scenarios and runners is covered in yardstick-71 (anac2, 09:10:33)
    22. the fremwork user guide covers how to add new scenarios, runners (yardstick-56) (anac2, 09:11:12)
    23. yardstick-79 (anac2, 09:16:12)
    24. yardstick-79 edited, assigned to per (anac2, 09:17:47)
    25. yardstick-82 assigned to per (anac2, 09:21:19)
    26. yardstick-84 (anac2, 09:21:38)
    27. ACTION: connect with Genesis to discuss installer support (anac2, 09:28:00)
    28. yardstick-86 is closed as opensteak is no longer in R2 (anac2, 09:28:19)
    29. yardstick-88 assigned to per (anac2, 09:29:28)
    30. https://jira.opnfv.org/browse/GENESIS-53 (Patrick_, 10:36:51)
    31. ACTION: anac to join genesis meeting and discuss dependencies from yardstick - yardstick or genesis to solve (anac2, 10:42:21)
    32. yardstick-94 (anac2, 10:45:19)
    33. yardstick-99 (anac2, 10:47:44)
    34. yardstick-100 (anac2, 10:50:07)
    35. not in R2 (anac2, 10:50:14)
    36. yardstick-109 (anac2, 10:54:09)
    37. keep yardstick-109 not in R2 until further discussion (anac2, 10:58:01)
    38. yardstick-113 (anac2, 10:58:40)
    39. lmbench scenario needs to be changed (anac2, 10:59:32)
    40. ACTION: anac to write a task for changing lmbench scenario for yardstick-113 (anac2, 10:59:58)
    41. yardstick-114 & 115 (anac2, 11:00:43)
    42. yardstick-123 (anac2, 11:02:14)
    43. ACTION: jnon add info/start discussion on yardstick-123 (anac2, 11:07:29)
    44. yardstick-125 & 126 (anac2, 11:08:50)
    45. yardstick-130 (anac2, 11:10:13)
    46. yardstick-135 (anac2, 11:11:31)
    47. assigned to Patrick (anac2, 11:14:16)
    48. yardstick-136 (anac2, 11:14:32)
    49. on-going, jnon's highest prio at the moment (anac2, 11:14:50)
    50. yardstick-137 (anac2, 11:15:12)
    51. on-going, code will be added (anac2, 11:17:01)
    52. yardstick-138 (anac2, 11:17:46)
    53. on-track for R2 (anac2, 11:18:50)
    54. yardstick-149 (anac2, 11:20:07)
    55. yardstick-150 (anac2, 11:20:55)
    56. can we have a decision for cyclic test (yardstick-122)? (anac2, 11:21:14)
    57. continue discusion in jira if required (anac2, 11:27:39)
    58. yardstick-151 (anac2, 11:27:59)
    59. anac will contact the sdnvpn project for understanding their test cases, everyone is welcome to join the opnfv meeting (anac2, 11:28:43)
    60. yardstick-153 (anac2, 11:29:02)
    61. test cases slogans in https://etherpad.opnfv.org/p/testing_requests_for_b_release (anac2, 11:30:23)
    62. ACTION: anac to update https://wiki.opnfv.org/feature_test_project_matrix%20 (anac2, 11:31:15)
    63. ACTION: anac will contact the ipv6 project to ask them to start the test specifications (anac2, 11:31:51)
    64. yardstick-154 (anac2, 11:32:23)
    65. need to have an ARM glance image (anac2, 11:32:45)
    66. not all test tools can be supported (anac2, 11:32:56)
    67. ACTION: anac to add task for investigation (anac2, 11:33:18)
    68. yardstick-155 (anac2, 11:33:38)
    69. anac to contact nvffg project for details (anac2, 11:33:52)
    70. idea is to reuse the work for SFC testing (anac2, 11:34:08)
    71. yardstick-156 (anac2, 11:34:36)
    72. ACTION: anac to add tasks to sfc jira epic to clarify the work (anac2, 11:37:33)
    73. https://etherpad.opnfv.org/p/yardstick_framework (Patrick_, 11:42:00)
    74. https://etherpad.opnfv.org/p/yardstick_framework (qiliang_, 11:42:09)
    75. ACTION: all to add comments/suggestion in https://etherpad.opnfv.org/p/yardstick_framework (anac2, 11:42:30)


Meeting ended at 11:45:46 UTC (full logs).

Action items

  1. anac to check yardstick-39
  2. anac to check yardstick-50
  3. anac to add a task for adding/expand docstrings in the scenarios, check if the current ones need update
  4. anac to include runners in the docstrings action
  5. connect with Genesis to discuss installer support
  6. anac to join genesis meeting and discuss dependencies from yardstick - yardstick or genesis to solve
  7. anac to write a task for changing lmbench scenario for yardstick-113
  8. jnon add info/start discussion on yardstick-123
  9. anac to update https://wiki.opnfv.org/feature_test_project_matrix%20
  10. anac will contact the ipv6 project to ask them to start the test specifications
  11. anac to add task for investigation
  12. anac to add tasks to sfc jira epic to clarify the work
  13. all to add comments/suggestion in https://etherpad.opnfv.org/p/yardstick_framework


People present (lines said)

  1. anac2 (186)
  2. Patrick_ (74)
  3. anac1 (46)
  4. qiliang_ (33)
  5. Jingwen_ (5)
  6. collabot (3)
  7. wuzhihui (1)
  8. jingwen (1)


Generated by MeetBot 0.1.4.