07:00:05 <anac1> #startmeeting Yardstick work meeting
07:00:05 <collabot> Meeting started Mon Oct 12 07:00:05 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:05 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:00:05 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:00:11 <anac1> #info Ana Cunha
07:00:18 <QiLiang> #info QiLiang
07:00:25 <YiminWang> #info Yimin Wang
07:01:04 <anac1> hi everyone, i have some information first
07:01:19 <anac1> #topic Test requests
07:01:28 <kubi> #info gaoliang
07:01:36 <anac1> #info yardstick received request to run tests for OVS project
07:02:15 <anac1> #info reuse some of test cases in yardstick backlog
07:03:15 <anac1> #topic architecture implamentation details
07:03:25 <anac1> #link https://etherpad.opnfv.org/p/yardstick_framework
07:03:29 <jingwen> #info Jingwen Hou
07:03:48 <anac1> any further comments on the architecture?
07:04:42 <QiLiang> no from me
07:05:20 <jingwen> me too
07:05:59 <anac1> #agreed team decides on architecture discussed in last meeting october 8th
07:06:34 <anac1> first to implement, as discussed, context part, comments?
07:07:28 <anac1> #info start with context implementation
07:08:09 <anac1> how much do you see needs to be changed in current model?
07:09:42 <QiLiang> first we need support bare mantel case, for ha and kvm, i think
07:10:34 <anac1> i agree, anyone disagree?
07:10:55 <jingwen> agree
07:11:00 <YiminWang> agree
07:11:02 <patrick11> #info patrick
07:11:16 <wuzhihui> #info wuzhihui
07:11:54 <kubi> yes ,ha kvm need this
07:11:58 <anac1> #agreed add context for bare metal and ha
07:12:01 <QiLiang> at the end of https://etherpad.opnfv.org/p/yardstick_framework i wrote my thought on context implemention
07:12:51 <anac1> the 6 steps, right?
07:12:53 <patrick11> agree with qiliang. we can create an abstract class: Context, and use subclasses like HeatContest and BMContest for different SUT deployment and info
07:13:08 <QiLiang> yes
07:13:54 <anac1> so we need to adapt the heat deploy we have currently ?
07:14:29 <anac1> #info proposal for context implementation in etherpad https://etherpad.opnfv.org/p/yardstick_framework
07:15:24 <anac1> #action anac to add jira tasks for context implementation
07:15:33 <kubi> i guess heat deploy become a subclass ?
07:15:40 <QiLiang> for current heat implementation, just need small change to support different kind of context
07:16:18 <anac1> ok
07:16:19 <QiLiang> kubi: yes
07:16:49 <anac1> qiliang: from your 6 steps, looks like we can map vsperf too?
07:17:15 <QiLiang> do we have more info on vsperf project?
07:18:06 <QiLiang> i think use this 6 steps we can support vsperf case.
07:18:25 <anac1> there is documentation on their repo VSPERF ltd  (under docs in VSPERF gerrit)
07:19:05 <anac1> last week we met, they had some problems to run yardstick
07:19:25 <anac1> jorgen (jnon) helped
07:19:40 <patrick11> we can create a poc.yaml to store the info about the BM, such us ip/user/key, and the info about the OpenStack info. and each sepcial Context can read and use this info as they wish.
07:19:54 <QiLiang> i see, i will read the doc later
07:20:35 <anac1> qiliang: ok, i have started to read
07:21:04 <anac1> patrick11: poc.yaml has the info on the hw available also?
07:21:26 <patrick11> yes.
07:22:17 <patrick11> this config file will include the info of SUT which will not be changed frequently.
07:23:09 <anac1> we need this info, see also https://jira.opnfv.org/browse/PHAROS-30
07:23:10 <patrick11> if yardstick has its own config file, we can reuse it to store these info.
07:23:47 <anac1> will this be a static file?
07:24:19 <patrick11> i think yes.
07:24:33 <anac1> ok, how do we keep track of changes (i guess they don't happen so often)
07:26:28 <patrick11> maybe we can fetch the lab info needed to yardstcik its own conf file. so we can change it when we changed another SUT.
07:26:53 <anac1> #agreed poc.yaml to include SUT info and to be used by context
07:27:29 <anac1> patrick11: fetch from pahros repo, possibly ? so if they update we get it ?
07:28:24 <anac1> pharos
07:30:34 <anac1> so, we'll use the proposal for context implementation, anyone disagree?
07:30:55 <kubi> agree
07:31:26 <anac1> #agreed implement context according to the proposal in https://etherpad.opnfv.org/p/yardstick_framework
07:32:35 <anac1> ok, we know how to continue. anything else on the architecture (we'll keep the etherpad for continuous discussion/updates)
07:33:05 <patrick11> I think first we can create the simple poc.yaml manually.  use the info we needed in HA and KVM. Then we can connect with pharos for how to fetch all the info about the lab.
07:33:40 <anac1> yes, they are not ready, so best to do manually to get going
07:34:19 <YiminWang> agree, I think we can modify the file by manual
07:34:41 <jnon> sry for being late (traffic problems), i agree on the context proposal above
07:34:49 <anac1> #info poc.yaml will be done in two steps: 1) manually to get progress on yardstick tests , 2) connect to pharos when available
07:35:08 <anac1> jnon: ok
07:35:37 <patrick11> agree. I saw there is already a yardstick.conf file to store the common info about the yardstick. maybe we can reuse this conf file to store the sut info and openstack info instead to read from the environment variables.
07:36:19 <QiLiang> https://gerrit.opnfv.org/gerrit/#/c/2383/1
07:36:25 <QiLiang> this patch
07:39:20 <YiminWang> good
07:39:20 <jnon> I think yardstick.conf and poc.yaml maybe should be different files, they have different purpose
07:41:00 <patrick11> ok.
07:42:19 <anac1> do we agree on separete files or need to discuss further ?
07:42:23 <anac1> separate
07:42:49 <QiLiang> if we use yardstick to test one poc, put yardstick.conf and poc.yaml is reasonable
07:43:13 <YiminWang> both are ok for me
07:43:41 <YiminWang> one file is simpler for use
07:44:25 <jnon> i prefer 2 files but 1 is ok for me too
07:44:46 <QiLiang> :)
07:45:03 <QiLiang> both ok for me
07:45:11 <patrick11> me too
07:45:37 <kubi> i 'm afraid it will be a little troubule in 1 file ,if we fetch paros
07:45:43 <jnon> ok start with onw file
07:45:53 <jnon> :)
07:46:17 <YiminWang> 2 files are moe reasonalbe. who code who decide?
07:46:23 <jnon> is pharos a yaml file ?
07:46:29 <anac1> i agree with kubi
07:46:59 <anac1> pharos plan for json/yaml
07:47:26 <QiLiang> maybe later when paros is read we need generate the config by ourselves
07:48:00 <anac1> 2 files ok?
07:48:07 <QiLiang> ok
07:48:14 <patrick11> ok.
07:48:14 <jnon> ok
07:48:15 <YiminWang> ok
07:48:25 <kubi> ok
07:48:30 <anac1> #agreed 2 files (yardstick.conf and poc.yaml)
07:48:44 <anac1> can we move to test result api?
07:48:54 <QiLiang> ok
07:49:00 <anac1> #topic test result api
07:49:30 <QiLiang> i commit two patches last week
07:49:41 <QiLiang> both for test result api
07:50:08 <QiLiang> https://gerrit.opnfv.org/gerrit/#/c/2411/2
07:50:18 <QiLiang> https://gerrit.opnfv.org/gerrit/#/c/2383/1
07:50:27 <anac1> #info two patches https://gerrit.opnfv.org/gerrit/#/c/2411/2 and  https://gerrit.opnfv.org/gerrit/#/c/2383/1
07:50:46 <anac1> we need some changes on the api?
07:51:27 <QiLiang> no, i found the solution
07:51:46 <anac1> :)
07:52:22 <anac1> any ideas how to version control the api?
07:52:52 <anac1> we'll need to freeze code eventually...
07:53:58 <anac1> #action anac, qiliang discuss with functest on version handling for test reult api
07:54:08 <anac1> #topic test runs
07:55:20 <anac1> #info wuzhihui is ready with https://jira.opnfv.org/browse/YARDSTICK-147
07:55:39 <anac1> #info to run current samples 10 times takes about 10 hours
07:56:00 <anac1> #info this input will be used for proposing a dialy and weekly run for yardstick
07:56:16 <patrick11> all of the samples?
07:56:37 <anac1> yes. details to be added to jira
07:56:43 <QiLiang> do we have log?
07:56:52 <anac1> yes will add to jira
07:56:53 <kubi> do we have the duration of each test case
07:56:57 <anac1> yes
07:57:08 <anac1> all details to be added in jira
07:57:14 <patrick11> good.
07:57:34 <anac1> then we can plan the daily+weekly
07:57:45 <anac1> thanks wuzhihui
07:58:09 <kubi> great
07:58:18 <anac1> #action ana add details in jira
07:58:58 <anac1> anything else?
07:59:02 <wuzhihui> hi,ana,Yardstick-147 is fininshed
07:59:25 <wuzhihui> i wrote a email to you
07:59:27 <anac1> great, thanks ! great job, will add all info in jira
08:00:42 <jnon> Im currntly doing some CI work, running allt yardstick test inside a docker image
08:00:46 <jingwen> ana, do we need add the time of case running to .json?
08:00:47 <patrick11> can we stat the execution of each test case when it is over and report on the result?
08:00:58 <jnon> preliminary patch: https://gerrit.opnfv.org/gerrit/#/c/2201/
08:01:29 <anac1> jingwen: the time stamp, you mean?
08:01:56 <kubi> i think jingwen means the duration of each test case
08:02:02 <anac1> patrick11: that's the idea
08:02:08 <patrick11> I think what jingwen said is the same with me.
08:02:20 <anac1> ok
08:02:51 <QiLiang> jnon i will reveiw the code :)
08:03:16 <anac1> #info docker ci code https://gerrit.opnfv.org/gerrit/#/c/2201/
08:03:25 <jnon> yes take a look pls:)
08:03:52 <jnon> i will update the patch with some more info later today
08:04:02 <QiLiang> ok
08:04:38 <anac1> that's all for today, keep discussion on architecture i etherpad
08:04:43 <anac1> thanks all
08:04:46 <anac1> #endmeeting