07:30:01 <anac1> #startmeeting Yardstick work meeting
07:30:01 <collabot> Meeting started Thu Oct 15 07:30:01 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:01 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:30:11 <anac1> #info Ana Cunha
07:30:24 <anac1> hello everyone
07:30:38 <YiminWang1> #info yimin wang
07:30:41 <QiLiang> #info qiliang
07:30:49 <jingwen> #info Jingwen Hou
07:30:58 <anac1> #topic merge conflicts
07:31:10 <kubi1> #info gao liang
07:31:16 <rex_lee> #info rex
07:31:20 <anac1> #info yardstick-132 and yardstick-108 have merge conflicts
07:31:59 <QiLiang> i will update yardstick-132
07:32:14 <kubi1> i will update Yardstick-108
07:32:19 <anac1> great, thanks
07:32:38 <anac1> #action qiliang to update yardstick-132
07:32:55 <anac1> #action kubi1 to update yardstick-108
07:33:05 <anac1> #topic status
07:33:15 <patrick11> #info patrick
07:33:29 <anac1> #info anything else on yardstick-103, 34, 122 and 61?
07:34:22 <anac1> #info can those be closed?
07:34:39 <kubi1> 103 is done
07:34:52 <anac1> #action anac to close 103
07:35:07 <QiLiang> For 122: later when the BareMetal context is ready i will push another path for cyclictest.
07:35:19 <anac1> ok
07:35:23 <QiLiang> 61 is done
07:35:42 <QiLiang> no will add ut for 61
07:35:51 <jingwen> 34 is not done
07:35:53 <anac1> #agreed yardstick-122 to remian until baremetal context is implemented
07:36:12 <anac1> #agreed yardstick-34 on-going
07:36:27 <anac1> 61 on-going?
07:36:27 <wuzhihui> #info wuzhihui
07:36:33 <QiLiang> yes
07:36:43 <anac1> #agreed yardstick-61 on-going
07:36:51 <anac1> #topic docmentation
07:37:18 <anac1> #info re-opened yardstick-2, a new template is added
07:37:42 <anac1> #info new template is according to etsi-nfv tst001
07:37:57 <anac1> we need to decide what template to use
07:38:27 <anac1> #action all check templates in yardstick-2, vote next meeting on monday
07:38:29 <jingwen> i think v2 is more clear
07:38:38 <anac1> ok, me too
07:38:56 <anac1> has everyone had the chance to check ?
07:39:07 <kubi1> yes, 2 is better
07:39:20 <jnon_> i will check today
07:39:44 <QiLiang> i will also check today
07:39:59 <anac1> ok, we decide next meeting, thanks!
07:40:35 <anac1> #info use docstrings in code to generate code documentation
07:40:57 <anac1> the idea is to enforce pep257
07:41:11 <anac1> so the authors need to add docstrings to the files
07:41:26 <anac1> comments?
07:42:04 <anac1> should we agree on a time frame for this to take effect?
07:44:08 <QiLiang> add docstring is good for others to understand code
07:44:23 <anac1> #action all comment on yardstick-161
07:44:31 <QiLiang> and we need some time to add docsting
07:44:44 <jnon_> yes
07:44:46 <anac1> qiliang: yes, we want people to understand our work
07:44:57 <anac1> we need time, yes
07:45:28 <anac1> the idea is to enforce the time when we are ready for it
07:45:40 <jnon_> isnt it 2 things, fix pep257 errors and adding content?
07:46:06 <anac1> jnon_: yes, first add content, or ?
07:46:19 <patrick11> maybe we can try our best to add docstring when we summit the new codes, and will complete the docstrings in MileStone E?
07:47:00 <anac1> patrick11: good idea, start by adding docstrings for new code
07:47:01 <jnon_> and do we have pep257 checks in flake8 now ?
07:47:14 <anac1> jnon_: i don't know
07:47:42 <krihun> as far as I know, flake8 does not check pep257
07:47:58 <anac1> was not there a package in flake8?
07:48:04 <jnon_> there should be a plugin for that i think !?
07:48:34 <krihun> yes, there are separate packages flake8-docstrings and flake8-pep257 that can be added to flake
07:49:13 <anac1> #link https://pypi.python.org/pypi/flake8-pep257/1.0.2
07:49:40 <anac1> ok, comments on yardstick-161, please
07:49:53 <anac1> #topic SLA check
07:50:32 <anac1> #info new jira yardstick-172
07:50:53 <anac1> jingwen: what's the proposal?
07:52:23 <anac1> update the original code?
07:53:05 <jingwen> i think the output is not complet
07:53:17 <jnon_> yes SLA handling is a bit limited now and should be improvef
07:53:49 <anac1> ok
07:54:13 <anac1> #topic other
07:54:20 <anac1> anything else to bring up?
07:54:35 <QiLiang> i push a Heat context code refactor patch for review: https://gerrit.opnfv.org/gerrit/#/c/2549/
07:54:59 <anac1> #action all review heat context refactor
07:55:04 <jnon_> great i will review
07:55:31 <QiLiang> And for vsperf project, i think we can reuse BareMetal context, and in the vsperf scenario to handle cross framework communication.
07:56:20 <anac1> qiliang: will you take the baremetal context implementation after the heat context?
07:56:31 <QiLiang> yes
07:56:37 <anac1> great
07:56:58 <QiLiang> cyclictest for kvm net baremetal context
07:57:05 <QiLiang> net -> need
07:57:29 <anac1> yes, so they can start using yardstick
07:57:43 <QiLiang> yes
07:57:59 <anac1> #action all help review vTC patches
07:58:25 <QiLiang> ok
07:58:29 <anac1> thanks
07:58:40 <jnon_> ok
07:58:44 <patrick11> ok
07:58:56 <jingwen> ok
07:59:28 <anac1> #info a discussion on lab requirements from test projects will happen today in test & performance meeting
07:59:52 <anac1> i will take notes on irc
08:00:00 <anac1> anything else?
08:00:13 <QiLiang> no from me
08:00:30 <jnon_> no
08:00:35 <anac1> thanks for your time !
08:00:38 <anac1> #endmeeting