07:30:05 <anac1> #startmeeting Yardstick work meeting
07:30:05 <collabot> Meeting started Mon Oct 19 07:30:05 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:05 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:05 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:30:14 <anac1> #info Ana Cunha
07:30:27 <QiLiang> #info QiLiang
07:30:28 <krihun> #info Kristian Hunt
07:30:58 <anac1> #topic  Jira
07:31:22 <anac1> #info anything more to do on yardstick-100?
07:31:38 <YiminWang> no
07:31:50 <jingwen> #info Jingwen Hou
07:32:03 <anac1> #agreed anac1 to close yardstick-100
07:32:09 <rex_lee> #info Rex Lee
07:32:13 <anac1> #topic OPNFV community labs
07:32:35 <anac1> #info there was a discussion last thursday on test&performance meeting
07:32:45 <anac1> #link https://wiki.opnfv.org/feature_test_project_matrix
07:33:03 <anac1> #info a tale was added in testing wiki, see link above
07:33:25 <anac1> i have added info for yardstick, double check, please
07:33:43 <QiLiang> ok
07:34:36 <QiLiang> we have jira for vnffg
07:34:54 <anac1> ok, i will add, thanks
07:35:51 <anac1> #info release b testing will need to use other community labs in addition to LF
07:37:08 <anac1> any questions?
07:37:28 <QiLiang> ok, i get it
07:38:05 <anac1> ok, we need to define the pod.yaml to get going
07:39:13 <iben> fdegir: you around?
07:39:22 <iben> I wrote down some thoughts on how this might work… https://spirent.box.com/s/gt37aq9orqc18i3p1ujfz9aq3vcj18tc
07:39:59 <anac1> jnon: have you started looking in pod.yaml
07:40:22 <anac1> #info need to start specificiation for pod.yaml
07:40:22 <jnon> not started
07:40:27 <anac1> ok
07:40:41 <anac1> #topic test case template
07:41:29 <anac1> #info 2 versions exist for test case template
07:41:51 <anac1> what the general opinion ? i prefer v2.
07:42:33 <krihun> I think the template using table structure looks cleaner
07:42:47 <anac1> yes, that's the v2
07:42:55 <QiLiang> +1 for v2
07:43:14 <anac1> anyone disagree to remove the previous version and use v2 ?
07:43:43 <YiminWang> +1 for v2
07:43:55 <anac1> #agreed use template v2 for test case specification
07:44:11 <jnon> +1 v2
07:44:20 <patrick1> #info patrick
07:44:22 <anac1> #topic test result api
07:44:24 <patrick1> sorry for late
07:44:33 <anac1> no problem
07:44:33 <patrick1> +1 for v2
07:44:45 <anac1> ok, v2 seems to be the consensus
07:45:04 <anac1> #action anac1 to remove previous template version from gerrit
07:45:47 <jingwen> v2 +1
07:45:54 <anac1> any news on test result api ?
07:46:01 <QiLiang> i saw morgan's patch
07:46:15 <anac1> yes?
07:46:31 <QiLiang> it seems that functest2dashboard need commit to releng
07:46:54 <anac1> ok, you informed morgan, right?
07:47:07 <QiLiang> https://jira.opnfv.org/browse/RELENG-45
07:47:12 <QiLiang> not yet
07:47:38 <QiLiang> will inform morgan later after meeting
07:47:49 <anac1> ok, thanks
07:47:56 <QiLiang> this morning there is some problem with my computer
07:48:11 <anac1> #info functest2dashboard need commit to releng
07:48:29 <anac1> qiliang: understand
07:48:57 <anac1> #topic framework architecture
07:49:13 <anac1> #link https://etherpad.opnfv.org/p/yardstick_framework
07:49:36 <patrick1> ana, i have a question about V2.: should we put the the meaning of options of the scenarios into the TC description? or just let the option description into the docstring of scenario, and give the link into the tc description? I wonder the beginner cannot write the whole test case when read this scenario's rst.
07:49:41 <anac1> #info use the link above for adding comments
07:50:24 <anac1> patrick1: yes, i saw your comment. i think we should put the options too, to help the beginners
07:50:39 <patrick1> great:)
07:51:05 <anac1> i will update with your comment
07:51:05 <jnon> doe we have to describe all options in TC ??
07:52:18 <patrick1> it's better to give the link of docstring , because the docstring will include the options mean and related link in each scenario's py.
07:52:39 <jnon> I think only options relevant for the TC should be described in TC description !?
07:53:27 <patrick1> that's right.
07:54:02 <anac1> so, we mean describe the options that we use in the TC, right?
07:54:56 <patrick1> we just describe the options we use.
07:55:27 <anac1> ok, we write a few examples and review, i add general info in the template
07:55:55 <jnon> ok
07:56:10 <patrick1> nice
07:56:25 <anac1> #action tc001 and tc002 examples using the v2 template, including options we use, for review next meeting
07:57:05 <anac1> or other tcxxx
07:57:19 <anac1> #topic meeting time
07:57:45 <anac1> we in europe will change to winter time from next weekend
07:57:59 <anac1> can we move this meeting (and thursday) 1 hour later?
07:58:11 <patrick1> ana, kubi cannot attend this meeting, but he comment that the ut coverage more strictly.  YARDSTICK-108
07:58:28 <patrick1> he send the email last week
07:58:32 <anac1> yes, i saw his e-mail
07:59:28 <anac1> i agree, anyone has an opinon?
07:59:43 <anac1> opinion
08:00:10 <patrick1> I think it will influence everyone, so maybe we will make a vote for 4 line limitation.
08:01:05 <QiLiang> after kubi's patch merger it will be hard to update existed code
08:01:34 <QiLiang> we need add a lot ut now
08:01:36 <anac1> looks like we need time to think, vote next meeting?
08:01:45 <QiLiang> ok
08:01:57 <patrick1> yes, maybe we will finish some technical debt
08:01:59 <patrick1> ok
08:02:23 <anac1> #action all the check kubi's e-mail about 4 line limitation, vite next meeting thursday
08:02:47 <jingwen> hi, ana, about yardstick -172 "sla check of scenarios", i have submit code to gerrit
08:03:23 <QiLiang> https://gerrit.opnfv.org/gerrit/#/c/2615/
08:03:30 <QiLiang> for yardstick-172
08:03:45 <jnon> i will check 172
08:03:59 <anac1> #action all to comment on yardstick-172
08:04:00 <jingwen> jnon: thank you
08:04:08 <jingwen> thanks
08:04:13 <anac1> #link  https://gerrit.opnfv.org/gerrit/#/c/2615/
08:04:39 <anac1> #action discuss yardstick-172 next meeting
08:04:47 <QiLiang> jnon also help review heat context refactor patch :)
08:05:03 <anac1> jnon: that's another one for you
08:05:10 <jnon> yes i will :)
08:05:18 <patrick1> ana, I have heard there is a joint meeting on the OPNFV summit with HA team?
08:05:20 <anac1> #action review heat context refactor patch
08:05:43 <anac1> patrick1: you mean the breakout session?
08:05:49 <patrick1> yes
08:06:32 <patrick1> i saw the agenda from Fuqiao.
08:07:07 <anac1> that's open for everyone, here's the link https://etherpad.opnfv.org/p/OPNFV_Design_Summit_2015
08:07:30 <anac1> i hope we will have a chance to discuss face to face
08:07:54 <patrick1> that would be greate
08:07:56 <patrick1> great
08:08:14 <anac1> projects will also have presentations, see: https://etherpad.opnfv.org/p/OPNFV_Summit_demo_theater
08:08:53 <anac1> ok, that's all for today, thanks for your time !
08:08:58 <anac1> #endmeeting