07:30:02 <anac1> #startmeeting Yardstick work meeting
07:30:02 <collabot> Meeting started Thu Oct 22 07:30:02 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:30:02 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:30:02 <collabot> The meeting name has been set to 'yardstick_work_meeting'
07:30:09 <anac1> #info Ana Cunha
07:31:10 <kubi> #info gao liang
07:31:24 <patrick11> #info patrick
07:31:32 <YiminWang> #info Yimin wang
07:31:33 <jingwen> #info Jingwen Hou
07:31:45 <rex_lee> #info Rex
07:32:03 <anac1> #topic OPNFV community labs
07:32:34 <anac1> #info pharos projects has asked all PTL's to inform on lab needs
07:32:38 <patrick11> qiliang asked for leave for business issues, so he cannot attend this meeting.
07:33:04 <anac1> patrick11: ok, thanks for information!
07:33:17 <anac1> #link https://wiki.opnfv.org/projectreqonpharos
07:33:40 <anac1> #info link above contains yardstick's reply
07:34:30 <anac1> #info yardstick intends to use ericsson lab, huawei lab, zte lab, china mobile lab, linux foundation lab
07:35:07 <anac1> #info and other lab for verifying the test cases for the projects we received requests from
07:35:42 <patrick11> nice.
07:36:21 <anac1> #topic yardstick-172 (sla check of scenarios)
07:37:26 <anac1> any further comments ?
07:37:29 <patrick11> we seems lack some lab resources in huawei lab. I will track this issues and try my best to support this resource config.
07:37:49 <anac1> patrick11: great, thanks !
07:38:35 <jingwen> comments has changed
07:39:05 <jingwen> comments has modified
07:39:47 <jingwen> not say new comments
07:39:57 <jingwen> not see new comment
07:40:00 <jingwen> sorry
07:40:08 <anac1> no problem
07:40:51 <patrick11> no newer comments from me
07:40:58 <anac1> #info no new comments
07:41:40 <anac1> #topic yardstick-168 (heat context refactor)
07:42:18 <patrick11> Qiliang push a patch to refactor runner_cfg host/target info handle, as specified at https://etherpad.opnfv.org/p/yardstick_framework step 4. Get general Context info (use Context.get).
07:42:32 <patrick11> gerrit link: https://gerrit.opnfv.org/gerrit/#/c/2693
07:42:58 <anac1> #action all review latest patch https://gerrit.opnfv.org/gerrit/#/c/2693
07:43:22 <patrick11> This patch changes all the existing test scenarios, so Qiliang asked everyone pls help to review the code to double check.
07:43:56 <anac1> #info the patch affects ALL existing test scenarios
07:44:35 <anac1> #info follow up on next meeting so make sure the sample authors review the patch
07:44:46 <patrick11> great
07:44:59 <patrick11> thanks
07:45:12 <anac1> #topic yardstick-108 (coverage report)
07:45:32 <anac1> #info agreed from last meeting to discuss again today
07:46:05 <anac1> comments ? when merged, this will affect all code
07:46:17 <kubi> yes, i need your opinion
07:47:30 <kubi> 4 extra missing lines is same as rally's standard
07:48:09 <krihun> I think 4-line requirement might be a bit too strict at first, we could start with something more lax and then move to a tighter solution once everybody has got used to the initial changes
07:49:06 <kubi> yes,our ut coverage rate is not good as rally , if we use this standard, it will be strict
07:49:44 <anac1> krihun: have a suggestion on how to start?
07:50:08 <anac1> jnon ?
07:50:32 <krihun> I really don't know, maybe start with a 10-line requirement at first and see how well it is adopted?
07:50:51 <kubi> how about that i don 't check the extra missing
07:51:02 <kubi> i just give the coverage report
07:51:30 <anac1> i think it is good to check the missing
07:51:54 <krihun> I agree with Ana, this gives motivation to write unit tests
07:52:02 <anac1> we could start with 10, like krihun says, and see how it goes
07:52:19 <kubi> ok, no problem , i think this is a good idea
07:52:28 <jnon_> i agree
07:52:53 <anac1> anyone disagree to start with 10?
07:52:56 <jingwen> agree
07:53:27 <patrick11> agree with ana. I think in Milestone D we will try best to finish the critical features and codes. but I think in Milestone E we should down to the 4-lime requrement like the rally. we should pay for the technical debt in release B?
07:54:16 <anac1> patrick11: agree
07:55:04 <anac1> #agreed start with 10-line restriction, report back every meeting
07:55:15 <kubi> ok
07:55:19 <anac1> #info goal is 4-line for milestone-E
07:55:37 <patrick11> ok, ths
07:56:07 <anac1> #topic yardstick-166
07:56:28 <kubi> yes ,i add some coment on it
07:56:47 <kubi> i have got the total time and the time of each task with code, however , "Runner.queue" was released before getting total time, so i can not put "total time" into result file, i 'm not sure it is ok that i use "log.info" to print "total time" to console , All comments are welcome~
07:57:41 <anac1> i think it is ok, you get the time for each task, right?
07:57:50 <kubi> yes
07:58:24 <kubi> i get two time : one is total time , another is task time
07:59:04 <kubi> if a test suite is run, total time is sum of each task time
07:59:40 <anac1> yes, you get each task, not i think this is ok. anyone has other opinion?
08:00:02 <patrick11> I think these are enough for testers basic using. so that's ok for me.
08:00:02 <anac1> yes, you get each task, SO i think this is ok. anyone has other opinion?
08:00:42 <anac1> #action anac to comment on jira, ok to use the tasks
08:00:56 <jnon_> no i think this is good enough
08:01:20 <anac1> jnon: you agree?
08:02:01 <anac1> #agreed the proposal to use tasks time is ok
08:02:15 <anac1> #topic test case description template
08:02:35 <anac1> #info updated yardstick-2 with comments from last meeting
08:03:15 <anac1> #info small addition to include the scenario options used
08:03:20 <jnon_> i agree
08:03:42 <anac1> ok, thanks
08:03:51 <patrick11> great, i will check it after meeting
08:03:57 <anac1> that was all for today, thank you everyone
08:03:59 <patrick11> by the way , there are some discussion on the https://etherpad.opnfv.org/p/yardstick_framework about the context type and the sample of pod.yaml , waiting for further comments:)
08:04:06 <kubi> anac1, about 166 ,i clarify that task time also can't be put into result file , i' m sorry if i let you misunderstand
08:04:40 <anac1> #action all read discussion and comment on https://etherpad.opnfv.org/p/yardstick_framework
08:05:18 <anac1> kubi: ok, i'll add comment in jira
08:05:23 <kubi> ok
08:05:33 <anac1> #endmeeting