08:30:03 <anac1> #startmeeting Yardstick work meeting
08:30:03 <collabot> Meeting started Thu Oct 29 08:30:03 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:03 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:30:10 <anac1> #info Ana Cunha
08:30:52 <QiLiang1> #info QiLiang
08:31:00 <kubi1> #info gao liang
08:31:01 <YiminWang> #info Yimin Wang
08:31:24 <anac1> #topic Lmbench bug fix
08:31:57 <anac1> what is the status on this ?
08:32:00 <jingwen> #info Jingwen Hou
08:32:38 <QiLiang1> fix in kristian 's  patch
08:33:06 <patrick1> #info patrick
08:33:08 <rexlee1> #info Rex
08:33:26 <krihun> I added it to my patch when I rebased it so it could pass all unit tests
08:33:29 <anac1> ok, so nothing to discuss, the patch https://gerrit.opnfv.org/gerrit/#/c/2623/ is fixing the issue?
08:33:45 <krihun> yes
08:33:56 <anac1> #info patch https://gerrit.opnfv.org/gerrit/#/c/2623/ fix the problems
08:34:00 <anac1> thanks
08:34:13 <anac1> #topic test result API
08:35:07 <jose_lausuch> #info Jose Lausuch
08:35:12 <jose_lausuch> I have comments for this section :)
08:35:24 <QiLiang1> yardstick2dashboard  is merged in releng
08:35:24 <anac1> ok, go ahead
08:35:38 <jose_lausuch> for all the test projects reporting results to the DB
08:35:54 <anac1> #info yardstick2dashboard is merged in releng
08:35:55 <QiLiang1> jiust add ping for poc
08:36:03 <jose_lausuch> we have to agree on a common way to have an option to push the results or not
08:36:14 <jose_lausuch> we talked about this last week in functest
08:36:31 <jose_lausuch> by default we shouldnt push anything
08:36:35 <jose_lausuch> and if we want, we add a flag to our scripts
08:36:42 <anac1> why we shouldn't push anything?
08:36:47 <jose_lausuch> something like --push_results=true or something like that
08:36:55 <jose_lausuch> because we dont want everyone that tries opnfv to push it
08:37:08 <jose_lausuch> there will be credentials in the DB soon
08:37:18 <jose_lausuch> and if someone doesnt have access, that push function will fail
08:38:11 <anac1> jose_lausuch: if we are using a result api, the default should NOT be DONT PUSH, doesn't make sense to me...
08:38:28 <jose_lausuch> imagine, I am individual and Im testing opnfv on my private lab
08:38:33 <jose_lausuch> and then I run the tests
08:38:39 <jose_lausuch> why should I have to push?
08:38:49 <jose_lausuch> I wont have credentials, it will fail anyway
08:38:52 <jose_lausuch> what do you think?
08:39:08 <QiLiang1> ci triggerd test can push result ?
08:39:09 <jose_lausuch> (this is not 100% decided, so we can share different views)
08:39:33 <jnon> yes a flag to push  or not is ok
08:39:33 <anac1> i think CI triggered should push results
08:39:34 <jose_lausuch> now it does
08:39:57 <jose_lausuch> CI connected labs is ok, they will have credentials to the target DB
08:40:11 <jose_lausuch> but Im concerned about everyone else testing opnfv
08:40:21 <jose_lausuch> this could cause a lot of pushes from different sources
08:40:22 <QiLiang1> so private test cannot use the api ?
08:40:26 <jnon> we are currently not continously pushing in ci job but im working on that
08:40:53 <jose_lausuch> we should all have credentials in the target db, thats for sure, all the opnfv community labs for sure
08:41:15 <anac1> yes, agree to the need to have credentials
08:41:32 <jose_lausuch> but in the end if I triy it on my private server, and another one does the same, and so 100 people, we can have 10000 different sources in the DB
08:41:42 <jose_lausuch> to avoid it, we will use credentials
08:41:51 <jose_lausuch> so what do you thing about the flag ?
08:41:51 <jnon> yes we need credentials tpo avoid that
08:41:54 <jose_lausuch> and by default dont push?
08:42:20 <jnon> yes
08:42:51 <anac1> so when is the credentials implemented?
08:43:01 <jose_lausuch> not sure when
08:43:04 <jose_lausuch> but we will know :)
08:43:28 <anac1> when?
08:43:41 <jose_lausuch> I dont have the details now
08:43:57 <anac1> jnon, qiliang: do we need a local dB?
08:44:15 <jnon> not for this , we can dumpt to file
08:44:35 <anac1> ok
08:44:41 <QiLiang1> agree with jnon
08:44:46 <anac1> ok
08:44:46 <jose_lausuch> that was all what I had to say, please add a flag to push results to DB as an option
08:44:47 <jose_lausuch> :)
08:45:09 <QiLiang1> ok, thanks
08:45:15 <anac1> jose_lausuch: how is the documentation for the api?
08:45:33 <jose_lausuch> that is what morgan has been working on
08:45:40 <jose_lausuch> what do you mean by "how" ? :)
08:45:53 <anac1> i mean, wiki, gerrit ?
08:46:08 <anac1> :)
08:46:15 <jose_lausuch> https://wiki.opnfv.org/collection_of_test_results
08:46:30 <jose_lausuch> guy rodrigue is working on that
08:46:37 <anac1> ok, will it always be in the wiki?
08:46:44 <jose_lausuch> for now... I think so
08:46:55 <anac1> i need a link to the documentation, that's why i ask
08:46:55 <jose_lausuch> not sure if morgan has plans to put it somewhere else, I will ask
08:46:59 <jose_lausuch> ok
08:47:04 <anac1> thans !
08:47:10 <anac1> thanks!
08:47:36 <anac1> so, jnon, qiliang: we agree to put a flag, default dont push?
08:48:01 <QiLiang1> agree
08:48:07 <jnon> yes that is a flag to the ci scripts
08:48:38 <QiLiang1> ci will push right ?
08:48:45 <jose_lausuch> yes
08:48:45 <anac1> #agreed to add a flag to result api, default DONT push
08:48:46 <jnon> i already added a flag to set db server address to the scripts (not pushed yet)
08:49:13 <jose_lausuch> thanks :)
08:49:14 <jnon> if not set it dumps to file
08:50:09 <anac1> jose_lausuch: do you know if the installer type is a variable from all installers?
08:50:34 <patrick1> actually we use the yarsick.conf to config to sent to DB or just dump to file. so pay attention to this config should not to conflict with the flag value.
08:50:38 <jose_lausuch> thats a tricky question
08:50:45 <jose_lausuch> even worse is the user and password of the installer
08:51:03 <jose_lausuch> we know the defaults, but you can install it without defaults (different usr/pass)
08:51:07 <jose_lausuch> for the installe type
08:51:12 <jose_lausuch> I give the parameters in the jenkins job
08:51:21 <jose_lausuch> installer_type and installer_ip
08:51:25 <jnon> patrik1: yes the flag updates yardstick.conf in docker image
08:52:01 <QiLiang1> jose_lausuch i  have check the code today :)
08:52:20 <patrick1> jnon: that's the point, tks.
08:52:41 <jose_lausuch> are you guys using fetch_os_credssh?
08:52:53 <jnon> yes
08:53:08 <jose_lausuch> so we have a common problem
08:53:27 <jose_lausuch> someone contacted us because he was not using root/r00tme in fuel, he changed the defaults
08:53:31 <jose_lausuch> and then that script failed
08:53:38 <jose_lausuch> so we will figure out how to do that
08:53:41 <jose_lausuch> not clear yet
08:53:58 <jnon> ok
08:54:07 <jose_lausuch> the only thing I can imagine now is to provide also together with installer_type and ip, installer_user and installer_password
08:54:18 <jnon> pod name is needed also
08:54:26 <jose_lausuch> but thats not very safe ...
08:54:33 <jose_lausuch> providing passwords like this :)
08:54:42 <jose_lausuch> ok jnon
08:54:49 <anac1> ok, moving on
08:54:50 <jose_lausuch> you mean for fetch_os_creds?
08:55:00 <anac1> #topic HA test cases
08:55:17 <jnon> no for other things
08:55:26 <anac1> patrick1: are you ok with the 5 test cases in the etherpad ?
08:55:51 <anac1> #link https://etherpad.opnfv.org/p/yardstick_ha
08:55:58 <patrick1> not yet . I gave the first, and try to finish all of them this weekend.
08:56:18 <patrick1> but I gave the five test case name and scope.
08:56:28 <anac1> ok, but that is the list to develop for r2?
08:56:35 <jnon> we need pod name to choose test suite, and in info dumped to db
08:56:50 <patrick1> yes.
08:56:59 <jose_lausuch> ok
08:57:21 <anac1> #info the list in etherpad is the R2 target
08:57:22 <patrick1> I try to finish all of them in R2,
08:57:44 <anac1> the first is almost done, where will you test?
08:57:57 <patrick1> but if some are not finished for some reason, I will delay it to C
08:58:01 <anac1> ok
08:58:19 <patrick1> Now I test it on huawei lab.
08:58:30 <anac1> and then on china mobile's lab?
08:58:54 <anac1> for ha project, i mean
08:59:04 <patrick1> I have talked to Fuqiao, I hope so
08:59:12 <anac1> ok, good
08:59:26 <patrick1> but I think maybe we can share a demo to HA team first
08:59:36 <patrick1> and talk about some details
08:59:54 <anac1> yes, when the code is ready
09:00:14 <patrick1> when the test case stable , we can deploy and run on China Mobiles lab
09:00:40 <anac1> sounds like a plan
09:00:56 <patrick1> In OPNFV Summit , HA has a session
09:01:08 <anac1> you mean breakout?
09:01:33 <patrick1> I will share the five test cases on it. And discuss with other guys from HA team.
09:02:12 <anac1> ok
09:02:25 <anac1> that's all for today, thanks everyone
09:02:28 <anac1> #endmeeting