15:00:17 <anac1> #startmeeting Yardstick work meeting
15:00:17 <collabot> Meeting started Mon Nov  2 15:00:17 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:17 <collabot> The meeting name has been set to 'yardstick_work_meeting'
15:00:37 <anac1> #info Ana Cunha
15:00:51 <vincenzo_riccobe> #info Vincenzo Riccobene
15:01:18 <anac1> #topic vTC code reviews
15:01:42 <anac1> #info patches are being pushed in gerrit
15:01:55 <anac1> do you get enough feedback?
15:02:13 <vincenzo_riccobe> I am waiting for feedbacks on my last review
15:02:32 <anac1> ok, i reminded the team this morning
15:02:39 <vincenzo_riccobe> we still have a lot of code to contribute
15:02:45 <vincenzo_riccobe> for the framework
15:03:08 <vincenzo_riccobe> we are working on the code at the moment
15:03:23 <vincenzo_riccobe> but as soon as we get this review accepted we will provide more modules
15:03:28 <anac1> can we spread in several patches or there are a lot of dependencies?
15:03:40 <vincenzo_riccobe> i am trying to do this
15:03:53 <vincenzo_riccobe> starting from those modules that do not have dependencies
15:04:28 <anac1> #action anac1 to highlight the need for more reviewers
15:05:20 <anac1> did you go through the code coverage patch ?
15:05:32 <anac1> we have a restriction of 10 lines
15:05:40 <vincenzo_riccobe> I had a look
15:05:45 <vincenzo_riccobe> today
15:05:56 <vincenzo_riccobe> I was trying to understand what is required from my side
15:06:40 <vincenzo_riccobe> I mean, we are writing the tests for the python modules in the framework
15:06:53 <vincenzo_riccobe> and have a shell script that call them
15:07:04 <anac1> ok, we will restrict 10 lines max without test coverage for milestone D (Dec 1st)
15:07:20 <anac1> so it looks like you are in in the right direction
15:07:45 <vincenzo_riccobe> I am wondering if I need to submit that as first element
15:07:54 <vincenzo_riccobe> and jenkins will call it automatically
15:08:04 <anac1> sounds like a good idea
15:08:12 <vincenzo_riccobe> ok
15:08:16 <anac1> you have access to the lab now right?
15:08:48 <anac1> so we give you 2 blades to start, would that work? 1 more to come later?
15:09:02 <vincenzo_riccobe> the next step then, after the approval of the current review will be the submission of the testing script
15:09:10 <anac1> yes, ok
15:09:19 <vincenzo_riccobe> I did not ttest the access
15:09:22 <anac1> #info next step is the test script
15:09:28 <vincenzo_riccobe> I will try to do this tomorrow
15:09:37 <anac1> please check, let me know when you are set up
15:09:41 <vincenzo_riccobe> Do I need to install OpenStack on my own or is it already there?
15:10:01 <anac1> i need to double check
15:10:37 <anac1> i'll get back to you later today
15:10:43 <anac1> or early tomorrow
15:10:51 <vincenzo_riccobe> Ok thanks!
15:12:00 <vincenzo_riccobe> I will access the nodes tomorrow. I suppose I can send an email to Daniel Smith in case of issues...
15:12:03 <anac1> regarding the documentation, i saw akis patch, will comment on the changes
15:12:13 <anac1> yes, contact Daniel directly, that is best
15:12:21 <vincenzo_riccobe> perfect!
15:12:26 <akiskourtis> #info Akis Kourtis
15:12:34 <anac1> can we agree on 2 blades to start with?
15:12:38 <akiskourtis> yes Ana I made changes, based on your proposals
15:12:56 <anac1> akiskourtis: i saw, will comment asap
15:13:01 <anac1> thanks!
15:13:07 <akiskourtis> and I am now  talking with Daniel to connect to the lab
15:13:27 <anac1> great
15:13:58 <anac1> anyone else needs access to the lab? if so, send a mail to Daniel
15:14:32 <anac1> i will make a yardstick presentation in opnfv summit
15:14:50 <anac1> i will refer to the vTC, apexlake and the T-nova, is that ok?
15:15:10 <akiskourtis> yes absolutely, thank you!
15:15:17 <anac1> thanks
15:15:34 <akiskourtis> If you need any supporting material please let me know
15:15:36 <vincenzo_riccobe> thank you Ana
15:16:12 <anac1> i have the slides from your community presentation, that and the info on gerrit is ok
15:16:41 <akiskourtis> ok great
15:16:55 <vincenzo_riccobe> if you would need  anything on our side please let us know, willing to help!
15:17:27 <anac1> thanks, appreciate ! will contact you when i have a draft
15:18:17 <vincenzo_riccobe> perfect, thanks!
15:18:19 <anac1> i plan to write my notes on irc from the summit, so all in the team is aware of the discussions
15:18:33 <anac1> hope that is a good way to share info
15:19:07 <anac1> #info documentation patch to be reviewed
15:19:28 <anac1> ok, anything else?
15:19:34 <vincenzo_riccobe> is there a link where we will find the notes?
15:20:03 <vincenzo_riccobe> (or is it just in the same dir of the minutes of this channel?)
15:20:06 <anac1> i will use yardstick irc, same place as the usual meeting notes
15:20:10 <vincenzo_riccobe> ok
15:20:11 <anac1> yes
15:20:12 <vincenzo_riccobe> great!
15:21:20 <anac1> so, let's get the lab going so we can verify the build scripts
15:21:57 <anac1> i will check the meeting invite also, seems the time has not changed...
15:22:26 <anac1> #action anac1 to check the meeting invite for this slot
15:23:05 <anac1> the meeting next week will be cancelled
15:23:16 <anac1> anything else ?
15:24:03 <anac1> ok, that's all for today, thanks!
15:24:08 <anac1> #endmeeting