08:30:01 <anac1> #startmeeting Yardstick work meeting
08:30:01 <collabot> Meeting started Thu Nov  5 08:30:01 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:01 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:30:08 <anac1> #info Ana Cunha
08:30:35 <QiLiang> #info QiLiang
08:30:48 <jingwen> #info Jingwen Hou
08:30:51 <jnon_> #info jnon_
08:31:18 <anac1> #topic yardstick-152
08:31:57 <anac1> is the Avoid the ValueError exception for a ping timeout patch the issue on yardstick-152?
08:32:06 <QiLiang> i merged zhihui's code
08:32:34 <anac1> i just wanted to double check that that was the yardstick-152
08:32:44 <QiLiang> ok
08:32:52 <anac1> no jira tag on commit message
08:33:13 <anac1> #info patch merged Avoid the ValueError exception for a ping timeout corresponds to yardstick-152
08:34:21 <anac1> #action all remember to always add the jira issue number you are working on the commit message
08:34:39 <anac1> #topic yardstick-149
08:34:53 <anac1> yimin, please fix the merge conflict
08:35:39 <anac1> is the work completed for the yardstick-149? anything else to be added?
08:36:10 <kubi> i will tell him to fix
08:36:10 <QiLiang> just need rebase can fix the conflict
08:36:26 <anac1> ok, thanks and thanks !
08:37:11 <anac1> #info merge conflict will be fixed
08:37:34 <anac1> #topic yardstick-6 and yardstick-8
08:37:39 <anac1> progress?
08:38:09 <anac1> per, what's the status?
08:38:41 <anac1> #info anac to check progress
08:38:56 <anac1> #topic cooperation with KVM project
08:39:14 <Per_H> I haven't done anything since I put in teh files into gerrit last week. Look into it today, comments.
08:39:27 <anac1> qiliang has done a great job, kvm gave good comments
08:39:49 <QiLiang> :)
08:40:22 <anac1> can yardstick-122 be closed?
08:40:48 <QiLiang> anac pls tell me what to do next, since i cann't attend the summit :).
08:41:29 <QiLiang> if 122 colsed then new jira related to 122 cyclictest need create i think.
08:41:54 <anac1> ok, i'll meet kvm in the summit, will let you know all the discussions
08:42:11 <anac1> ok, we keep yardstick-122
08:42:24 <anac1> #agreed keep yardstick-122 open
08:44:15 <anac1> qiliang: i think we'll get more test cases from kvm, we can discuss after the summit, i'll extend the meeting on monday 16th so i can give all info
08:44:38 <QiLiang> that's great.
08:44:48 <anac1> #topic result API/dashboard
08:44:48 <QiLiang> thanks
08:44:53 <anac1> no problem!
08:46:05 <anac1> result API seems to work, anything to add on this ?
08:46:08 <QiLiang> because of the network issuse, i cann't recive e-mail today
08:46:16 <anac1> ok
08:46:46 <jnon_> will there be changes in the result API?
08:46:50 <QiLiang> so i don't if anyone reply the e-mail
08:47:24 <anac1> i didn't get any replies
08:47:35 <QiLiang> ok
08:47:44 <anac1> jnon: yes, most likely
08:47:59 <jnon_> ok
08:48:26 <anac1> jose_lausuch: any info on if there will be changes in the test result api?
08:48:54 <jose_lausuch> anac1
08:49:02 <jose_lausuch> anac1: no, so far, that I know
08:49:18 <jnon_> authentication ?
08:49:35 <jose_lausuch> yes, there will be some authentication, but dont know how yet
08:49:41 <jose_lausuch> I think we will discuss it next week :)
08:50:19 <jose_lausuch> hopefully Aric will be there and will have a meeting about that
08:50:25 <anac1> #info test result API needs to include authentication
08:50:46 <anac1> #info implementation and timeline for this is not know at the moment
08:51:21 <jnon_> i think ..
08:51:26 <QiLiang> will dashboard code be put on opnfv git ?
08:51:39 <jnon_> we need installer version in the api ?
08:51:54 <jose_lausuch> mmmm
08:51:57 <jose_lausuch> isnt it there?
08:51:57 <jose_lausuch> wait a sec
08:52:12 <jnon_> there is a version but it is not clear what it is
08:52:40 <jose_lausuch> https://wiki.opnfv.org/collection_of_test_results#data_model
08:53:02 <anac1> #link  https://wiki.opnfv.org/collection_of_test_results#data_model
08:53:11 <jose_lausuch> "project_name": "",
08:53:12 <jose_lausuch> "pod_name": "",
08:53:12 <jose_lausuch> "version": "",
08:53:12 <jose_lausuch> "installer": "",
08:53:12 <jose_lausuch> "description": "",
08:53:12 <jose_lausuch> "creation_date": "YYYY-MM-DD HH:MM:SS",
08:53:12 <jose_lausuch> "case_name": ""
08:53:13 <jose_lausuch> "details":{
08:53:33 <jnon_> yes
08:53:37 <QiLiang> version is test_project's branch name currently
08:53:50 <jose_lausuch> I will propose a small change
08:53:59 <jose_lausuch> since we need branch name + commit IS
08:54:00 <jose_lausuch> ID
08:54:04 <jnon_> i think we need to know what we are testing on
08:54:39 <anac1> #info changes are needed in test result api, missing installer version
08:54:55 <jnon_> yes
08:55:19 <jose_lausuch> who of you will be next week in SF?
08:55:35 <anac1> ana, patrick, kubi
08:55:52 <anac1> #topic other
08:56:00 <anac1> anything else to bring up?
08:56:14 <jose_lausuch> ok
08:56:27 <jose_lausuch> we can have a small chat, also with Morgan about the needed parameters in the rest api
08:56:29 <jose_lausuch> what we are missing
08:56:40 <anac1> yes
08:56:52 <jnon_> yes pod/fuel version mainly
08:57:08 <jose_lausuch> pod is there
08:57:10 <jose_lausuch> pod_name
08:57:14 <jnon_> maybe branch name as well, but it is a bit redundant if we have commit id
08:57:29 <jose_lausuch> well, thats right too
08:57:34 <jnon_> it more a convenience thing
08:57:38 <jose_lausuch> with the commit id you can also know the branch..
08:57:41 <jose_lausuch> sure
08:58:13 <jnon_> depend on the tools that are analyzing the results
08:58:15 <anac1> #info following things are reported missing in test result api: installer version, branch name
08:58:25 <jnon_> if they have access to git
08:59:18 <anac1> anything else?
08:59:29 <jingwen> about YARDSTICK-108 ( coverage report ),“ALLOWED_EXTRA_MISSING=10”looks good for everyone, so i merge ?
08:59:43 <anac1> anyone against ?
08:59:57 <jnon_> im ok
09:00:06 <QiLiang> me too
09:00:09 <anac1> #agreed merge yardstick-108
09:00:15 <jingwen> ok
09:00:19 <anac1> thanks !
09:00:51 <anac1> that's all for today, thanks everyone
09:00:55 <anac1> #endmeeting