15:00:03 <anac> #startmeeting Yardstick work meeting
15:00:03 <collabot> Meeting started Mon Nov 30 15:00:03 2015 UTC.  The chair is anac. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:03 <collabot> The meeting name has been set to 'yardstick_work_meeting'
15:00:10 <anac> #info Ana Cunha
15:00:19 <akiskourtis> #info Akis Kourtis
15:01:02 <anac> #topic vTC in OPNFV Ericsson lab
15:01:29 <anac> akiskourtis: have you started testing vTC in the lab?
15:02:22 <akiskourtis> I am currently waiting to synchronize with Intel on how to run the tests, and also talk to Daniel to fix my access
15:02:42 <anac> ok
15:02:58 <anac> #info work on-going to enable testing
15:04:34 <anac> daniel is trying to log in, irc has problems today
15:04:59 <akiskourtis> I will talk to him offline via email no worries
15:05:12 <anac> ok, let's move on then.
15:05:19 <anac> #topic dashboard
15:05:45 <anac> #info this was discussed in test&performance meeting last thursday
15:06:32 <anac> #info OPNFV testing dashboard will set max 10 graphs per project
15:06:54 <lmcdasm> #info Daniel Smith
15:07:01 <anac> #info I suggested we run a prototype for Yardstick with Grafana
15:07:05 <anac> hi daniel
15:07:19 <anac> #info no objections to my proposal
15:07:20 * lmcdasm waves
15:07:51 <anac> so, we will add 10 graphs to opnfv testing dashboard and all the rest (including also those 10) in grafana
15:08:24 <anac> we need to specify what we need for influxdB
15:08:46 <akiskourtis> do we know which node will be the centralized one?
15:09:08 <akiskourtis> meaning the grafana one
15:10:25 <anac> lmcdasm: do you think we host the grafana node in Montreal lab or we request to LF ?
15:10:37 <lmcdasm> it depends
15:10:48 <lmcdasm> if you want a influxDB node (a collector / parser node)
15:11:01 <lmcdasm> i can prop you one up in the Montreal POD and then you dont have to network from your YS setup to the LF POD
15:11:17 <lmcdasm> however, if you want those graphs public then that might be tricky
15:11:38 <lmcdasm> it might be better if you want to maek them public to have a DBnode in the backend and then setup a web front end on the Public OPNFVERICSSON.CA Web GW
15:11:52 <lmcdasm> (that way people who want to see dont need to have access to the Nodes themselves)
15:12:11 <lmcdasm> but really - figure out how you want it setup andlet mek now the RAM/CPU/HD you need and Ips and where (maybe drop it in the diagram or something)
15:12:27 <lmcdasm> and ill build out what you need..i have a granafa server running here that ive been playing with
15:12:36 <lmcdasm> but i dont know the data sets from YS so i dont know the hook in
15:12:55 <anac> i think sounds reasonable, people don't need to have access to the nodes to see the results
15:13:06 <lmcdasm> and its easier if you want to "show off"
15:13:16 <anac> :)
15:13:19 <lmcdasm> you can jus tpoint people to "www.opnfvericsson.ca/ys/granfana
15:13:23 <lmcdasm> or something like that
15:13:37 <lmcdasm> but like i said, lets get a mock up of how we want it to look adn the data flow
15:13:50 <lmcdasm> and we can worry about front end presentation when we have data going from YS to InfluxDB
15:14:06 <lmcdasm> (as well there is a RDP gw coming online this week - so access to the lab will be alot easier)
15:14:14 <anac> we need to collect data from different labs
15:14:20 <lmcdasm> hmm.
15:14:21 <lmcdasm> ok..
15:14:27 <lmcdasm> how are you going to do this
15:14:29 <lmcdasm> a pull or a push
15:14:34 <lmcdasm> over what protocol?
15:15:03 <anac> so, i thought, a centralized influxdB managed by releng, push data from the labs there, and then the grafana node in Montreal ?
15:15:12 <lmcdasm> that could work
15:15:26 <lmcdasm> so you would have InfluxDB sit near theJenkins Master (LF probably)
15:15:42 <lmcdasm> and then we setup a secure connection to a Granafa box (that will PULL) from the inflxDB to make graph queiries?
15:16:31 <anac> the question is how often to pull ? we want, eventually, realtime
15:16:38 <lmcdasm> well.
15:16:44 <lmcdasm> maybe a way to approach it is like this
15:16:49 <akiskourtis> in grafana you can set it up, through the graph
15:16:59 <lmcdasm> firs t- think how often (granularity) you will pull from the other labs
15:17:01 <akiskourtis> from 1sec to 1 hour, depends on what you want
15:17:36 <lmcdasm> and then think, are you giong to want to collate or do comparative processing on the lab data before sending it to INFLUXDB
15:17:49 <lmcdasm> and then from there, is it going to be standard DB queiries that sit and are "on demand"
15:18:00 <lmcdasm> or do we want something more on the grafana side.
15:18:09 <lmcdasm> i think that stuff will come after you establigh your connetions
15:18:18 <lmcdasm> i dont think we "know" how much data we are talking about yet
15:18:34 <anac> collate, i think - comparative analysis on grafana side
15:18:35 <lmcdasm> so might be hard to pick a measurement period until we see the flow of data -but im game to try something simple
15:18:43 <lmcdasm> like pull from labs every hour
15:18:49 <lmcdasm> and then do a parse and present every 6 hours
15:18:51 <lmcdasm> just to start
15:19:01 <lmcdasm> and then adjust as you see the data come in to make it more relevant
15:19:09 <lmcdasm> (all suggestions)
15:19:19 <anac> sounds good to start, akis: what do you think?
15:19:39 <akiskourtis> yes I think it is fine
15:20:00 <akiskourtis> when I setup the vTC I can start sending some test data, and see from there
15:20:08 <akiskourtis> when everybody joins onboard
15:20:11 <anac> we can start sending data from YS in CA also
15:20:22 <lmcdasm> ok..
15:20:33 <lmcdasm> if someone wants to send me the specs for the granfana box,
15:20:44 <anac> akis, can you do that?
15:20:46 <lmcdasm> ill stage it and get the grafana stuf fon there, give it an IP in your YS setup, etc
15:20:58 <akiskourtis> yes, of course
15:21:02 <lmcdasm> and then you can figure out the SSH link between LF Box and this one
15:21:07 <lmcdasm> thx akis!
15:21:24 <anac> i have a wish-list on the graphs here: https://etherpad.opnfv.org/p/yardstick_visualization
15:21:50 <anac> akis, can you specify the influxdB also ?
15:22:08 <anac> #action akiskourtis to specify the grafana box
15:22:23 <anac> we need to request from releng
15:22:30 <akiskourtis> yes, we can have them on the same machine, or should we do them separately?
15:22:41 <anac> separate locations
15:22:48 <akiskourtis> ok good
15:22:51 <anac> thanks
15:23:08 <anac> #action akiskourtis to specify the influxdB
15:23:24 <anac> just to check, do we need influxdB also on each lab?
15:23:45 <akiskourtis> it is not necessary, we can have on centralized
15:24:17 <anac> ok, we push the test results to the centralized, good
15:25:32 <anac> if nothing else on this topic, we move on?
15:25:55 <anac> #topic milestone D
15:26:09 <anac> #info milestone D is tomorrow, Dec 1st
15:26:26 <anac> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan/yardstick_milestone_d_report
15:27:02 <anac> i think we won't manage all test cases until jan 5, we will continue coding after that
15:27:14 <lmcdasm> sorry - one question about InfluxDB
15:27:18 <lmcdasm> if i can ?
15:27:22 <anac> yes? sure !
15:27:58 <lmcdasm> akis - did you want to setup a influx in Montreal as well to get started and built - i dont know the time for a LF request, but maybe you can also look to setup a central / remote replication (LF --> Montreal INflux)
15:28:04 <lmcdasm> that might be somethign to think about.. just a comment
15:28:33 <anac> you mean timing ?
15:28:44 <lmcdasm> ya
15:28:50 <lmcdasm> or perhaps, maybe easier.. make the request to LF
15:28:53 <lmcdasm> see the response
15:28:58 <lmcdasm> and if too long we will do something in house
15:28:59 <lmcdasm> ?
15:29:14 <akiskourtis> I prefer yes, as the vTC will be in Montreal, so as not to have connectivity troubleshooting
15:29:15 <lmcdasm> i dont know how "critical" in the project getting this up us
15:29:27 <lmcdasm> ok
15:29:33 <lmcdasm> so you let me know and we will get it done!
15:29:34 <lmcdasm> :)
15:29:40 <akiskourtis> ok thank you :)
15:30:28 <anac> so, we agree to set up a influxdB in Montreal to start with?
15:30:35 <akiskourtis> yes
15:30:45 <anac> perfect !
15:30:49 <lmcdasm> i think so - i like the idea of getting a small prototype of all the nodes up and running
15:30:55 <lmcdasm> in a friendly network that we control first
15:31:04 <anac> i like the ieda of not waiting
15:31:07 <lmcdasm> to make sure we have all the interfaces and how we want it to look/layout down
15:31:13 <lmcdasm> and then when the other place is ready
15:31:19 <lmcdasm> you can just port configs / replicate the parts you want
15:31:22 <lmcdasm> then you arent waiting
15:31:28 <lmcdasm> (well.. on me a bit maybe :P).
15:32:26 <anac> #agreed set up an influxDB in Montreal to start with
15:32:47 <anac> #info a request to centralized dB in LF (Releng) will also be placed
15:33:48 <jose_lausuch> anac: have a question about milestone D and SFC
15:34:05 <anac> let's get this started, by the your response time, lmcdsm, i need to think faster !
15:34:22 <anac> yes, jose_lausuch ?
15:34:33 <jose_lausuch> SFC is not in the DB yet
15:34:34 <jose_lausuch> http://213.77.62.197/test_projects
15:34:40 <jose_lausuch> I guess we need to include it
15:34:48 <jose_lausuch> or do we assume is it in yardstick reporting?
15:34:57 <jose_lausuch> (I prefer creating a project for SFC though)
15:35:17 <anac> yes, i will create a project for all yardstick "companions"
15:35:34 <anac> one for each, i mean
15:35:35 <jose_lausuch> will you?
15:35:40 <jose_lausuch> I can do it also right away
15:35:43 <jose_lausuch> but as you wish
15:35:48 <jose_lausuch> because Brady is scared :D
15:35:50 <anac> be my guest :)
15:36:32 <anac> can you also add IPVSIX, VNFGRAPH, KVM
15:36:42 <jose_lausuch> well, yes I can do that , but I need more info
15:36:53 <jose_lausuch> like wiki url, description of the project and so on
15:36:59 <jose_lausuch> if we want to add also the test cases
15:37:25 <anac> we don't have that yet, can't you leave blank for the time being ?
15:37:34 <anac> this is not the dashboard, right?
15:37:52 <anac> just the list of test cases, or?
15:38:14 <jose_lausuch> yes
15:38:24 <jose_lausuch> but for milestone D everything should be there by today
15:39:08 <anac> the test specifications should be frozen, does not mean they are ready !
15:39:52 <anac> i reported there is work to do on the detailed test specs
15:40:52 <jose_lausuch> ok
15:40:59 <jose_lausuch> I know
15:41:05 <jose_lausuch> but the test cases should be ready described
15:41:16 <jose_lausuch> minimum is : slogan+description
15:41:33 <anac> that is in jira, but we will have detailed .rst per test case
15:42:16 <anac> description of what is to be tested, expected result, param settings
15:42:47 <anac> does jira isse count as url you are after?
15:42:51 <anac> issue
15:43:21 <jose_lausuch> maybe yes
15:43:33 <jose_lausuch> if the JIRA issue is clear enough
15:43:38 <jose_lausuch> for now we have only wikis :)
15:43:40 <jose_lausuch> but its fine
15:44:07 <anac> ok, i can add my other compnion projects
15:44:14 <anac> companion
15:44:19 <jose_lausuch> I'll add SFC, since I'm in contact with BRady already
15:44:24 <jose_lausuch> you add the others, ok?
15:44:28 <anac> ok
15:44:44 <anac> do you want to work on SFC for Yardstick too ?
15:45:15 <anac> let me know
15:45:28 <anac> #topic other
15:45:36 <anac> anything else to discuss?
15:45:46 <jose_lausuch> for now I cannot say yes/no... Im getting stressed with many things
15:45:51 <jose_lausuch> I'll try my best :)
15:46:09 <anac> jose_lausuch, take your time
15:46:56 <anac> ok, that's all for today, thanks everyone !
15:47:01 <anac> #endmeeting