08:30:04 <anac1> #startmeeting Yardstick work meeting
08:30:04 <collabot`> Meeting started Thu Dec 17 08:30:04 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:04 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:04 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:30:11 <anac1> #info Ana Cunha
08:30:23 <kubi11> #info kubi
08:30:25 <QiLiang> info QiLiang
08:30:27 <YiminWang1> #info Yimin
08:30:54 <anac1> #topic HA test cases
08:30:54 <MMcG> #info MMcG
08:31:33 <anac1> #info review is on-going in Gerrit
08:32:09 <anac1> YiminWang1: there are a few patches in Gerrit for HA, are they all on-going work ?
08:32:30 <patrick2> #info patrick
08:32:44 <YiminWang1> yes, I upload a new patch, need review
08:33:25 <anac1> ok, this one https://gerrit.opnfv.org/gerrit/#/c/4175/
08:33:38 <anac1> right?
08:33:53 <YiminWang1> I will upload some more code patch for HA test cases implement
08:34:19 <YiminWang1> please help review https://gerrit.opnfv.org/gerrit/#/c/4007/
08:35:06 <anac1> #action all review https://gerrit.opnfv.org/gerrit/#/c/4007/ and  https://gerrit.opnfv.org/gerrit/#/c/4175/
08:35:17 <YiminWang1> yes the https://gerrit.opnfv.org/gerrit/#/c/4175/ is the test case description
08:35:27 <YiminWang1> thanks
08:35:30 <anac1> ok, thanks
08:35:34 <patrick2> anac1:  https://gerrit.opnfv.org/gerrit/#/c/4175/  has upload a new patch using a extend test case description template for HA.
08:35:47 <anac1> the test case template, did you check with HA?
08:36:10 <patrick2> seems have no reply from HA team
08:36:19 <YiminWang1> I sent an email to HA team, Fuqiao will review
08:36:39 <anac1> ok, let's wait for Fuqioa's review
08:37:02 <patrick2> ok
08:37:21 <YiminWang1> ok
08:37:24 <anac1> we should agree with HA on the extended template, then we use it for HA only, the other test cases uses the one we have, ok?
08:37:38 <patrick2> agree
08:37:46 <YiminWang1> +1
08:38:02 <patrick2> thank you
08:38:10 <anac1> #info Yimin and Patrick will discuss the extended template with HA
08:38:25 <anac1> #info after it is agreed, we use the extended for HA only
08:39:15 <anac1> #info after agreed, add the extended template to the template folder in gerrit, and add explanation that it is meant for HA test cases
08:39:25 <anac1> ok, anything else from HA test cases?
08:39:54 <anac1> ok, moving on then
08:39:59 <YiminWang1> the second test case is in etherpad
08:40:16 <YiminWang1> waiting for HA team review
08:40:24 <anac1> #info the secong HA test case is in Etherpad
08:40:33 <anac1> #info HA team needs to review it
08:40:44 <anac1> #topic community labs
08:40:55 <YiminWang1> after they review I will upload to gerrit
08:41:15 <anac1> ok, thanks YimimWang1
08:41:24 <YiminWang1> :)
08:42:04 <anac1> Yardstick run in LF POD2 is broken
08:42:08 <anac1> anyone on it ?
08:42:46 <patrick2> what is the situation?
08:43:09 <anac1> stopped working last night
08:43:16 <anac1> needs troubleshooting
08:43:25 <anac1> jnon, you here?
08:43:31 <jnon> yes
08:43:48 <anac1> can you check LF POD2 later today?
08:44:07 <jnon> locks like docker is not running there
08:44:45 <anac1> kubi1: what's the status on Huawei SC?
08:45:31 <kubi11> i have start to do intergration yardstick in santa clara lab with may, now it can be triggered ,but there is still a mysql problem
08:46:26 <anac1> ok, you working on the fault? need help?
08:47:04 <kubi11> i'm working on it ,i will troubleshoot it with compass team
08:47:12 <anac1> ok, thanks
08:47:52 <kubi11> i have add a daily yaml for sc lab
08:48:26 <anac1> ok, good, thanks !
08:48:42 <kubi11> :)
08:49:22 <anac1> Fuel 8 upgrade will happen soon, we need to keep track of Ericsson POD1 and LF POD2 (current Fuel 7)
08:49:55 <anac1> #info work on going in Huawei SC to enable Yardstick daily runs
08:50:05 <anac1> #topic Grafana
08:50:44 <anac1> krihun, any news ?
08:51:30 <krihun> not much, I have created an empty db for yardstick in Ericsson lab, but the schema for measurements is not yet defined
08:51:59 <anac1> there is a suggestion from vTC, i'll add to jira, plese check
08:52:03 <krihun> ok
08:52:25 <anac1> QiLiang: access working for you ?
08:52:31 <QiLiang> yes
08:52:34 <anac1> good
08:52:48 <MMcG> vTC connectivity to grafana up and running. First test runs yesterday.
08:53:00 <anac1> great ! thanks !
08:53:07 <MMcG> will need to modify once format finalized
08:53:14 <anac1> #info vTC connectivity to Grafa working
08:53:49 <anac1> MMcG: i'll add your suggestion to jira, krihun can comment
08:54:09 <anac1> also QiLiang and jnon can comment
08:54:26 <QiLiang> :)
08:54:42 <anac1> #topic vTC
08:55:10 <MMcG> unit testing complete with 100% coverage
08:55:18 <anac1> great, any problems in the lab ?
08:55:29 <vincenzo_riccobe> we are running the framework
08:55:31 <vincenzo_riccobe> on the lab
08:56:00 <anac1> ok, let's plan a demo for mid-January?
08:56:09 <vincenzo_riccobe> I need to check few small things before conferm 100% but it seems to work
08:56:28 <vincenzo_riccobe> it should be ok
08:56:38 <anac1> ok, the API to Yardstick: do you have a proposal ?
08:56:51 <vincenzo_riccobe> we have implemented the api
08:57:06 <vincenzo_riccobe> I think it is reasonable, but it would be great to have a chat
08:57:08 <vincenzo_riccobe> about it
08:57:18 <anac1> ok, how do you suggest we review?
08:57:22 <vincenzo_riccobe> we also implemeted a python script that shows how to use it
08:57:48 <vincenzo_riccobe> if you can give a contact to the people
08:57:50 <vincenzo_riccobe> involved
08:57:54 <anac1> jnon, QiLiang: ok to review the patches or do we need a meeting?
08:58:04 <vincenzo_riccobe> we could probably have a meeting to define what's neeeded
08:58:32 <anac1> ok, next monday morning ok for you ?
08:58:54 <vincenzo_riccobe> the 21th, yes! it's ok for us
08:59:09 <jnon> ok for me
08:59:16 <anac1> #info a meeting is needed to review the API for ApexLake - Yardstick
08:59:45 <vincenzo_riccobe> we also need to define yaml template accordingly
08:59:49 <vincenzo_riccobe> to define the test case
08:59:51 <anac1> #info next monday dec 21st, the meeting will be extended to 1 hour (UTC 8:30 - 9:30)
08:59:54 <vincenzo_riccobe> I think
09:00:26 <QiLiang> ok for me
09:00:26 <anac1> vincenzo_riccobe: i'll add a task in jira, you add the info the guys need to check before the meeting, ok?
09:00:39 <vincenzo_riccobe> sure
09:00:57 <vincenzo_riccobe> I can also upload the files on gerrit (they will need to be there at some stage)
09:00:58 <anac1> #action anac1 to update meeting invite, add gotomeeting details, create a task in jira
09:01:16 <vincenzo_riccobe> so they can also have a look at the interfaces (methods)
09:01:32 <anac1> #action vincenzo_riccobe to update the jira, upload the files to gerrit
09:01:58 <anac1> #action jnon,QiLiang,krihun: review the API proposal
09:02:21 <anac1> #info more reviewers are welcome !
09:02:44 <anac1> good progress, vincenzo_riccobe, thanks !
09:02:53 <anac1> anything else?
09:03:05 <vincenzo_riccobe> I have a question
09:03:08 <anac1> yes?
09:03:23 <vincenzo_riccobe> is it required further testing or deployment on different testbed(s)?
09:04:21 <anac1> for the vTC, we don't need to deploy on different testbeds, sure we can if we have the time
09:04:36 <anac1> and we define what test cases we will run
09:04:52 <vincenzo_riccobe> as you prefer
09:04:57 <anac1> if you have the possibility to develop more, let's add more test cases
09:05:08 <vincenzo_riccobe> I do not think it is not possible
09:05:13 <vincenzo_riccobe> by the code freezing
09:05:36 <vincenzo_riccobe> maybe for future OPNFV releases
09:06:10 <vincenzo_riccobe> I have also another question, which is about the initial configration of ApexLake. It would need some user actions and we are going to release a readme or similar.
09:06:17 <anac1> we will develop some test cases after the code freeze'
09:06:43 <vincenzo_riccobe> is that fine with you?
09:06:50 <anac1> ok, can you clarify what user actions ?
09:07:12 <vincenzo_riccobe> installing and configuring pktgen and smcroute software compoonents
09:07:32 <anac1> ok, we need to document those
09:07:49 <vincenzo_riccobe> as I sayd, we plan to submit a readme
09:08:03 <vincenzo_riccobe> is that ok, or do we need more?
09:08:48 <anac1> ok, you can submit the description and the team can provide comments
09:08:59 <vincenzo_riccobe> perfect
09:09:01 <vincenzo_riccobe> thatnks!
09:09:04 <anac1> then we can conclude if something else is needed
09:09:09 <anac1> ok?
09:09:27 <anac1> anything else?
09:09:27 <vincenzo_riccobe> absolutely yes! thanks!
09:10:02 <anac1> then that's all for today, thanks everyone
09:10:06 <anac1> #endmeeting