08:29:13 <kubi> #startmeeting Yardstick Work Meeting
08:29:13 <collabot`> Meeting started Mon Sep 12 08:29:13 2016 UTC. The chair is kubi. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:29:13 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:29:13 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:30:08 <kubi> #topic roll call
08:30:18 <kubi> #info kubi
08:30:24 <Jing> #info Jing
08:30:32 <zhihui_wu> #info zhihui_wu
08:30:37 <Kanglin> #info Kanglin
08:30:53 <mywulin> # wulin wang
08:31:01 <Mingjiang1> #info Mingjiang
08:31:03 <chenjiankun> #info chenjiankun
08:31:10 <mywulin> #info wangwulin
08:31:13 <kubi> zhihui_wu: hi, nice to see you again
08:32:04 <zhihui_wu> :) sorry for missing some meeting
08:32:24 <kubi> zhihui_wu: you are welcome :)
08:32:30 <kubi> #topic committer update after Colorado 1.0
08:32:46 <OPNFV-Gerrit-Bot> Rex Lee proposed yardstick: bugfix: yardstick reporing in stable branch omit stable/ https://gerrit.opnfv.org/gerrit/20865
08:32:53 <OPNFV-Gerrit-Bot> A comment has been added to a proposed change to yardstick: bugfix: yardstick reporing in stable branch omit stable/ https://gerrit.opnfv.org/gerrit/20865
08:33:50 <kubi> #info After Colorado 1.0, I will update the commiter list, remove the unactive committers and nominate actvie contributors
08:34:18 <kubi> thanks for all contributors
08:34:53 <kubi> #topic Colorado stable status
08:35:35 <kubi> #link https://wiki.opnfv.org/display/yardstick/Yardstick+Colorado+CI+Status
08:35:53 <kubi> here is the wiki page for stable status
08:36:20 <zhihui_wu> today I deploy scenario os-nosdn-ovs-ha on my local pod. It deployed successfully.
08:36:29 <zhihui_wu> But the instance can not accessed via floating ip.
08:38:08 <Jing> zhihui_wu: in which installer environment?
08:38:17 <zhihui_wu> with fuel
08:38:38 <OPNFV-Gerrit-Bot> A comment has been added to a proposed change to yardstick: bugfix: yardstick reporing in stable branch omit stable/ https://gerrit.opnfv.org/gerrit/20865
08:38:55 <zhihui_wu> from your link, yardstick with this scenario is also failed.
08:39:03 <kubi> Jing: Is the os-nosdn-ovs-ha work with CI?
08:39:36 <Jing> kubi: No, this scenario is not running in CI
08:39:37 <Mingjiang1> as i recall, only fuel support "os-nosdn-ovs-ha"
08:40:18 <zhihui_wu> Do you follow the statusof this scenario with fuel?
08:41:07 <kubi> zhihui_wu: so you want to deploy "os-nosdn-ovs-ha" to run DPDK test case?
08:41:26 <Jing> there is no run of this scenario with fuel yet.
08:41:36 <zhihui_wu> only this scenario support hugepage. I used to plan execute dpdk test case with this scenario.
08:41:39 <zhihui_wu> kubi, yes
08:42:38 <zhihui_wu> Is there anyone troubleshooting with this problem?
08:42:45 <Jing> zhihui_wu: This scenario is runing in master branch.
08:43:55 <zhihui_wu> Jing , you mean release c does not support this scenairo?
08:45:02 <kubi> zhihui_wu: Jing: I guess we need to check with Fuel team, It seems that they didn't run the CI job with stable branch.
08:45:54 <zhihui_wu> please check this https://build.opnfv.org/ci/view/fuel/job/fuel-os-nosdn-ovs-ha-baremetal-daily-colorado/
08:46:43 <zhihui_wu> I think they run the CI job, just becase the deploy job is failed, so yardstick job is not triggered.
08:47:09 <kubi> zhihui_wu: oh, yes, you are right
08:47:45 <zhihui_wu> but in my local pod, the deployment is successful, but the health check is failed.
08:48:18 <kubi> zhihui_wu: I see
08:49:07 <kubi> zhihui_wu: I 'd like to check with fuel team whether they have plan to fix the error before Colorado 1.0
08:49:20 <zhihui_wu> kubi, ok, thanks
08:49:45 <kubi> #action kubi will check with fuel team whether they have plan to fix os-nosdn-ovs-ha error before Colorado 1.0
08:49:46 <zhihui_wu> in master branch, the deployment job is successful
08:50:03 <kubi> zhihui_wu: thanks for figure out this.
08:50:08 <kubi> zhihui_wu: got it.
08:50:45 <kubi> #topic New Feature Demo
08:51:10 <kubi> #info last week, Mingjiang give a demo about test suite evolution
08:51:42 <kubi> so, I' d like to continue this demo to other new feature
08:52:20 <kubi> any volunteer to give a demo about new feature
08:53:15 <Jing> kubi: I would like to host the next demo.
08:53:40 <kubi> Jing: great, what would you like to show
08:54:19 <Jing> I can make a intro about the new plugin feature to the team.
08:54:46 <kubi> Jing: thansk
08:55:06 <kubi> #info Jing will give a demo about Yardstick Plugin to the team
08:55:40 <Mingjiang1> Jing: looking forwad to watch this demo
08:56:31 <kubi> As this thurday is mid autumn festival vacation, we will deley the demo to next Thursday Meeting.
08:56:44 <kubi> Jing: Is it OK for you?
08:57:03 <Jing> no problem
08:57:08 <kubi> Jing: thanks
08:57:34 <kubi> #info Next Demo will be given at Next Thursday Meeting.
08:57:49 <kubi> #topic others
08:57:50 <kubi> anything else?
08:57:53 <zhihui_wu> yes
08:58:02 <kubi> zhihui_wu: go ahead
08:58:06 <zhihui_wu> I noticed that base ubuntu iso file and cirros are put into yardstick docker image. IMO, it is not good to make a big yardstick docker image.
08:58:27 <zhihui_wu> I suggest to boot the yardsitck containner with parameter -v, mount a local image store directory to the container.
08:59:16 <zhihui_wu> the owner of pod can download the iso file on local.
09:00:37 <kubi> zhihui_wu: good suggestion:)
09:01:16 <kubi> zhihui_wu: ubuntu iso file was added with the storperf integration
09:02:16 <zhihui_wu> Maybe I miss some important thing.
09:02:31 <zhihui_wu> can you give more details about it ?
09:04:36 <kubi> zhihui_wu: one questiion is how to make it work with CI, if we use -v, we need every CI pod exist ISO file at first
09:05:22 <kubi> zhihui_wu: ubuntu iso is used for storperf test case.
09:05:40 <zhihui_wu> if ci pod doesn't exist iso file, we can download it
09:05:50 <zhihui_wu> just like preious
09:06:19 <zhihui_wu> just like before
09:06:37 <Mingjiang1> i suggest this to be posponed, since we want all this to be automatic
09:06:46 <Mingjiang1> in CI
09:08:17 <Mingjiang1> now we've got docker ci job to push docker image everyday
09:08:35 <zhihui_wu> please refer the jjb file of fuel, it is a common practice
09:10:08 <zhihui_wu> it can be postponed, but it is worth to be considered
09:11:02 <Mingjiang1> agree, if this practice can short the ci time, that would be great.
09:11:19 <kubi> zhihui_wu: I think it is a good idea.
09:11:34 <kubi> zhihui_wu: could you help to do this?
09:11:47 <zhihui_wu> Yes, I am glad to do this
09:12:03 <kubi> zhihui_wu: great! thanks
09:12:22 <zhihui_wu> I did the same task with qtip. :)
09:12:54 <kubi> zhihui_wu: could you create a JIRA about this task after the meeting
09:13:10 <zhihui_wu> kubi, ok
09:13:20 <kubi> zhihui_wu: thank
09:14:29 <kubi> #info zhihui will create a jira about remove the iso file from Yardstick docker image and Run with CI.
09:14:42 <kubi> zhihui_wu: thanks, anything else?
09:15:11 <zhihui_wu> nope yet
09:15:36 <kubi> OK, thanks for today.
09:15:44 <kubi> #endmeeting