08:31:00 <kubi001> #startmeeting Yardstick Work Meeting
08:31:00 <collabot`> Meeting started Mon Nov 28 08:31:00 2016 UTC.  The chair is kubi001. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:31:00 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:31:00 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:31:08 <kubi001> #topic roll call
08:31:10 <kubi001> #info kubi
08:31:14 <Mingjiang> #info Rex
08:31:16 <JingLu> #info Jing
08:31:17 <JackChan> #info Jack
08:31:26 <rbbratta> #info Ross
08:31:54 <kubi001> rbbratta: what's time for you now ?
08:32:24 <rbbratta> 12:30 AM, but I'm usually up this late
08:33:23 <kubi001> rbbratta: thanks for your joining
08:33:25 <kubi001> :)
08:33:39 <kubi001> let's move to today's topic
08:34:08 <kubi001> #topic Yardstick flake8
08:34:50 <Mingjiang> Ross suggested that we can modify the columns limtation from 79->99
08:35:30 <rbbratta> I find it helps a little bit with not having to wrap so much
08:37:00 <kubi001> rbbratta: so if we want to change the limit from 79 to 99.  what we need to do?  should we use the pep257 to check the code?
08:37:36 <rbbratta> flake8 --max-line-length=99
08:38:25 <rbbratta> in run_tests.sh I guess
08:38:47 <rbbratta> and then everyone adjusts their IDEs to wrap
08:39:22 <Mingjiang> Kubi: does OPNFV devguide have any restriction about this?
08:40:07 <kubi001> It seems that the default setting of gerrit page is also 99
08:40:39 <kubi001> Mingjiang: I'm not sure, Let me check it after the meeting
08:41:34 <kubi001> If there is no special restriction , we can change it as rbbratta's suggestion
08:41:44 <JingLu> agree
08:41:54 <Mingjiang> +1
08:42:23 <kubi001> #action kubi will check if there is special restriction from community.
08:42:30 <Mingjiang> yes, gerrit limitation "red line" is set to be 99, we can see it the gerrit view
08:42:31 <kubi001> #undo
08:42:31 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x233a210>
08:43:08 <kubi001> #action kubi will check if there is special restriction of line length from community.
08:43:27 <rbbratta> on a related topic,  have we tried using pylint, shellcheck, yaml-lint, etc.
08:44:17 <JackChan> rbbratta: I find the limit in openstack/nova is 79. Do you have any other reasons to support 99?
08:45:37 <kubi001> rbbratta: at now, we use the flake8 and unittest to verify the code, that would be great if we have the more check tool.
08:46:11 <rbbratta> not really,  it does make it harder to automatically refactor code.  for the logging and context manager fixes I used lib2to3 to manipulate the parse tree
08:46:48 <rbbratta> pylint is very good.  shellcheck is good for bash,  yaml-lint can catch inconsistent yaml indents and yaml errors
08:47:15 <kubi001> But, I'm not sure If there is a lot of work to fix the error from pylint and shellcheck, yaml-lint
08:47:31 <Ace__> i think shellcheck may have some problem such like netperf tool can't identity the "$xxx" parameter.
08:48:19 <rbbratta> Ace__: I didn't check the netperf stuff, was there a specific error?
08:48:46 <kubi001> If we want to use the those tools as gerrit verify, we need to fix the error before we enable the new checker
08:49:13 <rbbratta> pylint catches more errors than flake8 in my experience, you do have to heavily customize the list of warning and errors, but I have a pylint wrapper from other projects we can re-use
08:49:29 <Ace__> the error is can't identity the parameter
08:49:41 <kubi001> rbbratta: sounds good
08:51:13 <rbbratta> Ace__: we might be double-quoting
08:52:21 <rbbratta> I'll try to publish a pylint wrapper
08:52:58 <JingLu> That's great.
08:53:03 <Ace__> i will check if there are double-quoting
08:53:17 <kubi001> rbbratta: thanks a lot.
08:53:26 <Ace__> you could discuss another question when i am testing
08:54:14 <kubi001> rbbratta: I heard from the guys from releng, they may want to do some common check for every projects
08:55:11 <kubi001> It seems that their solution also include shellchecker and yaml-lint
08:55:38 <kubi001> shellchecker =>shellcheck
08:56:44 <kubi001> #topic Testcase tier proposal review
08:57:07 <JingLu> Here is the link for the proposal link: https://wiki.opnfv.org/display/yardstick/Yardstick+test+case+tier+proposal
08:58:01 <JingLu> I have try to align the test case tier with waht functest does
08:58:49 <kubi001> JingLu: thanks for your work
08:59:08 <JingLu> any comment about the proposal?
08:59:29 <Mingjiang> i think you may list the tier in the order of tire number
09:00:32 <Mingjiang> #link https://wiki.opnfv.org/display/yardstick/Yardstick+test+case+tier+proposal
09:00:41 <JingLu> I  will draw a pic to illustrate the hierachy
09:00:54 <Mingjiang> that would be great
09:01:00 <kubi001> #action JingLu will draw a pic to illustrate the hierachy
09:01:58 <kubi001> #topic others
09:02:09 <kubi001> any other topic from you?
09:02:25 <Ace__> and the netperf problem
09:02:28 <Ace__> is that
09:02:36 <Ace__> i try to use "$xxx" "${xxx}" and "{$xxx}" there is always problem as follows:
09:02:47 <Ace__> WARNING! THROUGHPUT_UNITS,MEAN_LATENCY,LOCAL_CPU_UTIL,REMOTE_CPU_UTIL,LOCAL_TRANSPORT_RETRANS -m 65536 -M 87380 not recognized as an address family, using AF_UNPSEC
09:02:47 <Ace__> Are you sure netperf was configured for that address family?
09:02:47 <Ace__> resolve_host: could not resolve host ' 10.1.0.51 -l 20 -t TCP_STREAM -c -C -- -O THROUGHPUT' port '(null)' af AF_UNSPEC
09:02:49 <Ace__> getaddrinfo returned -2 Name or service not known
09:02:50 <OPNFV-Gerrit-Bot> Ross Brattain proposed yardstick: DRAFT: jenkins flake8, pylint, py.test wrapper  https://gerrit.opnfv.org/gerrit/25001
09:02:51 <Ace__> Netperf could not resolve  10.1.0.51 -l 20 -t TCP_STREAM -c -C -- -O THROUGHPUT as a host name
09:03:51 <rbbratta> okay, so we don't quote in netperf_benchmark.bash because each arg is already quoted
09:03:52 <Mingjiang> thanks ross, impresive by your lightening speed
09:04:34 <Ace__> oh, yes
09:05:07 <kubi001> rbbratta: thanks for your great contribution
09:06:59 <rbbratta> no problem
09:07:52 <kubi001> ok, any more comments?
09:08:19 <kubi001> Thanks all for today.
09:08:24 <kubi001> #endmeeting