08:31:06 <rbbratta> #startmeeting yardstick work meeting
08:31:06 <collabot> Meeting started Mon Sep 18 08:31:06 2017 UTC.  The chair is rbbratta. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:31:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:31:06 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:31:11 <rbbratta> #topic roll call
08:31:13 <rbbratta> #info Ross
08:31:15 <Mingjiang> #info Rex
08:31:25 <JingLu> #info JingLu
08:31:47 <rbbratta> #topic action item follow up
08:31:49 <kubi001> #info Kubi
08:31:58 <rbbratta> #info AP1: check Apex jobs
08:31:59 <JackChan> #info Jack
08:32:15 <rbbratta> Apex was failing due to docker issues, it looks like they upgraded docker without removing the old images
08:32:58 <abhijitsinha> #info Abhijit
08:32:59 <rbbratta> Apex team suggested we combine docker image removal script with functest, but that is releng business
08:33:24 <rbbratta> #action rbbratta follow up on releng to combine docker image remove scripts
08:33:45 <rbbratta> #action rbbratta fix yardstick meeting links
08:33:58 <rbbratta> I forgot which links were bad?
08:34:07 <rbbratta> #action rbbratta send new yardstick email meeting invites
08:34:21 <kubi001> https://wiki.opnfv.org/display/meetings/Yardstick
08:34:38 <rbbratta> need to send meeting invite with Outlook
08:35:28 <rbbratta> next topic
08:35:54 <rbbratta> #topic Euphrates CI
08:36:23 <rbbratta> we have branched, but it looks like nothing else is setup for euphrates,  gerrit-bot and other things aren't setup.
08:36:54 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/42189/1  jenkins jobs for euphrates
08:37:21 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/42203/ jenkins yardstick project jobs for euphrates
08:38:18 <rbbratta> is that all we need to do to enable euphrates?
08:38:47 <kubi001> https://build.opnfv.org/ci/view/yardstick/
08:38:58 <rbbratta> how do we update the view?
08:39:24 <kubi001> I guess Jing have the right to update the view
08:40:27 <rbbratta> JingLu: do you know what needs to be done for Euphrates in Jenkins?
08:40:47 <JingLu> I will try to figure out how to update the view
08:41:23 <rbbratta> #action JingLu figure out how to update Jenkins for Euphrates
08:41:34 <kubi001> meanwhile, should we add a new item in grafana for Euphrate, so user can select the result from stable branch.
08:42:30 <JingLu> @rbbratta normally, just update the yardstick jjb in releng and make sure all scenarios in installers have a corresponding testsuite file
08:42:30 <collabot> JingLu: Error: "rbbratta" is not a valid command.
08:42:53 <rbbratta> JingLu: okay, we'll check after releng changes are merged
08:44:20 <rbbratta> side-topic: Intel IT forced a change in firewall rules for Intel pods, we now have whitelist of external connections, so influxdb http://104.197.68.199:8086/write?db=yardstick  is not working
08:44:44 <rbbratta> what is http://104.197.68.199:8086  ?  what host is that?
08:45:38 <JackChan> rbbratta: wait minutes, I will check it.
08:46:25 <rbbratta> are there any other outgoing connections required for yardstick CI?  Do we connect to external grafana?
08:47:51 <JackChan> It seem it is a vitual machine. So I not sure what pod it is located
08:48:23 <JackChan> But I have check the grafana, it can get data from influxdb. So our influxdb seems fine.
08:49:45 <kubi001> rbbratta: could you add this IP into your whitelist?
08:50:56 <rbbratta> kubi001: I will submit request, but it is better if it has a hostname
08:51:16 <rbbratta> okay where it is located
08:51:30 <rbbratta> or where it is located
08:52:02 <JackChan> the hostname is gce-opnfv-influxdb-fbrockners
08:52:44 <rbbratta> #action rbbratta add gce-opnfv-influxdb-fbrockners:8086 to intel pod whitelist
08:52:51 <kubi001> It seems that it is related to frank
08:53:14 <rbbratta> are there any other outgoing connections we need?
08:53:28 <rbbratta> do we ssh anywhere?
08:54:15 <kubi001> I guess no more outgoing connection
08:54:45 <kubi001> well, one more connection
08:55:07 <kubi001> report to MongoDB which are host by community
08:56:29 <rbbratta> kubi001: do you know where we do that?  in Jenkins CI?
08:57:20 <kubi001> yes. daily jobs
08:58:04 <kubi001> http://testresults.opnfv.org/reporting/master/yardstick/status-compass.html
08:58:16 <kubi001> to generate above page
08:58:39 <rbbratta> I see  YARDSTICK_DB_BACKEND 104.197.68.199:8086
08:59:49 <rbbratta> if it is on regular port 80, or 8080, then it should be okay, only non-standard ports like 8086 are blocked.
09:00:03 <rbbratta> okay, running out of time.
09:00:31 <rbbratta> I wanted to discuss https://jira.opnfv.org/browse/YARDSTICK-699 as well, but maybe that can wait until tomorrow.
09:00:50 <rbbratta> #info https://jira.opnfv.org/browse/YARDSTICK-699 update yardstick ci test case in euphrates
09:01:11 <rbbratta> Mingjiang wanted to rearrange the test cases for Euphrates
09:01:23 <rbbratta> #topic AoB
09:02:09 <Mingjiang> yes, i think we can rearrange the test suite if necessary
09:03:33 <rbbratta> Mingjiang: do you have proposal?  can you add to Jira?
09:04:37 <Mingjiang> no specific proposal for now, maybe we can discuss tomorrow so we can share the points
09:05:01 <rbbratta> last before I forget, although we branched stable/euphrates, I think we still want to sync up with master still, until things slow down.
09:05:18 <rbbratta> or until Euphrates CI starts working
09:06:51 <Mingjiang> agree, so how do we sync, is there any best practice to guide?
09:07:38 <rbbratta> I just rebased master on top of stable/euphrates and did a git-review on stable/euphrates which created all the reviews.
09:07:39 <kubi001> sorry, what does the "sync up with master" mean?
09:07:55 <rbbratta> then I just +2/+1 and merged them.
09:08:31 <rbbratta> kubi001: it means everything we have in master currently we also want in stable/euphrates.
09:09:02 <rbbratta> kubi001: I just cherry-picked all the stuff from master into stable/euphrates.
09:10:06 <rbbratta> once we have Euphrates CI working, then we can cherry-pick individual fixes
09:10:14 <kubi001> rbbratta: ok, got it
09:10:42 <rbbratta> okay, I think that's it for now.   see you all next meeting
09:10:49 <kubi001> sounds reasonable
09:11:16 <rbbratta> #endmeeting