09:30:31 <mj_rex> #startmeeting Yardstick weekly meeting - Jan 29
09:30:31 <collabot`> Meeting started Tue Jan 29 09:30:31 2019 UTC.  The chair is mj_rex. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:30:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:30:31 <collabot`> The meeting name has been set to 'yardstick_weekly_meeting___jan_29'
09:30:54 <mj_rex> #topic Roll Call
09:31:07 <mj_rex> #info Rex Lee
09:33:35 <mj_rex> efoley: Hi, i’m not be able to use the zoom now. Can we use irc?
09:33:46 <efoley> Sure
09:34:21 <mj_rex> #topic gating time
09:34:34 <efoley> #info Emma Foley
09:34:53 <efoley> Did you get my e-mail last week?
09:35:17 <efoley> We have some really long UTs that are taking a lot of time and need to be looked at
09:35:22 <mj_rex> #info efoley has list current verify job time
09:36:16 <mj_rex> yes, some ut takes more than 3 minutes
09:36:46 <efoley> It's gotten worse recently. It used to take less than a minute to run them
09:36:55 <efoley> This was as recently as Fraser
09:37:19 <mj_rex> why it takes so long?
09:37:30 <efoley> These long tests should be revised, or refactored as functional tests
09:37:35 <mj_rex> and it get worse?
09:38:04 <efoley> Some of the longer ones may be relying on delays
09:38:40 <efoley> I haven't had a chance to take a look yet though
09:39:14 <mj_rex> i would suggest to make them functional test first, if it could be refactored to take much less time, it could be move back
09:41:02 <efoley> I will move the Timer tests to functional
09:41:58 <efoley> I will take a look at the others and propose some changes
09:42:41 <mj_rex> and it would be better we add the time count in the log, so we’ll know better about the job time, is it necessary?
09:43:57 <efoley> We can update the job to use pytest in the gate as well
09:44:06 <efoley> the changes would be minimal
09:44:28 <efoley> pytest supports unittest without any changes
09:44:58 <efoley> #action move longer tests to functional
09:45:26 <efoley> #action use pytest in the gate jobs to list timings
09:45:31 <mj_rex> yes, it looks great to use pytest
09:45:52 <efoley> #info pytest can be used with unittest without any modifications
09:47:34 <efoley> We could also look at running tests selectively
09:48:04 <efoley> as in, don't run UTs when there's a doc-only change
09:48:46 <mj_rex> agree
09:49:14 <mj_rex> could we add a precheck filter for it?
09:49:53 <mj_rex> this is also what patrice suggest in the last meeting
09:50:21 <efoley> I think there's a way in jenkins to do this check
09:50:30 <efoley> When defining the jobs
09:50:59 <efoley> That's what hte docs jobs already do
09:51:25 <mj_rex> that would be great, we can add it directly in the job template
09:51:47 <efoley> In releng?
09:52:58 <mj_rex> is it possible to be done in releng jenkins job?
09:53:05 <efoley> mj_rex: Do you want to take that action? Update the job template to only run code tests on code changes?
09:53:31 <mj_rex> yes, i would take the action
09:53:37 <OPNFV-Gerrit-Bot> Serhiy Pshyk proposed yardstick: [WIP] Add new scenario NSPerf-RFC2544  https://gerrit.opnfv.org/gerrit/66561
09:53:40 <efoley> It's a small minority of changes that have no python changes, but it's makes for shorter gating times for docs-only
09:54:08 <efoley> #action mj_rex: Update the job template to only run code tests on code changes?
09:54:12 <efoley> #undo
09:54:19 <efoley> #action mj_rex: Update the job template to only run code tests on code changes
09:55:43 <efoley> Any other item in this topic?
09:56:05 <mj_rex> i’m done with it
09:56:25 <mj_rex> #topic AoBs
09:56:51 <efoley> Open reviews?
09:57:09 <efoley> I hsvea bunch of refactoring ones open
09:57:34 <efoley> I have a bunch of refactoring ones open
09:58:01 <mj_rex> #info efoley has a bunch of refactoring open for review
09:59:27 <mj_rex> I’ll review them today after the meeting.
09:59:39 <efoley> https://gerrit.opnfv.org/gerrit/#/q/project:yardstick+Rework+network_services+owner:%22Emma+Foley+%253Cemma.l.foley%2540intel.com%253E%22
10:00:42 <efoley> I've recently added an update to the dynamic html report (yardstick report generate-nsb) that pulls barometer metrics in. It's a WIP at the moment, but any feedback is appreciated
10:01:28 <efoley> There is some work ongoing to reduce the number of sample files and make use of jinja2 templating so that new users can make use of the samples more easily
10:02:43 <efoley> https://gerrit.opnfv.org/gerrit/#/q/owner:%22John+O'Loughlin%22+status:open+cli
10:02:44 <mj_rex> i’m now wip on the alpine image, would have a patch this week
10:02:51 <efoley> Awesome
10:03:22 <efoley> #info mj_rex had WIP on rebasing the yardstick container to use Alpine Linux
10:03:45 <efoley> #info WIP on testcase templating: https://gerrit.opnfv.org/gerrit/#/q/owner:%22John+O'Loughlin%22+status:open+cli
10:04:38 <mj_rex> it would be China spring festival holiday next week, so i might cancel next weekly meeting.
10:04:52 <efoley> I am out of office next wekk too
10:05:18 <mj_rex> ok, so i’ll cancel it next week
10:05:39 <shobhi> #info WIP on creating a metadata table in influxdb database in yardstick.
10:06:07 <shobhi> This metadata table will help in grafana templating and will reduce number of TC
10:07:11 <efoley> We should have a recurring dev update section :) There's a lot going on at the moment, especially in terms of efficiency and helping user interaction
10:08:25 <efoley> Is that everything?
10:09:08 <mj_rex> yes, that’s all from my side
10:09:20 <shobhi> yes
10:09:26 <efoley> shobhi?
10:09:40 <shobhi> yes, that's all from my side too :)
10:09:52 <efoley> I'm done too
10:09:59 <mj_rex> #info next weekly meeting would be canceled
10:10:03 <efoley> Thanks Rex
10:10:08 <mj_rex> thank you all
10:10:27 <shobhi> Thanks
10:10:29 <mj_rex> #endmeeting