16:00:18 <vikramdham_> #startmeeting ovn4nfv weekly
16:00:18 <collabot> Meeting started Fri Aug 11 16:00:18 2017 UTC.  The chair is vikramdham_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:18 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:18 <collabot> The meeting name has been set to 'ovn4nfv_weekly'
16:00:45 <vikramdham_> #chair vikramdham_ trinaths
16:00:45 <collabot> Current chairs: trinaths vikramdham_
16:02:13 <trinaths> #info Trinath Somanchi - NXP
16:02:19 <trinaths> 0/
16:02:22 <trinaths> o/
16:02:56 <vikramdham_> #info Vikram Dham - Futurewei
16:03:22 <trinaths> vikramdham_: Hi, Good Morning.
16:03:50 <vikramdham_> Hi @trinaths
16:04:04 <vikramdham_> thanks for leading and guiding the project in my absence
16:05:16 <vikramdham_> would you like to add anything to agenda or change order of any item?
16:05:34 <trinaths> vikramdham_: :) thanks a lot for giving me that oppurtunity. it was a very good learning for me.
16:05:36 <vikramdham_> believe we can get started
16:05:41 <trinaths> yes
16:05:46 <trinaths> I added few to agenda.
16:06:04 <trinaths> https://wiki.opnfv.org/display/OV/Meeting+Agenda
16:06:15 <vikramdham_> ok I see now
16:06:58 <vikramdham_> 1. would like to discuss MS5
16:07:27 <trinaths> its there in the agenda.
16:08:12 <rprakash_> #info rprakash
16:08:14 <vikramdham_> do you know is joid has scenario running
16:08:25 <vikramdham_> in jenkins
16:08:33 <vikramdham_> welcome @rprakash_
16:09:07 <trinaths> vikramdham_: it was added to jenkins. I think its running.
16:09:15 <trinaths> rprakash_: hi, Good Morning
16:09:21 <rprakash_> #sure same to trinath and where is Narinder?
16:09:47 <vikramdham_> don't see him online
16:09:50 <rprakash_> #link https://build.opnfv.org/ci/view/joid/
16:09:55 <trinaths> rprakash_: its not morning here, it 2139 hrs,
16:10:30 <vikramdham_> ovn4nfv-build-master
16:10:30 <vikramdham_> ovn4nfv-virtual-daily-master
16:10:30 <vikramdham_> joid-k8-ovn-lb-noha-virtual-daily-master
16:10:32 <vikramdham_> joid-k8-ovn-lb-noha-baremetal-daily-master
16:10:34 <vikramdham_> apex-os-ovn-nofeature-noha-baremetal-danube
16:10:36 <vikramdham_> apex-os-ovn-nofeature-noha-baremetal-master
16:10:38 <vikramdham_> joid-k8-ovn-lb-noha-cengn-pod1-daily-master
16:10:40 <vikramdham_> joid-k8-ovn-lb-noha-orange-pod1-daily-master
16:10:42 <vikramdham_> apex-testsuite-os-ovn-nofeature-noha-baremetal-danube
16:10:44 <vikramdham_> apex-testsuite-os-ovn-nofeature-noha-baremetal-master
16:12:22 <vikramdham_> looks like joid jobs are running into issues in jenkins
16:13:01 <rprakash_> #info tried cant locate ovn in https://build.opnfv.org/ci/view/joid/job/functest-joid-baremetal-daily-master/lastBuild/console
16:13:27 <trinaths> ok
16:13:37 <rprakash_> so will need some one to verify let move next now
16:14:12 <vikramdham_> rprakash_ check here - https://build.opnfv.org/ci/job/joid-k8-ovn-lb-noha-baremetal-daily-master/
16:14:31 <trinaths> api-check failed.
16:15:35 <rprakash_> #apex we did see it fail yesterday so noted and await response from radez
16:15:58 <vikramdham_> trinaths where do you see that message?
16:16:51 <trinaths> #link: https://build.opnfv.org/ci/view/joid/job/functest-joid-baremetal-daily-master/lastBuild/console
16:17:04 <trinaths> https://build.opnfv.org/ci/view/joid/job/functest-joid-baremetal-daily-master/lastBuild/console
16:17:08 <trinaths> 2017-08-11 11:31:45,705 - functest.ci.run_tests - INFO - Running test case 'api_check'...
16:17:14 <trinaths> +-------------------+------------------+------------------+----------------+ |     TEST CASE     |     PROJECT      |     DURATION     |     RESULT     | +-------------------+------------------+------------------+----------------+ |     api_check     |     functest     |      06:10       |      FAIL      | +-------------------+------------------+------------------+----------------+
16:17:18 <vikramdham_> is ovn job subset of this job?
16:17:30 <vikramdham_> or i thought it was seperate
16:17:32 <vikramdham_> https://build.opnfv.org/ci/job/joid-k8-ovn-lb-noha-baremetal-daily-master/
16:17:58 <vikramdham_> will need to follow up with Narinder if we are not sure
16:18:29 <vikramdham_> similarly for apex we saw errors
16:18:43 <vikramdham_> #info email sent to dradez for clarification
16:18:48 <trinaths> https://build.opnfv.org/ci/job/joid-deploy-baremetal-daily-master/2397/
16:18:55 <trinaths> https://build.opnfv.org/ci/job/joid-deploy-baremetal-daily-master/2388/
16:19:00 <rprakash_> #note we had 5 api's that inluded connect, api_check, vping_ssh, vping_userdata and some terminate are we referring to those ?
16:19:01 <trinaths> k8-ovn-lb-noha
16:19:29 <vikramdham_> ok
16:19:31 <trinaths> yes
16:19:35 <trinaths> rprakash_: yes
16:19:51 <vikramdham_> those tests may not be valid for k8s?
16:19:55 <trinaths> rprakash_: https://build.opnfv.org/ci/view/joid/job/functest-joid-baremetal-daily-master/lastBuild/console
16:19:57 <vikramdham_> as those are os specific?
16:20:23 <trinaths> in that above link, the fail is on DEPLOY_SCENARIO=os-nosdn-lxd-ha
16:20:43 <rprakash_> Unless you get clarification form Dan Radez on which tests he refers to vs. what JOID k8 refres to we have a confusion here, need clarity to seperate the two
16:21:04 <vikramdham_> agreed
16:21:39 <vikramdham_> #action vikramdham_ email to Narinder & Dan Radez
16:21:40 <trinaths> +1
16:22:17 <rprakash_> vikram please take one action for you to get Da Radez clear for you and let Trainath take an actio to clear on with Narinder on k8 and I will leave as I need to get to offcie
16:22:18 <trinaths> there are no ovn featues atll
16:22:32 <vikramdham_> #info currently we have 2 installers in pipeline for MS5
16:22:40 <vikramdham_> #info apex and joid,
16:22:54 <vikramdham_> any updates from compass4nfv ?
16:23:18 <rprakash_> #info as per Dan OVN is not a feature its SDNC and therefore he is etiher testing simple tempets tests and not ovn as sdnc based on scenarion name
16:25:24 <rprakash_> #we have no updates from compass4nfv and send and use for later if possible
16:25:59 <rprakash_> #nee to leave please continue viram and trinath
16:26:03 <vikramdham_> #action vikramdham_ follow with Compass
16:26:20 <vikramdham_> #action trinaths follow with Narinder
16:26:39 <vikramdham_> trinaths_ can you update about your devstack env ?
16:27:21 <trinaths> vikramdham_: I have faced couple of issues with devstack
16:27:27 <trinaths> they were all cleared now.
16:27:33 <vikramdham_> ok great
16:27:55 <vikramdham_> did you follow rusell's blog or github?
16:27:58 <trinaths> I was running functional tempest tests on the environment.
16:28:06 <trinaths> vikramdham_: https://jira.opnfv.org/browse/OVN4NFV-9
16:28:20 <vikramdham_> do those tests pass ?
16:28:50 <trinaths> vikramdham_: its taking long time. will post the results to jira now.
16:28:58 <trinaths> vikramdham_: i followed,  https://docs.openstack.org/networking-ovn/latest/contributor/testing.html
16:28:59 <vikramdham_> ok
16:29:12 <vikramdham_> great progress
16:29:53 <trinaths> we got approval for pharos lab setup.
16:29:54 <vikramdham_> for ms6 we need to identify tests and move them to ovn4nfv repo so that functest can call them
16:30:14 <vikramdham_> pharos lab at nxp ?
16:30:20 <trinaths> currently we are acquiring hardware and lab setup in progress
16:30:21 <trinaths> yes
16:30:27 <vikramdham_> great
16:30:41 <trinaths> vikramdham_: what tests we need identify ?
16:30:55 <trinaths> vikramdham_: tempest functional tests be moved to functests?
16:31:02 <vikramdham_> apex has tests which are being called by functest
16:31:30 <vikramdham_> http://testresults.opnfv.org
16:31:34 <vikramdham_> is down currently
16:31:46 <trinaths> oh ok
16:32:14 <vikramdham_> we can identify tests used by apex and port them to ovn4nfv repo
16:32:23 <trinaths> okay.
16:32:50 <trinaths> vikramdham_: also I have sent an email about edgenfv dev conf. where chris is in program committe
16:33:03 <trinaths> please try to attend if you are near
16:33:08 <vikramdham_> do we have any task left for ms5?
16:33:24 <vikramdham_> yes will try to attend
16:33:31 <vikramdham_> or have someone from my team
16:34:05 <trinaths> ok
16:34:23 <trinaths> I have https://jira.opnfv.org/browse/OVN4NFV-9 and https://jira.opnfv.org/browse/OVN4NFV-6
16:34:34 <trinaths> I dont think I have tasks pending for MS5
16:34:39 <vikramdham_> ok
16:34:58 <vikramdham_> is anything blocking us for ms6 or are we on schedule
16:35:12 <vikramdham_> https://git.opnfv.org/functest/tree/docs/testing/user/userguide/introduction.rst
16:35:37 <trinaths> what is the expectation for MS-6
16:36:04 <trinaths> https://jira.opnfv.org/browse/OVN4NFV-6 has 2 sub tasks. 1.Verify if the test described in E-Release are correct and if not modify it
16:36:15 <trinaths> 2.Review Tempest tests and update ovs or ovn tests there if they can be applied to OPNFV
16:36:16 <vikramdham_> trinaths can you help follow up with jose/morgan and see what they need from ovn4nfv for functest integration?
16:36:27 <trinaths> sure.
16:37:00 <vikramdham_> for 1 http://testresults.opnfv.org is down, will need to check api when it comes up
16:37:01 <trinaths> can you give their email addresses or initiate an email. I will follow-up
16:37:28 <vikramdham_> i will send you their addresses
16:37:52 <trinaths> ok
16:38:32 <trinaths> #action: Follow-up jose/morgan and find out the requirements on OVN4NFV for functest integration
16:39:19 <trinaths> vikramdham_: #link, https://blogs.rdoproject.org/7963/ovn-support-in-tripleo?utm_content=buffer0afed&utm_medium=social&utm_source=linkedin.com&utm_campaign=buffer
16:39:50 <trinaths> numans has helped me resolve ovn based issues.
16:40:04 <vikramdham_> good
16:40:30 <trinaths> we have triple-o project too in opnfv. do we want to integrate some tests for it. will that be a good addition ?
16:40:47 <vikramdham_> that is good suggestion
16:41:03 <vikramdham_> would numan be able to help with that?
16:41:55 <trinaths> i think so. I will check what triple-o ovn tests are there. and test them. then we will move them to functest and add a job.
16:42:09 <vikramdham_> ok
16:42:10 <trinaths> if we need some additional help we can ask numans.
16:42:25 <vikramdham_> ok, good to keep him in loop so he is not surprised
16:42:46 <trinaths> +1
16:42:47 <vikramdham_> i will email tests once website comes up
16:42:51 <vikramdham_> http://testresults.opnfv.org
16:42:53 <trinaths> ok.
16:43:21 <vikramdham_> good for now lets stay in touch on email and irc for upcoming milestones
16:43:35 <vikramdham_> unless you have any other agenda we can call off the meeting
16:44:10 <trinaths> lets call off the meeting.
16:44:20 <trinaths> I have nothing to say
16:44:23 <vikramdham_> ok
16:44:27 <vikramdham_> #endmeeting