01:02:10 <trinaths1> #startmeeting ovn4nfv
01:02:10 <collabot> Meeting started Tue Oct 31 01:02:10 2017 UTC.  The chair is trinaths1. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:02:10 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:02:10 <collabot> The meeting name has been set to 'ovn4nfv'
01:03:06 <trinaths1> #chair trinaths
01:03:06 <collabot> Warning: Nick not in channel: trinaths
01:03:06 <collabot> Current chairs: trinaths trinaths1
01:06:20 <SridharP1> Hello
01:08:37 <trinaths1> Hi
01:09:27 <trinaths1> lets wait for virkram
01:10:53 <trinaths1> #chair trinaths vdham
01:10:53 <collabot> Current chairs: trinaths trinaths1 vdham
01:11:01 <trinaths1> #agenda https://wiki.opnfv.org/display/OV/Meeting+Agenda
01:11:23 <trinaths1> Project Roadmap and Release plan [1] for F Release[2].
01:11:31 <trinaths1> #topic Project Roadmap and Release plan [1] for F Release[2].
01:11:56 <trinaths1> Hi vdham SridharP1
01:12:10 <vdham> Hi Trinath and Sridhar
01:12:38 <vdham> I am not able to access the page, it seems password limited access
01:13:13 <trinaths1> vdham: oh! logged in !
01:13:41 <vdham> For f release suggest - a. We look at couple of new scenarios, investigate support in xci and work on sfc
01:14:32 <trinaths1> vdham: +1
01:15:09 <trinaths1> vdham: what is the procedure to get into xci ?
01:15:13 <vdham> For sfc suggest trinaths1 you may want to look at work done by john mcdowall
01:15:38 <SridharP1> Hi Vikram
01:16:01 <trinaths1> vdham: yes,
01:16:03 <trinaths1> #link http://openvswitch.org/support/ovscon2016/7/1400-fourie.pdf
01:16:11 <vdham> One option for xci would be to work with narinder gupta from canonical he has k8s scenario with ovn, might want to integrate it with xci
01:16:18 <vdham> Hi Sridharp1
01:16:33 <vdham> Yes same sfc deck
01:16:37 <trinaths1> vdham: guide me how do we implement SFC scenario into other installers,
01:17:07 <vdham> Might need to have sfc running in devstack with ovn first
01:17:41 <vdham> If it works use apex installer and work with Dan Radez
01:17:54 <trinaths1> vdham: fine, we will have OVN SFC tested with openstack-devstack
01:18:25 <trinaths1> then how we integrate with other installers.
01:18:38 <vdham> For f release i wouldnt advise committing anything more than couple of scenarios and sfc testbed
01:18:39 <trinaths1> this scenario for joid ?
01:18:47 <trinaths1> vdham: agree.
01:19:10 <vdham> K8s is in joid
01:19:13 <vdham> With ovn
01:19:23 <vdham> Narinder is your guy
01:19:43 <trinaths1> vdham: container-vnf and ovn sfc ?
01:19:58 <vdham> Sfc is seperate
01:20:06 <vdham> Scenario
01:20:13 <vdham> K8s is seperate for now
01:20:19 <trinaths1> vdham: agree.
01:20:21 <trinaths1> vdham: ok.
01:20:55 <trinaths1> vdham: then we dont add any new fucntionality/scenario to joid
01:20:57 <trinaths1> ?
01:21:06 <vdham> If dont want to do sfc in f other option would be to do vm and container hybrid scenario which only ovn can do
01:21:35 <vdham> Suggest commit very less
01:21:52 <vdham> - xci scenario
01:21:59 <trinaths1> vdham: we want to sfc.. since vCPE is a Edge NFV solution where SFC is important
01:22:28 <vdham> Would require looking at latest status of sfc on ovs thread
01:23:02 <trinaths1> vdham: agree. them, lets only propose OVN-SFC for now and have time, then propose hybrid scenarios.
01:23:42 <vdham> Want to take a day investigate sfc status before committing?
01:24:06 <vdham> Hybrid might be low hanging unique value addition
01:26:39 <trinaths1> yes, we need to investigate SFC.. but less time for me.. since sydney summit and preperations
01:26:52 <trinaths1> lets have hybrid scenario.
01:27:06 <trinaths1> if ovn-sfc works, can we update the release plan ?
01:27:15 <vdham> For hybrid might get help from container4nfv team as well
01:27:25 <vdham> Yes we can add sfx later
01:27:32 <trinaths1> ok
01:27:35 <vdham> Commit less minimal for now
01:27:44 <trinaths1> vdham: sure. +1
01:28:09 <vdham> So os and k8s scenarios in xci
01:28:23 <vdham> Talk with dan and narinder to scope
01:28:28 <trinaths1> vdham: ok
01:28:32 <vdham> Or if they plan to do it
01:28:48 <vdham> Secondly work on hybrid scenario vm plus container
01:28:55 <trinaths1> #action 1. OS and K8S scenarios in XCI - Dan and Narinder help required.
01:29:19 <vdham> +1
01:29:24 <trinaths1> #action 2. OVN fabric for Hybrid environment Container and VM
01:29:32 <vdham> Great
01:30:00 <trinaths1> #link https://wiki.opnfv.org/display/SWREL/OVN4NFV+Release+Plan+for+OPNFV+Euphrates
01:30:03 <vdham> Optional for marketing showcase edge scenario on arm
01:30:17 <vdham> Trivial edge scenario
01:30:51 <trinaths1> vdham: yes, after SFC is working.
01:30:57 <trinaths1> #link https://wiki.opnfv.org/display/SWREL/Fraser+Scenario+Status
01:31:23 <trinaths1> vdham:  I think we need to discuss with dan and Narinder for update of the scenario status
01:31:50 <trinaths1> #link https://wiki.opnfv.org/display/SWREL/OVN4NFV
01:32:13 <trinaths1> vdham: the above link os for projects F release plan
01:32:15 <vdham> They are generally available on irc if you ping them or else email
01:32:53 <trinaths1> vdham: I will ping them also will aks for their contact number (if they give)
01:33:11 <trinaths1> need convince narinder and dan to attend this meeting
01:34:05 <vdham> Ok
01:34:44 <trinaths1> ok. vdham please review this #link https://wiki.opnfv.org/display/SWREL/OVN4NFV
01:35:31 <trinaths1> vdham: OS and K8S scenarios in XCI - Dan and Narinder help required. - Do we need to move the existing scenarios to XCI ? fatih is the guy for xci
01:35:42 <vdham> Please sync with Srinivas for hybrid scenario and he can help ovn4nfv would suggest making him committer
01:36:02 <vdham> Yes Fatih can give pointers
01:36:06 <vdham> For xci
01:36:10 <trinaths1> vdham: srinivas ?
01:36:23 <vdham> From intel
01:36:28 <trinaths1> vdham: :)
01:36:49 <trinaths1> vdham: he is our x CTO , we worked in his team for 11 years..
01:37:03 <vdham> Ohhh :))
01:37:38 <trinaths1> i'm working for container4nfv for arm cpe scenrios.
01:37:51 <vdham> He should definitely be able to assign some intel resource for ivn4nfv
01:38:15 <vdham> Especially only ovn can support hybrid scenario
01:38:26 <trinaths1> he did not attend the meeting now. yes he can.. but intel platforms..
01:38:45 <trinaths1> vdham: I will ping him sometime today.
01:38:52 <vdham> Ok
01:40:27 <trinaths1> vdham please review this #link https://wiki.opnfv.org/display/SWREL/OVN4NFV
01:41:15 <trinaths1> I just used the data from E release.
01:41:25 <vdham> Ok
01:41:50 <trinaths1> do we need to give a detailed release plan for F release ?
01:42:10 <trinaths1> #link https://wiki.opnfv.org/display/SWREL/Suggested+Release+Plan+Template
01:42:12 <vdham> Let me check tonight and get back to you on it
01:42:22 <trinaths1> ok
01:42:25 <trinaths1> #topic Scenarios and Installer support [3].
01:42:49 <trinaths1> we agreed on Apex and JOID. with existing scenarios
01:43:04 <trinaths1> vdham: with hybrid in place, we get a new scenario ?
01:43:19 <vdham> Yes
01:44:17 <trinaths1> what can be new status name. ? also, to include the new status, we need to get Narinder and Dan approve it
01:44:51 <trinaths1> ??
01:45:17 <trinaths1> os-ovn-nofeature-ha => os-ovn-hybrid-ha
01:45:30 <trinaths1> K8-ovn-lb-noha => K8-ovn-lb-hybrid-noha
01:45:32 <vdham> Yes
01:46:26 <trinaths1> since we have very less time, (nov 3rd for proposals) lets have os-ovn-nofeature-ha and K8-ovn-lb-noha  have in place.
01:47:03 <trinaths1> in mean time lets talk to dan and narinder for these new scenarios. for this, we required OVN Containter and VM usecase tested and ready
01:47:10 <trinaths1> vdham:  comments ?
01:47:43 <vdham> Need to check if ovn is ha ready
01:48:10 <vdham> Believe ben had pushed patch for ha couple of mnths back
01:48:19 <trinaths1> vdham: ok.
01:48:41 <trinaths1> #action 3. Check OVN is HA ready. refer to Ben patches for HA in OVN
01:49:01 <trinaths1> #topic F release milestones
01:49:06 <trinaths1> #link https://wiki.opnfv.org/download/attachments/12390157/OPNFV%20Release%20%2522Fraser%2522%20r4.pdf?version=1&modificationDate=1508970501000&api=v2
01:50:23 <trinaths1> #info Nov - 3rd - Planning Complete and Deliverables defined
01:50:59 <trinaths1> #info Nov - 17th - Test cases documented in Testcases database
01:51:35 <trinaths1> vdham: for the above 17th dead line, do we need to post test scripts to functests
01:51:37 <trinaths1> ?
01:51:47 <vdham> Too close
01:51:56 <trinaths1> vdham: yes.
01:52:32 <trinaths1> #info Dec - 4th - Plugfest
01:52:46 <trinaths1> #info Dec - 15th - E 5.2
01:53:05 <vdham> Mnot going to plugfest
01:53:14 <vdham> Change of plan
01:53:53 <trinaths1> # info Feb'18 - 2nd - Integration with OpenStack
01:54:15 <trinaths1> vdham: oh! ok. no issues. is it mandatory that every project has to participate at plugfest ?
01:54:36 <vdham> No
01:54:51 <trinaths1> ok
01:55:02 <trinaths1> #topic E Release - Review.
01:55:25 <trinaths1> vdham: do we have any work for E release.
01:55:33 <trinaths1> i remember release notes
01:55:46 <vdham> Release notes and jira cleanup
01:55:55 <trinaths1> jira cleanup is done
01:55:59 <trinaths1> release notes is pending
01:56:25 <trinaths1> #action Complete E release notes - trinaths, vdham
01:56:33 <vdham> Ok
01:56:41 <trinaths1> vdham: for the above 17th dead line, do we need to post test scripts to functests
01:57:24 <vdham> Only docs
01:57:52 <trinaths1> vdham: please point me to E docs
01:58:03 <trinaths1> we have 3 minutes more.. !
01:59:05 <trinaths1> #topic OpenStack Summit – Sydney – Interesting talks for the Project.
01:59:15 <trinaths1> #link https://www.openstack.org/summit/sydney-2017/summit-schedule/events/20416/whats-new-with-ovs-and-ovn-2-8
01:59:23 <trinaths1> Ben is giving this talk.
01:59:33 <vdham> Nice
01:59:40 <trinaths1> I will try meet him for some tech talk
02:00:33 <trinaths1> thanks vdham, I will update the release plan and work on the action items.
02:00:50 <trinaths1> thanks vdham, SridharP1
02:00:50 <vdham> Ok thanks
02:00:58 <trinaths1> #endmeeting