16:31:31 <trinaths> #startmeeting ovn4nfv
16:31:31 <collabot`> Meeting started Tue Feb 27 16:31:31 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:31:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:31:31 <collabot`> The meeting name has been set to 'ovn4nfv'
16:33:50 <trinaths> Agenda #link https://wiki.opnfv.org/display/OV/Meeting+Agenda
16:33:57 <trinaths> Amir_M : Hi
16:34:16 <Amir_M> Hi Trinaths
16:34:22 <trinaths> while other team members join, lets discuss your project proposal
16:34:53 <Amir_M> Okay
16:35:58 <trinaths> have gone through the MS and action items
16:36:01 <trinaths> ?
16:36:14 <Amir_M> Currently I'm reading the list you have sent me on OVS&OVN, K8s, etc
16:36:20 <trinaths> ok.
16:36:42 <Amir_M> yes I did.
16:37:10 <trinaths> k8s0vn is developed for JOID installer by aakash
16:37:22 <trinaths> *k8s-ovn
16:37:45 <Amir_M> but as I expect that it will take me a while to get familiar with different tools/terminologies
16:37:54 <trinaths> there are two implementations in the project proposal.
16:38:54 <trinaths> 1. VM + CN - mixed environment
16:39:01 <trinaths> 2. VM + VM sfc with OVN
16:39:14 <trinaths> 2 one is with no-nsh support and single node.
16:39:27 <trinaths> hi salladi
16:39:41 <salladi> Hello trinaths
16:39:58 <trinaths> I think aakash may join late today.
16:40:07 <salladi> Sorry for joining in late..
16:40:24 <trinaths> we have new contributor Amir_M
16:40:47 <salladi> Hi Amir_M
16:41:04 <Amir_M> Hi Salladi
16:41:16 <trinaths> he come with good networking background. His interests include network automation, NFV and SDN
16:41:59 <trinaths> Amir_M - is pursing his Ph.D from Queens University, Canada
16:42:52 <salladi> okay
16:43:08 <trinaths> Amir_M - I feel to trim the proposal in view of cross project collaboration may take time.
16:43:29 <trinaths> wipe out MS 3 and 4 and give more time for MS 1 and 2.
16:43:44 <Amir_M> you mean the collaboration with Pharos project?
16:44:06 <trinaths> os-ovn-vmcn-sfc-noha – Single Node PoC
16:44:15 <trinaths> os-ovn-vmcn-sfc-noha – Test cases + UG
16:44:23 <trinaths> os-ovn-vmvm-sfc-noha – Single node – Fuel + UG
16:44:41 <Amir_M> Okay
16:45:23 <trinaths> the above tasks may take time. since with recent mail from Apex team to TSC, they have move mixed environment scenarios out for upcoming release.
16:45:35 <Amir_M> Just want to make it clear again, I'm working on getting deep understanding of different Lego bricks
16:45:55 <trinaths> lego bricks ?
16:45:59 <Amir_M> example, I was wondering what is the diff between OVN and other SDNCs
16:46:27 <trinaths> OVN is the implementation for native SDNC.
16:46:44 <Amir_M> by lego bricks I mean different pieces that make the full picture in any scenario
16:46:53 <trinaths> ok.
16:46:54 <trinaths> got it.
16:47:32 <trinaths> hi ak_dev_
16:47:39 <ak_dev_> Hello, sorry for joining in late, was busy with some research work
16:48:20 <ak_dev_> trinaths:  we are still stuck on the pod issue, I saw that you put a mail on the thread to Aric and Trevor
16:48:51 <trinaths> Amir_M - so I will re-phrase the plan and update you now. Also, please share with me the .doc copy of the document.
16:49:02 <trinaths> ak_dev_ yes.
16:49:20 <Amir_M> sure I will
16:50:13 <trinaths> Amir_M regarding doubts with OVN, please post them first in openstack-dev mailing list with [networking-ovn] in subject line. We are all there to help you.
16:50:30 <trinaths> ok. since all team is here, let start with agenda.
16:51:19 <trinaths> #topic Action items review
16:51:55 <trinaths> ak_dev_ I will put a mail to David again on this virtual POD requirement today. lets see how he responds.
16:52:15 <Amir_M> trinaths: I've already came across some web resources and old posts (2015) in the mailing list that discuss the same issue
16:52:24 <trinaths> salladi - I can share you a local VM for OVN development.
16:52:49 <trinaths> Amir_M - * same issue ?
16:53:08 <salladi> okay
16:53:18 <ak_dev_> trinaths: sure, or else we will have to start looking for some other solution, openstack is too huge to deploy on my machine also
16:53:29 <Amir_M> Trinaths: sorry, I mean the OVN vs ODL and other SDN-C's
16:54:01 <trinaths> Amir_M - ok. let me share you a detailed differential doc link for your understand on ODL and OVN
16:55:10 <Amir_M> Trinaths: you mean this doc #link https://docs.google.com/document/d/13K4Xpdu1IbRJDj5JTepDI4nwUkCDCu7IOnYwHkZtcMA/edit
16:56:30 <trinaths> ak_dev_ - mean time can you put some thoughts on - test support for k8s scenarios
16:56:44 <trinaths> ak_dev_  I just sent a mail I rcvd from david
16:57:00 <trinaths> Amir_M - yes
16:58:02 <trinaths> ak_dev_can you put a mail in opnfv-tech-discuss on functest and yardstick scenarios we need to consider for JOID k8s-ovn scenario.
16:58:54 <ak_dev_> trinaths: I do not have much experience with test scenarios
16:59:12 <trinaths> ak_dev_ lets put a mail and see how we proceed on.
16:59:57 <trinaths> #topic documentation review and readiness.
17:00:26 <ak_dev_> trinaths: just to be clear, put a mail regarding test support for JOID  in functest and yardstick right?
17:00:56 <trinaths> ak_dev_ can you put some effort on k8s-ovn and os-ovn JOID scenario documentation
17:01:23 <trinaths> ak_dev_ yes true said. Let me put that mail with david in CC
17:01:37 <trinaths> since Apex also have k8s-ovn and os-ovn scenarios.
17:01:48 <ak_dev_> trinaths: yes, I think thats better since I have not much clue about it
17:02:11 <trinaths> we can get clear response from redhat team on this.
17:02:47 <ak_dev_> trinaths: about the documentation, I will start up on it soon, but should we first complete os-ovn before writing documentation for it?
17:03:13 <trinaths> for k8s-ovn you can submit the doc.
17:03:30 <ak_dev_> trinaths: yes, i will start working on that
17:04:06 <ak_dev_> i will also look up on some functest and yardstick stuff so we can proceed in that direction
17:04:34 <trinaths> for os-ovn has a doc with - pending state. we can groom it while we get a vPOD.
17:05:06 <ak_dev_> okay sure
17:05:13 <trinaths> #action Amir_M - to send inter project proposal doc to include revised proposal and milestones.
17:05:32 <trinaths> #action ak_dev_ scenario documentation for JOID installer.
17:05:45 <Amir_M> Trinaths: I will directly after this meeting
17:05:47 <trinaths> #action trinaths scenario documentation for APEX installer.
17:07:06 <trinaths> that all from my end.
17:07:13 <trinaths> #topic open-discussion
17:07:35 <trinaths> if done with discussion, we can close the meeting.
17:07:45 <ak_dev_> trinaths: yes almost done
17:07:48 <ak_dev_> one side note
17:08:03 <ak_dev_> narinder once mentioned that we can deploy services as standalone in openstack
17:08:07 <ak_dev_> instead of the whole
17:08:26 <ak_dev_> i will look in to that, if its possible, we can do it on my machine till we can get a vPOD
17:08:27 <trinaths> ok. will that help us for JOID scenario progress
17:08:35 <trinaths> ak_dev_ +1
17:08:46 <trinaths> salladi Amir_M - you have some thing to discuss
17:09:14 <salladi> nothing from my side
17:09:23 <trinaths> Amir_M please share the document, I will revise and send the same to you. you need to send this revised proposal again to OPNFV for consideration
17:09:48 <Amir_M> Trinaths: nothing from my end. I will.
17:10:34 <trinaths> #action salladi - document OVN CN packet flow.
17:10:49 <trinaths> thank you for joining the weekly meeting.
17:10:59 <ak_dev_> thank you
17:11:05 <Amir_M> Trinaths: thank you
17:11:10 <salladi> thank you
17:11:15 <trinaths> #endmeeting