16:33:43 <trinaths> #startmeeting ovn4nfv
16:33:43 <collabot`> Meeting started Tue Mar 20 16:33:43 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:33:43 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:33:43 <collabot`> The meeting name has been set to 'ovn4nfv'
16:33:53 <trinaths> #chair trinaths
16:33:53 <collabot`> Current chairs: trinaths
16:34:08 <trinaths> Hi Amir_m ak_dev_
16:34:26 <trinaths> #topic Agenda
16:34:51 <trinaths> #link https://wiki.opnfv.org/display/OV/Meeting+Agenda
16:36:12 <trinaths> Hi Amir_m - Can you elaborate your weekly status.
16:36:38 <Amir_m> Server is up and running
16:36:51 <trinaths> Excellent
16:37:45 <trinaths> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=13210692
16:38:10 <trinaths> you were able to bring up OVN using Apex ?
16:38:16 <Amir_m> Currently I'm really confused about the way ahead, as I don't know the steps I'm supposed to follow to do the PoC
16:38:46 <Amir_m> I followed all the links in the last meeting but nothing was there regarding Apex
16:39:14 <Amir_m> I'd like to have a one-to-one meeting with you Trinaths
16:39:34 <trinaths> ok. Amir_m
16:39:56 <trinaths> when can we schedule that.
16:40:22 <Amir_m> I got to the OPNFV Apex project page #link   https://wiki.opnfv.org/display/apex/Apex
16:40:23 <trinaths> since we have 2 weeks completed, we need to send a detailed work status report to OPNFV.
16:40:45 <trinaths> Amir_m - follow the instructions from Apex E release and install Apex.
16:40:57 <trinaths> ak_dev_ you have something to add for Amir_m
16:41:08 <Amir_m> any time except for Thursday from 12:00 to 4:00
16:41:41 <Amir_m> Do you mean Apex for Euphrates ?
16:41:47 <ak_dev_> trinaths: nope, not much aware about apex
16:41:53 <ak_dev_> Amir_m:
16:41:54 <trinaths> ok
16:42:03 <trinaths> Amir_m yes
16:42:05 <trinaths> #link http://docs.opnfv.org/en/stable-danube/submodules/apex/docs/release/installation/index.html#apex-installation
16:43:02 <Amir_m> Trinaths: This is another issue, you are assuming me to know things simply because you know, but this is not the case here :(
16:43:22 <trinaths> Amir_m - can you put a mail regarding your doubts to opnfv-tech-discuss.
16:44:04 <Amir_m> Trinaths: I've already read all info in your this link
16:44:21 <trinaths> Amir_m - No, that is not the case, since you are not aware of these installer and scenarios, I want you to learn while you try it.
16:44:37 <trinaths> Amir_m please be assured, we are there to help you.
16:45:12 <Amir_m> I know, but I have to do my homework first, before asking trivial questions, right?
16:45:40 <trinaths> Amir_m also, you can mail Tim Rozet (trozet@redhat.com)  who is the PTL for Apex. He will be surely helping you.
16:45:56 <Amir_m> Trinaths: okay
16:46:03 <trinaths> Amir_m - I'm confused. Did I post any Trivial questions ?
16:47:12 <Amir_m> Trinaths: I mean me, I'm trying to do my homework before asking trivial questions, whose answer can be found
16:48:02 <trinaths> Amir_m okay. We need to make our hands dirty to learn and build projects here.. :)
16:49:05 <Amir_m> Trinaths: totally agree
16:49:57 <Amir_m> Trinaths: One final thing, do I need to enable nested virtualization on the server?
16:51:10 <trinaths> Amir_m [1] Try to install Apex.[2] Using Apex, bring up and configure the OpenStack OVN Environment. [3] Understand OVN [4] Spawn 2 VMs [5] Using the OVN-SFC documentation, make a Service path via 2 VMs. [6] Document the finding.
16:51:35 <trinaths> Amir_m - I dont think you required nested virtualization.
16:52:34 <trinaths> Amir_m Apex with do it for you.
16:53:17 <trinaths> Amir_m - During deployment the Apex installer will detect if nested KVM is enabled, and if not, it will attempt to enable it; while printing a warning message if it cannot. Check to make sure before deployment that Nested Virtualization is enabled in BIOS, and that the output of cat /sys/module/kvm_intel/parameters/nested returns “Y”. Also verify u
16:53:18 <trinaths> sing lsmod that the kvm_intel module is loaded for x86_64 machines, and kvm_amd is loaded for AMD64 machines.
16:53:35 <trinaths> #link http://docs.opnfv.org/en/stable-euphrates/submodules/apex/docs/release/installation/virtual.html
16:53:42 <Amir_m> Trinaths: Install Apex using this #link https://wiki.opnfv.org/display/apex/Integration+Guide
16:53:52 <trinaths> yes.
16:54:06 <Amir_m> okay
16:54:10 <trinaths> Amir_m its Integration guide. Its our next level
16:54:38 <trinaths> Amir_m http://docs.opnfv.org/en/stable-danube/submodules/apex/docs/release/installation/virtualinstall.html#installation-guide-virtual-deployment
16:54:40 <trinaths> #link http://docs.opnfv.org/en/stable-danube/submodules/apex/docs/release/installation/virtualinstall.html#installation-guide-virtual-deployment
16:56:51 <trinaths> Amir_m - Have any doubts - please shoot via Email. I and Apex team will help you
16:57:11 <trinaths> #toipc JOID - os-ovn scenario support.
16:57:13 <Amir_m> Trinaths Ok
16:57:50 <trinaths> Amir_m - Please expedite the work to reach our goals.
16:57:54 <trinaths> ak_dev_ - Hi
16:58:09 <trinaths> ak_dev_ can you elaborate your weekly status
16:59:24 <ak_dev_> trinaths: hi
16:59:47 <ak_dev_> yeah, so the charm spec got merged in to the master branch
17:00:04 <ak_dev_> #link https://review.openstack.org/551800
17:00:48 <ak_dev_> waiting on james's reply to begin work
17:00:52 <trinaths> ak_dev_ so next task
17:01:03 <trinaths> ak_dev_ find him now at charms IRC
17:01:17 <trinaths> ak_dev_ may be he will be available now.
17:01:28 <ak_dev_> right now I am involved with something else, but yeah i will check in some time
17:01:51 <trinaths> ak_dev_ - Due to James Time Zone, he will be available now.
17:02:14 <ak_dev_> according to me, the making the charm should not take more than two weeks, but I want to know what James estimates
17:02:26 <ak_dev_> trinaths: yeah
17:02:57 <ak_dev_> do you want me to put the charm spec under ovn4nfv too?
17:03:45 <trinaths> no.
17:04:08 <ak_dev_> trinaths: okay
17:04:20 <trinaths> ak_dev_ - openstack-charms devs may take time to review the code to be merged.
17:04:37 <trinaths> ak_dev_ also, I think your k8s-ovn is not into openstack-charms repo. correct ?
17:04:48 <ak_dev_> trinaths: yeah true
17:04:57 <ak_dev_> trinaths: no it isnt, it was developed independently
17:05:07 <trinaths> #action Amir_m - Install Apex , run and understand OVN.
17:05:35 <trinaths> ak_dev_ - I recommend it also have a spec in openstack-charms and move the code for review.
17:05:53 <trinaths> ak_dev_ that way the code is official into openstack-charms
17:06:01 <ak_dev_> trinaths: i think k8s-ovn wont fit in openstack charms, since its openstack only charms right?
17:06:17 <ak_dev_> and this is Kubernetes, maybe we should talk to the Kubernetes team?
17:06:24 <trinaths> ak_dev_ agree. Can you put this question to James.
17:07:18 <ak_dev_> trinaths: I dont think it will be good to ask him, since its OpenStack, and we would be suggesting putting k8s stuff there, may not look good
17:08:05 <ak_dev_> trinaths: if not that, we can probably host the k8s-ovn repo in ovn4nfv?
17:08:55 <trinaths> that also looks good.
17:10:36 <ak_dev_> directory structure
17:10:53 <ak_dev_> ovn4nfv/code/JOID/charm-k8s-ovn
17:11:04 <ak_dev_> does this look fine? I will push code for review then
17:11:16 <trinaths> perfect.
17:12:18 <trinaths> my weekly status, - I was on vacation and office work for the week. This week I take up the docs review task.
17:12:41 <trinaths> regarding Mile-stone 6 - We have Test cases working/passing for Apex, Joid and Fuel installers.
17:13:01 <trinaths> MS-6 Also, we have Initial F release documentation in place.
17:13:45 <ak_dev_> trinaths: cool, I will start adding documentation for os-ovn too on the go
17:15:10 <trinaths> ak_dev_ ok.
17:15:52 <trinaths> #topic Open Discussion
17:16:15 <ak_dev_> just a general question, is the venue / date for OPNFV summit in summer decided?
17:19:18 <trinaths> #action - ak_dev_ - to submit k8s-ovn code and work on os-ovn charms
17:19:36 <trinaths> ak_dev_ - there will not be any special OPNFV summits,
17:19:52 <trinaths> ak_dev_ all LF summits are merged to OpenNetworkingSummir 2018
17:19:52 <ak_dev_> trinaths:  oh i was not aware
17:20:27 <trinaths> yes
17:20:37 <ak_dev_> trinaths: oh, los angeles this time
17:20:46 <ak_dev_> thats great
17:22:04 <trinaths> yes
17:22:34 <trinaths> I have a paper selected. and a local employee is giving the session
17:22:45 <trinaths> https://onsna18.sched.com/event/Dm4M/creating-a-safer-smart-ride-nfv-for-automotive-steven-furr-trinath-somanchi-nxp
17:23:30 <ak_dev_> trinaths: oh wow, congrats !!!
17:24:05 <ak_dev_> so you wont be going? I have a wish to go, but I dont think LF will call me for the summit this time
17:25:25 <trinaths> ok
17:25:35 <trinaths> guy time we have 5 more mins
17:25:57 <ak_dev_> yeah, I am done, I was just asking random stuff
17:26:01 <ak_dev_> thank you for the meeting
17:26:05 <Amir_m> Nothing from my end, thanks
17:28:09 <trinaths> #endmeeting